Subject: [pim] I-D ACTION:draft-ietf-pim-mib-v2-02.txt

From: [email-masked]
Date: Fri, 29 Apr 2005 15:50:45 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Protocol Independent Multicast Working Group of the IETF.

	Title		: Protocol Independent Multicast MIB
	Author(s)	: J. Lingard, et al.
	Filename	: draft-ietf-pim-mib-v2-02.txt
	Pages		: 43
	Date		: 2005-4-29
	
This memo defines a portion of the Management Information Base (MIB)
   for use with network management protocols in the Internet community.
   In particular, it describes managed objects used for managing the
   Protocol Independent Multicast (PIM) protocols (PIM-SM and BIDIR-
   PIM).  This document obsoletes RFC 2934.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pim-mib-v2-02.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-pim-mib-v2-02.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-pim-mib-v2-02.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "James Lingard" <[email-masked]>
Date: Sat, 30 Apr 2005 14:22:52 +0100

We've just submitted a new revision of the PIM MIB I-D, the first in over two years.

The new PIM MIB is a complete rewrite of the previous version of the MIB (both from RFC 2934 and from earlier revisions of this I-D).  The changes are too extensive for me to list them all here, but the main changes are as follows.

o  Address family independence (that is, the new MIB supports IPv4 and IPv6 through the use of InetAddres objects).
o  Support for managing BIDIR-PIM.
o  Removal of support for managing PIM-DM (since PIM-DM is not on the Standards Track).
o  Removal of support for managing PIM-SM v1.
o  Removal of the dependency on the IPv4 Multicast Routing MIB [RFC 2932].
o  Addition of a Neighbor Secondary Address table.
o  Addition of lots of useful information to the Interface and Neighbor tables.

This I-D is very much a snapshot of our work in progress, and there are many outstanding issues to resolve and things still to do.  The main outstanding issues include:

o  Whether or not we should keep the existing structure of MRoute and MRouteNextHop tables, or whether we should replace them with tables that more closely mirror the protocol state model from the PIM-SM and BIDIR-PIM drafts.

o  Whether or not to support multiple domains and/or scope-zones, and if so, how to support them.

We would very much appreciate feedback on the new MIB, particularly from people with operational experience who could let us know if the MIB meets their requirements for configuring and managing PIM routers, and if not, how we could improve it to be more useful.  We'd also be grateful for input on the above two unresolved issues.

Please send your comments to the PIM-MIB mailing list [[email-masked]].  And if you'd like to get involved further, please come and join the discussions on that mailing list.  You can subscribe from:

http://www.mountain2sea.com/mailman/listinfo/pim-mib

Regards,
James, Raghava and Bharat.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: 29 April 2005 20:51
To: [email-masked]
Cc: [email-masked]
Subject: [pim] I-D ACTION:draft-ietf-pim-mib-v2-02.txt

	

Send a message to:
	[email-masked].
In the body type: