Subject: [pim] Comment regarding: draft-ietf-pim-sm-v2-new-11

From: James Courtier-Dutton <[email-masked]>
Date: Fri, 8 Apr 2005 13:47:38 +0100

We have 4 types of Prune message:
Prune (*,*,RP)
Prune (*,G)
Prune (S,G,rpt)
Prune (S,G)
but, we only seem to have 3 types of Prune-Echo messages:
Prune-Echo (*,*,RP)
Prune-Echo (*,G)
Prune-Echo (S,G)

Is there supposed to be one for the "Prune (S,G,rpt)". If not, I think
it would be wise to add a small comment explaining they not into the
RFC.

On another point, could someone explain to me what external event
would cause a PIM-SM router to send a Join (*,*,RP)?
IGMPv3 messages will cause Join (*,G) and Join (S,G) messages, but I
can't see any IGMPv3 that would generate Join (*,*,RP)

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "James Lingard" <[email-masked]>
Date: Fri, 8 Apr 2005 14:02:31 +0100

Hi James,

Your question on Prune-Echoes is an interesting one, and one I had been thinking about myself only a few days ago.  I can't see any good reason for their absence, and I too would be interested to know if there's a good reason they are missing.  Would any of the authors like to comment?

As for the Join (*,*,RP) signals, the answer is in section 11 of the document.  In brief, the idea is that they are generated at routers on the border between a sparse-mode and a dense-mode domain, and therefore the "external event" is likely to be direct configuration of the router.  However, be aware that many PIM implementations do not support (*,*,RP) Join/Prune signals.

Regards,
James.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 08 April 2005 13:48
To: [email-masked]
Subject: [pim] Comment regarding: draft-ietf-pim-sm-v2-new-11

-- 
James Lingard
Data Connection Ltd (DCL)
http://www.dataconnection.com/