Subject: [pim] *, G processing when router has no RP info

From: Prashant Jhingran <[email-masked]>
Date: Tue, 31 May 2005 12:59:38 +0530

Hi All,
Would like to know whether anyone has implemented the below mentioned
section of the draft ?

To me implementing the same means inviting trouble e.g. *,G Join storms and
thus the creation of redundant *,G entries [atleast for a while].

**************************
4.5.2.  Receiving (*,G) Join/Prune Messages

....If a router has no RP information (e.g. has not recently received a BSR
message) then it may choose to accept Join(*,G) or Prune(*,G) and treat the
RP in the message as RP(G).
**************************
Regards,
Prashant Jhingran
Huawei Technologies,
Bangalore, India.
Mobile#00-91-9886321570

Sound when stretched is MUSIC,
Movement when stretched is DANCE,
Life when stretched is CELEBRATION....
- Sri Sri Ravi Shankar
www.artofliving.org

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Shankar Vasudevan <[email-masked]>
Date: Tue, 31 May 2005 07:12:41 -0400

Hi Prashant,

   To my knowledge most of the implementations do this. This helps in 
faster building up of trees. so that the BSR / auto-rp
convergence doesnot impact the setting up of the trees.

   I dont understand what you mean by (*,G) join sorms. .. can you 
expand your concern ?

regards,
Shankar

---

From: Prashant Jhingran <[email-masked]>
Date: Tue, 31 May 2005 17:12:25 +0530

Hi Shankar,

My concern is how (and how safe it is) to trust the RP address present in a
*,G Join/Prune message [when a router has no RP(G)].

For fast convergence I feel its enough if the router keeps track of *,G Join
message [by maintaining a pending list and keep looking for RP in each BSM
etc] and create an *,G entry the moment it learns RP(G).

By *,G Storms, I meant what if someone (host/router) maliciously keeps
sending large number of *,G Joins [deliberately groups for which there is no
RP information in the domain]. Is it safe to trust the RP address (and thus
create entries) present in a *,G Join/Prune message [when a router has no
RP(G)]?

Regards,
Prashant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Shankar Vasudevan
Sent: Tuesday, May 31, 2005 4:43 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [pim] *, G processing when router has no RP info

Hi Prashant,

   To my knowledge most of the implementations do this. This helps in 
faster building up of trees. so that the BSR / auto-rp convergence doesnot
impact the setting up of the trees.

regards,
Shankar

Prashant Jhingran wrote:

>To me implementing the same means inviting trouble e.g. *,G Join storms 
>and thus the creation of redundant *,G entries [atleast for a while].
>