Subject: [pim] Multicast Interface Mode versus Group Mode

From: Ian <[email-masked]>
Date: Tue, 31 May 2005 14:57:15 +0000

Hello,

In some implementations the (*,G) group entry will be dense mode if there is no
RP for that group. However, if the interface is configured as sparse-mode, does
this mean that traffic is not forwarded by this router (i.e. a dense group but
sparse interfaces)?

I am struggling to understand the relationship of the (*,G) group and the
interface mode (i.e. sparse of dense), so if anyone can explain the bigger
picture of this it would be appreciated.

Regards,
Ian

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 31 May 2005 09:47:11 -0700

On Tue, May 31, 2005 at 02:57:15PM +0000, Ian wrote:
> Hello,
> 
> In some implementations the (*,G) group entry will be dense mode if there
> is no RP for that group. However, if the interface is configured as
> sparse-mode, does this mean that traffic is not forwarded by this router
> (i.e. a dense group but sparse interfaces)?
> 

Are you interested to operate a particular router or to implement
something ? Interface mode is purely a (historic) implementation choice
on certain platforms.

In Cisco IOS:
  - "ip pim sparse-mode" for dense mode groups inhibits flooding of
    traffic for these groups because of PIM neighbors.
  - "ip pim dense-mode" for sparse mode groups causes sparse/dense
    border functionality allowing sparse mode groups to connect to a
    dense mode domain.

Cheers
	Toerless