Subject: RE: [pim] [PIM-BIDIR]: upstream forwarding using only RPA state ?

From: "Srikanth Rao" <[email-masked]>
Date: Wed, 4 May 2005 09:46:24 -0700

Pavlin,

My question is about the timing of G1 to RP set mapping.
For such a match to happen router should know about G1, without
receiving (*,G1) join or sampling data, how do you know upfront
if G1 maps to RPA1 or RPA2..in the RPA SET ?

Srikanth

-----Original Message-----
From: Pavlin Radoslavov [mailto:[email-masked]]
Sent: Wednesday, May 04, 2005 3:57 AM
To: Srikanth Rao
Cc: [email-masked]
Subject: Re: [pim] [PIM-BIDIR]: upstream forwarding using only RPA state
? 

> In section 3.3.2 on source only branches of the draft (pim-bidir-07), it =
> mentions that=20
> upstream forwarding can happen "only on RPA state". This may not work =
> when there=20
> are multiple RPs of the same priority in the RP-set announced by a =
> PIM-BSR, for=20
> the same multicast group range. Some of the vendors are sampling data to =
> do
> upstream forwarding., but the question is can you make it data event =
> independent ?
> 
> For instance, consider a first hop router attached to a sender only =
> branch where
> a group range GR-1 is served by RP1 & RP2 with RPF interfaces to RP1 and =
> RP2=20
> being different (from the MRIB). A multicast group G1 in the range GR-1 =
> may either=20
> map to RP1 or RP2 depending on the hash function. In this scenario, if =
> router sees=20
> traffic for G1 on the sender-only branch that it has to upstream forward =
> towards RP,=20
> then will it forward towards RP1 or RP2 ?
> =20
> Actually this problem is not limited to sender-only branch, it can =
> happen on
> any intermediate router where it hasn't learnt the group apriori.
> 
> If this has been already discussed, please point me to the outcome.

I may be misunderstanding your question, but is a problem to have
multiple RPs with the same priority in the same group range?

If all Bidir-PIM routers have the same RP-Set, then by definition
all of them will match group G1 to the same RP (say, RP1 in your
example).
The DF election per Cand-RP should have happened in advance (when
the Cand-RP set was propagated), hence there is no ambiguity where
to forward the data packets on source-only branches: toward the DF
for RP1.

Regards,
Pavlin

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Pavlin Radoslavov <[email-masked]>
Date: Wed, 04 May 2005 11:37:47 -0700

> if G1 maps to RPA1 or RPA2..in the RPA SET ?

If you know the group address G, then you apply the group-to-RP
mapping to find the RPA.

If I understand you correctly, you want to install in advance the
forwarding entries toward the RPs for source-only branches so you
don't have to calculate on the fly the G-to-RPA mapping for the
first packet from the source.

I am afraid you cannot do this if (as you noted in your previous
email) there is more than one Cand-RP (with the same RP priority)
per group prefix.

For such group prefix you would have to lookup on-the-fly the first
packet for each new group against the Cand-RP set for that
particular group prefix, and only after that you apply the Bidir
forwarding rules (e.g., on sender-only branches you forward on
RPF_interface(RPA(G)) if you are the DF).

On the other hand, if a  group prefix has a single Cand-RP you can
install in advance a single forwarding entry that can be used for
sender-only branches for that group prefix. Note that if you are 
careful how you implement this in your forwarding path (e.g., you
may need longest-prefix match for group prefixes), you can install
such entries even if they overlap with group prefixes that have
multiple Cand-RPs. This is possible because the group-to-RP mapping
algorithm performs first the longest match on group ranges.

Regards,
Pavlin