Subject: RE: [pim] ID update for "Anycast-RP using PIM"

From: "James Lingard" <[email-masked]>
Date: Thu, 12 May 2005 20:23:53 +0100

My vote is to remove caching from the spec.  I think it's currently under-specified, and suffers from various (at least potential) problems, as Amit has already pointed out.

James.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Tom
Pusateri
Sent: 12 May 2005 20:15
To: Dino Farinacci
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [pim] ID update for "Anycast-RP using PIM" 

In message <[email-masked]> you write:
>>> I don't think we should allow supression of register-stop messages.
>>> An implementation cannot reliably do register stop caching if 
>>> suppression is allowed. If you feel we must allow suppression, then 
>>> I would ask that caching be complety removed from the spec.
>
>    But are stated as MAYs which means it doesn't have to be implemented. The
>    two implementations I know of do not.

Dino,
	I think you missed the point.  An RP that would like to do
	register-stop caching cannot do it if one or more of its
	anycast RP's do supression.

	Therefore, we must decide now if we are going to allow
	caching. If so, we MUST require a mandatory knob to
	disable supression or just not allow it at all.

	If you are going to allow implementations to always do supression
	then there is no reason to mention caching in the spec.

	So we either need to add something to the spec or take something out.

Thanks,
Tom

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Amit Shukla" <[email-masked]>
Date: Thu, 12 May 2005 12:35:06 -0700

I think it`s better to remove caching from the spec otherwise
more details should be added.
-Amit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
James Lingard
Sent: Thursday, May 12, 2005 12:24 PM
To: Tom Pusateri; Dino Farinacci
Cc: [email-masked]; [email-masked]
Subject: RE: [pim] ID update for "Anycast-RP using PIM" 

James.

-----Original Message-----

Dino,

Thanks,
Tom

---

From: "Amit Shukla" <[email-masked]>
Date: Mon, 16 May 2005 01:19:26 -0700

>> I was raising a different issue, where inconsistently configured
anycast-RP
>> sets could result in loop. Spec currently recommends copying the TTL
>> from a register message to the register messages it copies and send
to 
>> other RPs. I understand that copying the TTL does terminate any loop 
>> started by mis-configuration. My question/suggestion was that why
can`t 
>> we reserve a bit in register message, which is set to 1 when RP is
copying 
>> and sending register to other anycast-RP`s. Doing this will not let
any loop 
>> start at first place and any mis-configuration can be easily
detected. 

[Dino] Why do we need to make another change to the spec? TTL is
sufficient in
[Dino] the rare cases of misconfigurations (yes, misconfigurations
happen but
[Dino] people do want their networks to work).

Misconfiguration may be rare event, only reason i brought up this 
issue to explore if there`s a better solution than TTL copying without 
adding any complexity.

-Amit