Subject: [pim] Multicast using MBGP

From: "Arut Selvan" <[email-masked]>
Date: Mon, 30 Jan 2006 08:46:02 -0500

Hi,

I would like to know why MBGP is used for multicast ?
I came across some document which says that it is used for RPF checks
and
MP_REACH_NLRI is being used to carry that info, but I would like to
know why
the regular BGP cannot be used for this purpose. I know that MBGP is
not a
multicast routing protocol, but would like to clarify its role in
multicasting.

Is it used in conjunction with BGMP ? If yes, please clarify.

Thanks,
asm

-- 
___________________________________________________
Play 100s of games for FREE! http://games.mail.com/

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Jonathan Natale" <[email-masked]>
Date: Mon, 30 Jan 2006 11:16:10 -0500

MBGP is used so your multicast traffic can take a different path than your
unicast traffic.

Regular bgp *can* be used, check out
http://www.nanog.org/mtg-0306/pdf/mcbride.ppt (slide 7),
this explains it well.

BGMP??? *I think* this is defunct.  But in RFC3913:
"Bidirectional forwarding state means that packets received from any target
are
forwarded to all other targets in the target list without any RPF checks".
So based on this:
No, it is not used in conjunction with BGMP.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Arut
Selvan
Sent: Monday, January 30, 2006 8:46 AM
To: [email-masked]
Subject: [pim] Multicast using MBGP

Hi,

Thanks,
asm

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 30 Jan 2006 11:41:45 -0500

Hello;

MBGP is used primarily  for interdomain multicast, so that you can
have different AS paths for multicast and unicast.

>From RFC 2858

To provide backward compatibility, as well as to simplify introduction
of the multiprotocol capabilities into BGP-4 this document uses two
new attributes, Multiprotocol Reachable NLRI (MP_REACH_NLRI), and
Multiprotocol Unreachable NLRI
(MP_UNREACH_NLRI). The first one (MP_REACH_NLRI) is used to carry the
set of reachable destinations together with the next hop information
to be used for forwarding to these destinations. The second one
(MP_UNREACH_NLRI) is used to carry the set of unreachable
destinations. Both of these attributes are optional and non-
transitive. This way a BGP speaker that doesn't support the
multiprotocol capabilities will just ignore the information carried in
these attributes, and will not pass it to other BGP speakers.

So, you need the MBGP extensions to do this. PIM-SM actually does the routing.

> Is it used in conjunction with BGMP ? If yes, please clarify.

BGMP is AFAIK not deployed and is basically dead.

Regards
Marshall

---

From: John Zwiebel <[email-masked]>
Date: Mon, 30 Jan 2006 09:55:21 -0800

> I would like to know why MBGP is used for multicast ?

FWIW:
MBGP started out meaning "multicast" BGP, but is now "Multiprotocol" BGP
since it (BGP) is now used for many different address families.

2cents.

---

From: Beau Williamson <[email-masked]>
Date: Mon, 30 Jan 2006 12:19:14 -0600

>since it (BGP) is now used for many different address families.

Actually, it's the other way around.  It started as Multiprotocol BGP in 
the IETF.  It's just that the first instance of use for something besides 
IPv4 Unicast was IPv4 Multicast.

Some vendors actually began to refer to their implementation of this first 
IPv4 Multicast NLRI support over Multiprotocol BGP as "Multicast BGP" and 
even used the term "mbgp" to mean just that in their CLI.  Since that time 
they've had to adopt other CLI syntax due to the double meaning of the term.

Beau Williamson

---

From: Pekka Savola <[email-masked]>
Date: Tue, 31 Jan 2006 08:00:43 +0200 (EET)

> I would like to know why MBGP is used for multicast ?

Answers to these kinds of issues can be found at:

http://tools.ietf.org/wg/mboned/draft-ietf-mboned-routingarch

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings