Subject: RE: [pim] Are there any freeware tools which support IGMPv3 host stack

From: "fei wang" <[email-masked]>
Date: Tue, 3 Jan 2006 18:13:24 +0800

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 2005年11月22日 13:23
To: [email-masked]
Subject: [pim] Are there any freeware tools which support IGMPv3 host stack

Hello, 

Are there any freeware tools that run the IGMPv3 host stack (sending

INCLUDE and EXCLUDE membership reports) which can be used for testing

IGMPv3 querier state machine. 

VLC (video lan client) is one such freeware tool with supports v3 host

stack. VLC generates INCLUDE reports when configured to listen to

traffic only from certain selected sources. Is there is a way to

configure VLC to EXCLUDE traffic from certain sources. 

[fei wang] I captured the IGMP packet by executing the ‘vlc udp:[email-masked]’ command on XP.

It seemed that the VLC only send IGMPv3 Packet with Record Type 5 (Allow new Source) other than type 1. And when I stop the multicasting by clicking the ‘Stop’ button on the panel, the Type 6 (Block Old Sources) message was sent.

I think a special tool to simulate all type of IGMPv3 message was badly needed.

Cisco 12.4 seems to support v3 host stack. The command to send

membership reports with INCLUDE records seems fairly simple. Cisco

supports "join igmp X1.X2.X3.X4 source Y1.Y2.Y3.Y4". How do we get the

Cisco box to send reports with EXCLUDE records.

Thanks,

Sowmya

_______________________________________________

pim mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/pim

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Tue, 3 Jan 2006 14:17:20 +0100

> configure VLC to EXCLUDE traffic from certain sources. 

See the attached source for a tool called mctest that I wrote. All it
does, is join a list of sources for a group (INCLUDE), or join a group
and exclude a number of sources. You can then look at the IGMP reports
sent by the system.

Stig