Subject: [pim] Question about PIM Trap pimNeighborLoss

From: "Xiangrong Cai" <[email-masked]>
Date: Wed, 26 Apr 2006 18:32:24 -0400

In PIM MIB RFC2934, PIM Traps section, there is this pimNeighborLoss trap:

======================================================
-- PIM Traps   

pimNeighborLoss NOTIFICATION-TYPE
    OBJECTS {
       pimNeighborIfIndex
    }
    STATUS             current
    DESCRIPTION
            "A pimNeighborLoss trap signifies the loss of an adjacency
            with a neighbor.  This trap should be generated when the
            neighbor timer expires, and the router has no other
            neighbors on the same interface with a lower IP address than
            itself."
    ::= { pimTraps 1 }
=======================================================

Can somebody tell me why this trap needs to be raised? From the text, it 
seems to me that if I have the lowest ip (either because I had and still 
have or because the dead one is the only one that had lower ip than I 
do), and I detected a neighbor loss, then I should raise this trap. Why 
this way? To me the only place that deal with neighbor IP address in PIM 
is DR election, but DR election involves with Priority also, and if 
priority is the same, the highest ip, not the lowest ip, becomes the new DR.

Thanks.

-- Karl

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Raghava Sivaramu" <[email-masked]>
Date: Sat, 29 Apr 2006 12:25:03 -0700

> -----Original Message-----
> From: Xiangrong Cai [mailto:[email-masked]] 
> Sent: Wednesday, April 26, 2006 3:32 PM
> To: [email-masked]
> Subject: [pim] Question about PIM Trap pimNeighborLoss 
> 
> Can somebody tell me why this trap needs to be raised? From 
> the text, it seems to me that if I have the lowest ip (either 
> because I had and still have or because the dead one is the 
> only one that had lower ip than I do), and I detected a 
> neighbor loss, then I should raise this trap. Why this way? 
> To me the only place that deal with neighbor IP address in 
> PIM is DR election, but DR election involves with Priority 
> also, and if priority is the same, the highest ip, not the 
> lowest ip, becomes the new DR.
> 

AFAIK, the idea behind the trap is just to track a neighbor-loss event, and
to have only one router generate the trap (one with lowest-ip). It has
nothing to do with DR election.

raghava