Subject: [pim] Question about Assert Cancel

From: 황선영 <[email-masked]>
Date: Thu, 18 May 2006 19:19:22 +0900

Hello all,

I have a question about sending assert cancel.

                 Source
                   |
                  R1 (Upstream)
                   |
                   |
      +------- Network 1-------+
      |                        |
      |                        |
     DUT                      R2 
(Current (S,G)AssertWinner)    |
      |                        |
      +------- Network 2-------+
      |                        |
  receiver1                 receiver2

In this circumstance,
If R1 pim-sm is disabled, then DUT have to send assert cancel message to Network 2?

Please let me know.

Thank you in advance.
Sunyoung, Hwang.

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "Rajgopalan R S" <[email-masked]>
Date: Tue, 23 May 2006 17:19:36 -0700

*Hi,*
**
*   The assert state machine handles this scenario in a different way. When
pim is disabled on the interface a Hello with a holdtime of zero is sent on
that interface. When the Assert Loser finds that the neighbor liveness of
the current winner is off, the assert state is deleted and the assert
loser moves into the NO-INFO state. This is explained in the draft in
section 4.6.1 which I have pasted below for your reference*
**
*

Current Winner's GenID Changes or NLT Expires
*

The Neighbor Liveness Timer associated with the current winner expires or we
receive

a Hello message from the current winner reporting a different GenID from the
one it

previously reported. This indicates that the current winner's interface or
router has

gone down (and may have come back up), and so we must assume it no longer
knows

it was the winner. We transition to the NoInfo state, deleting this (S,G)
assert

information (action A5 below).

A5:

Delete assert info (AssertWinner(S,G,I) and AssertWinnerMetric(S,G,I) will
then

return their default values).

Best Regards,

Rajgopalan

   - *To*: pim at ietf.org <[email-masked]>
   - *Subject*: [pim] Question about Assert Cancel
   - *From*: 황선영 <syhwang at samsung.com <[email-masked]>>
   - *Date*: Thu, 18 May 2006 19:19:22 +0900
   - *List-help*:
<mailto:[email-masked]?subject=help<[email-masked]?subject=help>>

   - *List-id*: Protocol Independent Multicast <pim.ietf.org>
   - *List-post*: <mailto:[email-masked] <[email-masked]>>
   - *List-subscribe*: <https://www1.ietf.org/mailman/listinfo/pim>, <
   mailto:[email-masked]?subject=subscribe<[email-masked]?subject=subscribe>>

   - *List-unsubscribe*: <https://www1.ietf.org/mailman/listinfo/pim>, <
   mailto:[email-masked]?subject=unsubscribe<[email-masked]?subject=unsubscribe>>

------------------------------
   Hello all,

                 Source
                   |
                  R1 (Upstream)
                   |
                   |

In this circumstance,
If R1 pim-sm is disabled, then DUT have to send assert cancel message to
Network 2?

Please let me know.

Thank you in advance.
Sunyoung, Hwang.

_______________________________________________
pim mailing list
pim at ietf.orghttps://www1.ietf.org/mailman/listinfo/pim
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim