Subject: [pim] PIM BSR semantic fragementation.

From: "Gan" <[email-masked]>
Date: 12 May 2006 04:52:48 -0000

Hi,

I have couple of questions regarding BSR semantic fragmentation. 

1. Suppose if the BSR packet is divided into 5 fragments and sent, how does the receiving router know that the end of the packet is reached. Is there any field in the BSR fragment which states the end of fragment is received.

2. And once the BSR is received, what is the receiving router supposed to do. Should it wait till all the fragements are recieved and then it should multicast the bootstrap message. or it can just keep mcasting the fragements as and when they are received.

3. Do any of you have issues with respect to implementing the BSR semantic fragementation. 

Regards,
-G

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: Stig Venaas <[email-masked]>
Date: Sun, 14 May 2006 11:55:24 +0200

Gan wrote:
> 1. Suppose if the BSR packet is divided into 5 fragments and sent, how 
> does the receiving router know that the end of the packet is reached. Is 
> there any field in the BSR fragment which states the end of fragment is 
> received.

There is no way to know that you've received all fragments (apart from 
possibly seeing a new fragment tag), but you don't need to.
> 
> 2. And once the BSR is received, what is the receiving router supposed 
> to do. Should it wait till all the fragements are recieved and then it 
> should multicast the bootstrap message. or it can just keep mcasting the 
> fragements as and when they are received.

I think they should be multicasted/forwarded as soon as they are received.

> 3. Do any of you have issues with respect to implementing the BSR 

When using the contents of the BSMs, I would not worry about receiving 
all fragments of the BSM, but receiving complete group ranges. By 
looking at the rp-count field, you know when you have a complete group 
range. As soon as you do, you can then use the content to update your 
RP-set. You should IMO not try to wait and see if more fragments come along.

Stig

> 
> Regards,
> -G
> 
> 
> 
> <http://adworks.rediff.com/cgi-bin/AdWorks/sigclick.cgi/www.rediff.com/signature-home.htm/1507191490@Middle5?PARTNER=3> 
> 
> 
> 
> ------------------------------------------------------------------------
>