Subject: [pim] CRP message processing, Priority down to Group prefix level?

From: "Rajesh Nataraja" <[email-masked]>
Date: Fri, 19 Jan 2007 17:10:38 -0800

Hi,

I had a question in CRP message processing.

If a CRP does not advertise a particular group prefix in a message,
Should the BSR treat that Group prefix as not configured for the CRP any
more and then adjust its BSR message to accomodate the removal of the group
prefix immediately?
or
Should it courteously wait until the Group prefix, which could be started
for the hold time the CRP advertised before, expire and then adjust its BSR
message?

Why Iam asking this is to see if it is legal to advertise group prefixes for
a CRP with granularity for the priority down to a group prefix level.
I have seen this in one of the implementations.

Thanks
Rajesh.

On 1/19/07, Rishabh Parekh <[email-masked]> wrote:
>
>  Hi,
>
> The latest BSR draft states "There MUST however be a minimum of
> BS_Min_Interval between each time a BSM is sent." This is mentioned in the
> context of generating BSMs on C-RP set changes.
>
> However, the C-BSR state machine also originates BSMs in E-BSR state for
> the event "Recieve Non-Preferred BSM". This action is not limited by
> BS_Min_Interval. Should this action also be throttled by BS_Min_Interval
> value? If so, then the action should be to reduce BS Timer to
> BS_Min_Interval if it is greater than this interval.
>
> Regards,
>
> Rishabh.
>
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pim
>
>
>
_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: sumanta seal <[email-masked]>
Date: Sat, 20 Jan 2007 09:40:05 +0000 (GMT)

Rajesh Nataraja <[email-masked]> wrote: Hi,

 If a CRP does not advertise a particular group prefix in a message,
 Should the BSR treat that Group prefix as not configured for the CRP any more and then adjust its BSR message to accomodate the removal of the group prefix immediately?
 or
 Should it courteously wait until the Group prefix, which could be started for the hold time the CRP advertised before, expire and then adjust its BSR message?

What I think is that, the BSR will not immediately adjust it's BSM to accomodate the removal of the group prefix, rather it will wait to expire GET associated with the group perfix, which is updated by the Holdtime of the received C-RP-Adv message. As per the standard (draft-ietf-pim-sm-bsr-09, section 3.3, page 19),If the holdtime is zero, the mapping is immediately removed from the C-RP-Set and when a CGET expires, the corresponding group-to-C-RP mapping is removed from the C-RP-Set.

 There are no other cases by which this mapping can be removed from C-RP-Set in the BSR.

Rgds,

Sumanta

Why Iam asking this is to see if it is legal to advertise group prefixes for a CRP with granularity for the priority down to a group prefix level.
 I have seen this in one of the implementations.
  
 Thanks
 Rajesh.

 On 1/19/07, Rishabh Parekh <[email-masked]> wrote:   Hi,
 The latest BSR draft states "There MUST however be a minimum of BS_Min_Interval between each time a BSM is sent." This is mentioned in the context of generating BSMs on C-RP set changes.  
 
 However, the C-BSR state machine also originates BSMs in E-BSR state for the event "Recieve Non-Preferred BSM". This action is not limited by BS_Min_Interval. Should this action also be throttled by BS_Min_Interval value? If so, then the action should be to reduce BS Timer to BS_Min_Interval if it is greater than this interval. 
 
 Regards,
 Rishabh.

Thanks & Regards, 
************************************************** 
Sumanta Seal
Salt Lake City, Kolkata
West Bengal
**************************************************

---------------------------------
 Here’s a new way to find what you're looking for - Yahoo! Answers