Subject: [pim] Some doubts about draft-ietf-pim-mib-v2-09?

From: Su Haiyang <[email-masked]>
Date: Tue, 27 Feb 2007 18:42:37 +0800

Hi,

   I have some doubts about The PIM Group Mapping Table defined at draft
draft-ietf-pim-mib-v2-09

I will appreciate your help if someone can give answer about the following
doubts

   in page 66 of draft-ietf-pim-mib-v2-09, there are some words as bellow:

            Given the collection of rows in this table at any point in

            time, the PIM mode and RP address to use for a particular

            group is determined using the following algorithm.

            1. From the set of all rows, the subset whose group prefix

               contains the group in question are selected.

            2. If there are no such rows, the behavior is undefined.

            3. If there is at least one such row, from the selected

               subset of rows, the subset that have the lowest value

               of pimGroupMappingPrecedence are selected.

            4. From the selected subset of rows, the subset that have

               the greatest value of pimGroupMappingGrpPrefixLength are

               selected.

            5. If there are multiple selected rows, the subset that have

               the highest precedence (the lowest numerical value for

               pimGroupMappingPrecedence) are selected.

            6. If there are multiple selected rows, the row selected is

               implementation dependent; the implementation might or

               might not apply the PIM hash function to select the row.

            7. The group mode to use is given by the value of

               pimGroupMappingPimMode from the single selected row; the

               RP to use is given by the value of

               pimGroupMappingRPAddress, unless pimGroupMappingOrigin is

               'embedded', in which case the RP is extracted from the

               group address in question."

 I don't understand these words totally:

                1. What's the purpose of  pimGroupMappingPrecedence item? Is
it only used in mapping a group prefix to a static rp?

                2. If there are static RP (embedded RP added in IPv6
multicast), BSR-RP, or some other dynamic RP mechanism like CISCO's private
AutoRP, 

willing to sever a group/prefix, How to choose the unique RP?

                3. Why the pimGroupMappingPrecedence appear twice in the
above words(row3 and row5)? Is there

                   any diffrence between this two rows? 

Best Regards

Steven Su

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: "David McWalter" <[email-masked]>
Date: Tue, 27 Feb 2007 10:58:39 -0000

Hi Su.
 
                1. What's the purpose of  pimGroupMappingPrecedence item? Is it only used in mapping a group prefix to a static rp?
[DMcW] If more than one RP could be used for a group, the pimGroupMappingPrecedence chooses between them.

                2. If there are static RP (embedded RP added in IPv6 multicast), BSR-RP, or some other dynamic RP mechanism like CISCO's private AutoRP, 

[DMcW] Each willing RP has a pimGroupMappingEntry row.  The one with the lowest numerical pimGroupMappingPrecedence is chosen.

                3. Why the pimGroupMappingPrecedence appear twice in the above words(row3 and row5)? Is there

[DMcW] You're right, 3 and 5 say the same thing.  I think 5 has no effect, and should be deleted.
 
Hope that helps,
David McWalter.
 
-----Original Message-----
From: Su Haiyang [mailto:[email-masked]]
Sent: 27 February 2007 10:43
To: [email-masked]
Cc: [email-masked]
Subject: [pim] Some doubts about draft-ietf-pim-mib-v2-09?

Hi,

   I have some doubts about The PIM Group Mapping Table defined at draft draft-ietf-pim-mib-v2-09

I will appreciate your help if someone can give answer about the following doubts

               selected.

                1. What's the purpose of  pimGroupMappingPrecedence item? Is it only used in mapping a group prefix to a static rp?

                2. If there are static RP (embedded RP added in IPv6 multicast), BSR-RP, or some other dynamic RP mechanism like CISCO's private AutoRP, 

                3. Why the pimGroupMappingPrecedence appear twice in the above words(row3 and row5)? Is there

Best Regards

Steven Su