Subject: [pim] Query about two special topology of Bidir-PIM

From: Su Haiyang <[email-masked]>
Date: Wed, 12 Dec 2007 12:05:52 +0800

Dear All,
   I have two doubt about the Bidir-PIM(RFC5015).
Question 1: In the following topology, multicast streams will be forwarded
to RP by the 'Next to RP'router although there is no any (*,G) join rooted
at RP. Why there is no any description about this limitation. Should we
extend the behavior of RPA, such as RPA sending (*,G) prune if there is no
any (*,G) join state at RPA, and every router along the path to PRA
maintaining prune state at RPF_interface(RPA(G)) if a explicit (*,G) prune
is received, otherwise maintaining default join state. 

              +----------+
              |  RPA     |
              |          |
              +----+-----+
                   |
                   |
              +----+-----+
              |Next to RP |
              |          |
              +----+-----+
                   |
        +----------+-----------+
        |     +                |
        |                      +
    +---+----+            +----+----+
    |First-DF|            |Last-DF  |
    |        |            |         |
    +---+----+            +----+----+
        |                      |
        +                      +
     Source                  Receiver
Quesition 2: Why (*,G) assert mechanism is totally thrown away from
Bidir-PIM. In a multi-access network, if two downstream router choose
different RP_Nbr(RPA(G)) depending on unicast routing-table, only assert can
elect a single forwarder.
Hope someone to clarify above doubts.Thanks.
Su Haiyang

_______________________________________________
pim mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pim

---

From: John Zwiebel <[email-masked]>
Date: Wed, 12 Dec 2007 08:03:34 -0800

1) The paradigm used in this protocol is that packets are always  
forwarded upstream.
	You certainly could send prunes downstream, but then the RP would  
have to
	check every packet it received to determine which group it belonged  
to so
	that it could create the necessary (*,G) state that could send that  
prune.
2) If this happens, then your DF election is broken and/or your  
downstream routers
	failed to send their joins to the upstream DF.  Yes, this would be a  
bad thing.
	However, implementing asserts is "worse".  At least as the protocol  
stands now.
	
Both cases are "data triggered events" which need to be eliminated  
from PIM.
Which is also why one should be working toward the elimination of ASM  
deployments
and make it SSM and bidir instead.