Subject: [pim] Reg: IPv6 PIM SNMP testing

From: "Arunkumar.Janakiraman" <[email-masked]>
Date: Wed, 23 Apr 2008 19:00:08 +0530

Hi,
I am new to SNMP testing, I want to know how to test IPv6 PIM using RFC 5060
In this RFC it mentioned that this MIB is independent of ip version, so my doubt is
How to differentiate ipv4 and ipv6 during SNMP get and walk(here OID is same for ipv4 and ipv6)

Note: I tried SNMP walk but it always fetch the ipv4 PIM values.

Arun

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: Bharat Joshi <[email-masked]>
Date: Mon, 28 Apr 2008 21:56:16 +0530

Hi Arun,

>Note: I tried SNMP walk but it always fetch the ipv4 PIM values.

As you rightly mentioned that the PIM MIB in RFC 5060 is IP version independent. This MIB is made IP version independent by using InetAddressType and InetAddress object whereever IP address is required. So please check if your SNMP Agent implementation support these objects in PIM MIB.

Thanks,
Bharat

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: Bharat Joshi <[email-masked]>
Date: Wed, 30 Apr 2008 10:29:42 +0530

Hi Arun,

> Thanks for the update.
> 
> I am still wondering how the MIB walk will work 

I am not sure what you mean by this.

> and also
> What about the scalars it is not using InetAddressType and InetAddress object.

There are couple of scalars which are per system and has nothing to do
with IP address at all and so they will be fetched as normal scalars in
a MIB are fetched.

Regards,
Bharat

> Thanks
> Arun
> 
> -----Original Message-----
> From: Bharat Joshi [mailto:[email-masked]]
> Sent: Monday, April 28, 2008 9:56 PM
> To: Arunkumar Janakiraman
> Cc: [email-masked]
> Subject: RE: Reg: IPv6 PIM SNMP testing
> 
> 
> Hi Arun,
> 
> >I am new to SNMP testing, I want to know how to test IPv6 PIM using RFC
> >5060 In this RFC it mentioned that this MIB is independent of ip
> >version, so my doubt is How to differentiate ipv4 and ipv6 during SNMP
> >get and walk(here OID is same for ipv4 and ipv6)
> >
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error,please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility forloss or damage arising from the use of the information transmitted by this email including damage from virus."