Subject: [pim] pim session behavior at address-list option disappears

From: "Yamamoto, Susumu" <[email-masked]>
Date: Fri, 01 Aug 2008 20:48:44 +0900

Dear all,

I have a question regarding to address-list option
of PIM-SM.

Accoding to 4.3.1 of RFC4601, the option can be
omitted if no secondadry addresses exist.

Then, what is the expected behavior of PIM neighbor
for some reason receving a Hello without address-
list option which existed in the previous Hellos ?
Just receive the Hello or delete the neighbor
immediately, or else ?

Regards,
-Susumu

-- 
Susumu YAMAMOTO
NTT Network Service Systems Lab.
+81 422 59 2744 (tel), 5636 (fax)

_______________________________________________
pim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pim

---

From: "Yamamoto, Susumu" <[email-masked]>
Date: Fri, 01 Aug 2008 21:50:58 +0900

Chris,

Thank you very much for your quick response.

I understand that PIM neighbor is kept, but the address
list is updated to the latest information, i.e. no
secondary address, right ?

And what about the existing mFIB for which the secondary
address received previously was used to determine RPF ?

Regards,
-Susumu

---
> Yamamoto, Susumu initiated a hyperspace jump with:
>> Dear all,
>>
> Receive the hello and update the address list stored. Since
> the address list is not present then all of the addresses stored
> will be deleted.
> 
> Chris
> 
>

---

From: "Daniel Alvarez (dalvarez)" <[email-masked]>
Date: Fri, 1 Aug 2008 08:25:31 -0700

Susumo,

If you read a bit further down to 4.3.4 you will find:

"If a received PIM Hello message does not contain an
   Address List Hello option, then all secondary addresses associated
   with the neighbor must be deleted."

So you will remove the neighbor association of the secondary addresses.
You should still maintain a peering with the 'primary' address.

Cheers,

dan 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yamamoto, Susumu
> Sent: Friday, August 01, 2008 4:49 AM
> To: [email-masked]
> Subject: [pim] pim session behavior at address-list option disappears
> 
> Dear all,
> 
> I have a question regarding to address-list option of PIM-SM.
> 
> Accoding to 4.3.1 of RFC4601, the option can be omitted if no 
> secondadry addresses exist.
> 
> Then, what is the expected behavior of PIM neighbor for some 
> reason receving a Hello without address- list option which 
> existed in the previous Hellos ?
> Just receive the Hello or delete the neighbor immediately, or else ?
> 
> Regards,
> -Susumu
> 
> --
> Susumu YAMAMOTO

---

From: Christopher Thomas Brown <[email-masked]>
Date: Fri, 1 Aug 2008 05:01:20 -0700

Chris

---

From: "Yamamoto, Susumu" <[email-masked]>
Date: Fri, 08 Aug 2008 19:07:27 +0900

Christopher,

Just a clarification.

 > RPF' changes to NULL.

You mean, to delete the existing mFIB entries because of
RPF changed to Null, or to apply the Null RPF only to
the newly recieved pim join requets (i.e., the exiting
mFIB entries are maintained.)

Regards,
-Susumu

---
> Yamamoto, Susumu wrote:
> Correct.
> RPF' changes to NULL.

---

From: Christopher Thomas Brown <[email-masked]>
Date: Sat, 9 Aug 2008 01:53:43 -0700

> mFIB entries are maintained.)

In PIM the RPF' neighbor becomes NULL. What this mean for the
mFIB is an implemenation detail. I know of one PIM implementation
deletes the entry from its mFIB (and it also deletes the PIM
state). I know of another PIM implementation that changes the
mFIB to have no incoming interface.

Chris