Subject: [pim] Linux PIM SM implementations

From: "Eric S. Johnson" <[email-masked]>
Date: Mon, 10 Aug 2009 17:50:18 -0400

Hello,

Does anyone have pointers to modern linux PIM-SM implementations.

We had been happy with usc pimd pimd-2.1.0-alpha29.19, but on
linux 64 bit kernels/machines it doesn't quite seem to work anymore.

And it is officially "retired" anyway. Even the old ftp/http
sites at catarina and netweb .usc.edu are no longer around.

Is there a standalone replacement? 

Is there PIM SM  available for zebra/quagga ?
qpimd pops up on google search, but looks like it 
does SSM only... I need old fashioned igmpv2 and PIM.

Is the only option xorp? (nothing against it, but the routers are all
using quagga now)

Thanks for any pointers.
E

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 10 Aug 2009 17:54:39 -0400

Look at:

http://www.xorp.org/

Tom

On Aug 10, 2009, at 5:50 PM, Eric S. Johnson wrote:

> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Bill Atwood <[email-masked]>
Date: Mon, 10 Aug 2009 18:15:14 -0400

We are using XORP successfully.  Although it is large (you need 1.4GB of
disk to compile it), the resulting binaries can be transferred to a less
well-equipped machine.  My student appears to have been able to use it
"out of the box".  In addition, the supporter of the PIM code is active.

   Bill Atwood

Tom Pusateri wrote:
>> [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email: [email-masked]
1455 de Maisonneuve Blvd. West    http: //users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8