Subject: [pim] [PIM-SM] UpstreamJPState, SwitchToSptDesire and re-join

From: huajun Lee <[email-masked]>
Date: Mon, 3 Aug 2009 09:21:52 +0800

Hi,
    At the DR, when one source sent (S,G)data  to  the DR(interface E1)

         follow the 4.4.1 on page 37
               DownstreamJPState(S,G, E1) =Join
               immediate_olist(S,G) and inherited_olist(S,G)  (+) E1
         So the UpstreamJPState(S,G,E1) = Join, then Send Join(S,G),
         Does it lack some description for not doing Send  ? So dose it at
RP when a Join(*,G) arrived.

         Need DR  creat (*,G)state before creat(S,G)?

   At the 27th page of the rfc4601
        SwitchToSptDesired(S,G) return true once a single packet has been
received for the source and group
    is that mean: (S,G)data can be received on the interface I ( I != RPF(S)
)

  At page 42   4.4.2
       packet_arrives_on_rp_tunnel(pkt){
             }

       where do the RP re-join  SPT?

 thanks and regards,
Spark Lee

---

From: G G <[email-masked]>
Date: Tue, 18 Aug 2009 12:54:05 +0530

Hi Huajun,

Please see inline with #GG#

>          Need DR  creat (*,G)state before creat(S,G)?
#GG# Normally DR does not create (*,G) unless it is RP for G. It creates
(S,G) state only.

>     is that mean: (S,G)data can be received on the interface I ( I !=
> RPF(S) )
>
#GG# Yes, till Last-Hop router switches to SPT,  (S, G) data can arrive on
interface I (I != RPF(S)). I is the interface towards the RP for G and it
may or may not be same as interface towards source.

>        where do the RP re-join  SPT?
#GG# I think receipt of first register packet will lead to creation of (S,
G) on RP and if JoinDesired(S,G) is TRUE at RP, it will propogate (S, G)
join upstream towards Source DR.
and when data packet arrives at RP, it updates the SPT bit as per
Update_SPTbit(S,G,iif).

Regards,
GG