Subject: [pim] Regarding Source IPv6 address in PIMv6 Graft Messages

From: deepa ramar <[email-masked]>
Date: Wed, 14 Sep 2011 18:39:08 +0530

Hi,

This mail is regarding a doubt I have w.r.t source address in the PIM-DMv6
GRAFT message .

As per the RFC : 3973 ( PIM-DM)

In Section 4.7:

All PIM-DM packets use the same format as PIM-SM packets.  In the
   event of a discrepancy, PIM-SM [4] should be considered the
   definitive specification.  All PIM control messages have IP protocol
   number 103.  All PIM-DM messages MUST be sent with a TTL of 1.  All
   PIM-DM messages except Graft and Graft Ack messages MUST be sent to
   the ALL-PIM-ROUTERS group. Graft messages SHOULD be unicast to the
   RPF'(S).  Graft Ack messages MUST be unicast to the sender of the
   Graft.

As per the RFC : 4601 (PIM-SM)
In Section 4.9:
PIM Packet Formats

   This section describes the details of the packet formats for PIM
   control messages.
   All PIM control messages have IP protocol number 103.
   PIM messages are either unicast (e.g., Registers and Register-Stop)
   or multicast with TTL 1 to the 'ALL-PIM-ROUTERS' group (e.g.,
   Join/Prune, Asserts, etc.).  The source address used for unicast
   messages is a domain-wide reachable address; the source address used
   for multicast messages is the link-local address of the interface on
   which the message is being sent.

The RFC(3973) specifies that the Ggraft messages should be unicast.

Since the graft message is sent to the neighbor on the local link,
using the link local address for the Graft messages also are valid.

But in PIM-SM  RFC (4601) specifies that the source address used for
unicast messages is a domain-wide reachable address.

I am confused as to which address(Link-local address or domain-wide
reachable ) I need to use in the source address of GRAFT message? Or
are both types of addresses valid?.

Regards,
Dheepa P R

---

From: "Nicholas, Jonathan - ES" <[email-masked]>
Date: Thu, 15 Sep 2011 08:10:35 -0400

Hello,

Strictly speaking, PIM-DM does not care whether the address used is link local or domain wide, since the message won’t go beyond the local link anyway.

PIM-SM does care because its messages will go beyond the local link and therefore specifies the use of domain wide addresses.

Please note that PIM-DM and PIM-SM are separate and independent protocols which happen to share several messages.  One should not assume that anything written for PIM-SM is required for PIM-DM or vice versa.

Jonathan Nicholas

From: [email-masked] [mailto:[email-masked]] On Behalf Of deepa ramar
Sent: Wednesday, September 14, 2011 9:09 AM
To: [email-masked]
Subject: [pim] Regarding Source IPv6 address in PIMv6 Graft Messages

Hi,

This mail is regarding a doubt I have w.r.t source address in the PIM-DMv6 GRAFT message .

In Section 4.7:

Since the graft message is sent to the neighbor on the local link, using the link local address for the Graft messages also are valid.

But in PIM-SM  RFC (4601) specifies that the source address used for unicast messages is a domain-wide reachable address.

I am confused as to which address(Link-local address or domain-wide reachable ) I need to use in the source address of GRAFT message? Or are both types of addresses valid?.

Regards,
Dheepa P R

________________________________
This e-mail and any files transmitted with it may be proprietary and are intended solely for the use of the individual or entity to whom they are addressed. If you have received this e-mail in error please notify the sender.
Please note that any views or opinions presented in this e-mail are solely those of the author and do not necessarily represent those of ITT Corporation. The recipient should check this e-mail and any attachments for the presence of viruses. ITT accepts no liability for any damage caused by any virus transmitted by this e-mail.