Subject: [pim] Question about PIM-DM and RFC 3973

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 24 Jan 2014 10:12:51 -0000

Hi,

I have a question...

Has anyone an opinion on whether PIM-DM should:
- remain Experimental
- be archived
- be moved onto the Standards Track

Thanks,
Adrian

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jan 2014 02:35:42 -0800

Hmm...

Where could i read up on process and practical implications of "archived" ?
Haven't tried to understand those yet.

Attempts to go standards track are IMHO totall unacceptable without
a clearer description of the scope/applicability, eg: where it makes
sense and it's limitations.  I would hate to see cycles spent on
improving PIM-DM without a lot more customers supporting that effort, so
i would advise against opening up the PIM-DM spec for revision.

If folks feel that they want to invest cycles into PIM-DM, there
should be a separate deployment experience draft written plus proposals
on how to define forthgoing its applicability, and if we can get that type
of draft through as an RFC, then it will also point us to the
right future status of the PIM-DM spec itself.

Short of either understanding whether archive is an obvious good
choice without further work, and short of work to set the applicability
straight, i'd just stick with experimental.

Cheers
    Toerless

On Fri, Jan 24, 2014 at 10:12:51AM +0000, Adrian Farrel wrote:
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

-- 
---
Toerless Eckert, [email-masked]
Cisco NSSTG Systems & Technology Architecture
SDN: Let me play with the network, mommy!

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 24 Jan 2014 09:11:23 -0800

> Has anyone an opinion on whether PIM-DM should:

Absolutely.

> - be archived

Need a clear definition, like Toerless said.

> - be moved onto the Standards Track

Definitely not.

There have been some thoughts going around for some time of doing "stateless" multicast where most of the packet delivery would be to all interfaces (modulo the one the source can be reached through) in backbone systems where the trees are dense in that part of the network where spareness occurs towards the tail of the network topology.

Having said that dense-mode or simply non-pruned multicast could have a come back.

Dino

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 28 Jan 2014 19:36:33 -0000

Thanks Dino and Toerless,
My question is answered.
Adrian

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: 24 January 2014 17:11
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [pim] Question about PIM-DM and RFC 3973
> 
> 
> There have been some thoughts going around for some time of doing "stateless"
> multicast where most of the packet delivery would be to all interfaces (modulo
> the one the source can be reached through) in backbone systems where the
> trees are dense in that part of the network where spareness occurs towards the
> tail of the network topology.
>