Subject: [pim] Question on 'B' bit in encoded group address

From: "Sowmya Krishnaswamy (sowkrish)" <[email-masked]>
Date: Tue, 4 Mar 2014 18:49:23 +0000

Hi All,

Wanted to know if the 'B' bit in the encoded group address format in RFC 4601 needs to be filled in correctly in every PIM packet like assert, JP etc. based on the protocol type. (BIDIR/non-BIDIR). Is there any specific use case of the bit in JP/Assert messages? I see it being used only in RFC 5059 in the context of CRP/BSR mapping messages.

Encoded-Group Address

   Encoded-Group addresses take the following format:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |  Addr Family  | Encoding Type |B| Reserved  |Z|  Mask Len     |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                Group multicast Address
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+...

   Addr Family
        Described above.

   Encoding Type
        Described above.

   [B]idirectional PIM
        Indicates the group range should use Bidirectional PIM [13<https://tools.ietf.org/html/rfc4601#ref-13>].
        For PIM-SM defined in this specification, this bit MUST be zero.

Best Regards,
Sowmya

---

From: Jaroslaw Adam Gralak <[email-masked]>
Date: Tue, 4 Mar 2014 20:06:21 +0100

On Tue, Mar 4, 2014 at 7:49 PM, Sowmya Krishnaswamy (sowkrish)
<[email-masked]> wrote:
> Hi All,
>
> Wanted to know if the 'B' bit in the encoded group address format in RFC
> 4601 needs to be filled in correctly in every PIM packet like assert, JP
> etc. based on the protocol type. (BIDIR/non-BIDIR). Is there any specific
> use case of the bit in JP/Assert messages? I see it being used only in RFC
> 5059 in the context of CRP/BSR mapping messages.
>
> Encoded-Group Address
>
>         Indicates the group range should use Bidirectional PIM [13].

Hi Sowmya,
RFC is clear here and states that it should be set. Most of PIM
implementation distinguish bidir groups from non-bider ones based on
group address, but in theory there might be implementation out there
that relies solely on a presence of that bit. Because of that I would
say it should be always set appropriately.

Best Regards,

-- 
Jaroslaw Adam Gralak