Subject: [pim] WG Adoption Call: draft-pim-with-ipv4-prefix-over-ipv6-nh

From: Michael McBride <[email-masked]>
Date: Tue, 22 Aug 2017 18:02:25 +0000

Hello PIMers,

This begins a call for adoption of draft-pim-with-ipv4-prefix-over-ipv6-nh-01 which was presented in Prague where 4 were for adoption and 0 against. Please respond with your thoughts, either way, on whether we should adopt this draft. The draft notes, from the discussion in Prague, are below.

Thanks,
Mike

Prague meeting notes:

Stig: pim-with-ipv4-prefix-over-ipv6-nh.
Ashutosh gupta is the main author.
Problem statement:
mcast routing needs a RPF tree to be formed in order to receive one copy of mcast data on lowest cost loop free path
in case of PIMv4, it needs a valid PIMv4 neighbor to send PIMv4 join
when using RFC5549, a IPv4 prefix is reachable over IPv6 next hop or vice versa
if rpf interface has more than 1 pimv4 neighbor, then a new pim mechanism is needed to choose corresponding neighbor for IPv6 next hop.
solution: use of secondary address list option in PIM hello
status:
deployed by one cisco customer.
looking for wg adoption
Toerless: is the join for the v4 still an v4 packet?
Stig: yes
Toerless: there is no interest to have a single address family pim adjacency.
Stig: there could be. there is v4 and v6 on the router interfaces.
Toerless: the address extension is in v4 or v6?
stig: there is a hello where the family should be same as interface itself.
Toerless: minimum recommendation is that v4 mapping is the hello option in v6 hello. one other logical next step is what is preferred solution. perhaps just build a v6 port connection. and can still send v4 joins.
Stig: you could send a pim join with v6 destination address that might contact v4 s,gs.
toerless: say prefer doing this in v6.
stig: there is also people trying to deploy v6 only in their core networks. and also deliver v4 payloads
toerless: first step make the control plane v6. and make v4 a service. get rid of native v4 packets is a different problem.
stig: would prefer to have this a separate thing. simple document. to do what you say to use v6 join to ask for v4 join that would make a change to pim spec.
toerless: would love protocol drafts to share best practices. have hello option in v6 pim.
stig: would like some guidance on whether wg should do this.
4 people have read. 4 people think we should adopt. will take to list.
Toerless: most of my comments don't have to go in this draft. maybe in mboned.
Stig as chair: think it would be interesting to look at this in mboned. people that deploy multicast. v4 mcast with v6 signalling. maybe talk to isps.

---

From: Xufeng Liu <[email-masked]>
Date: Tue, 29 Aug 2017 16:39:20 +0000

Support the adoption.

Thanks,
- Xufeng

From: pim [mailto:[email-masked]] On Behalf Of Michael McBride
Sent: Tuesday, August 22, 2017 2:02 PM
To: [email-masked]
Subject: [pim] WG Adoption Call: draft-pim-with-ipv4-prefix-over-ipv6-nh

Hello PIMers,

Thanks,
Mike

Prague meeting notes:

---

From: Hitoshi Asaeda <[email-masked]>
Date: Wed, 30 Aug 2017 10:59:04 +0900

I support the adoption.

> 2017/08/23 3:02, Michael McBride <[email-masked]> wrote:
> 
> Hello PIMers,
>  
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim