Subject: Re: [pim] Benoit Claise's Discuss on draft-ietf-pim-yang-13: (with DISCUSS and COMMENT)

From: Benoit Claise <[email-masked]>
Date: Fri, 16 Feb 2018 11:38:13 +0100

Dear authors,

What is the status on this draft?

Regards, Benoit
> Benoit Claise has entered the following ballot position for
> draft-ietf-pim-yang-13: Discuss
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-pim-yang/
>
>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> Thanks to Jürgen, who reminded me that the YANG doctor feedback has not been
> addressed or replied to.
> https://datatracker.ietf.org/doc/review-ietf-pim-yang-12-yangdoctors-lc-schoenwaelder-2017-12-20/
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> [removed the entries taken care of in version 13]
>
> - Question for Alvaro, there is a normative reference to [I-D.ietf-bfd-yang].
> What is the status?
>
>
>       import ietf-bfd-types {
>         prefix "bfd-types";
>       }
>
>       grouping interface-config-attributes {
>         description
>           "A grouping defining interface attributes.";
>         container bfd {
>           if-feature bfd;
>           description
>             "BFD (Bidirectional Forwarding Detection) operation.";
>           uses bfd-types:client-cfg-parms;
>         }
>
> >From https://tools.ietf.org/html/draft-ietf-bfd-yang-07
>     grouping client-cfg-parms {
>       description
>         "BFD grouping for config parameters
>          used by clients of BFD, e.g. IGP or MPLS";
>
>       leaf enable {
>         type boolean;
>         default false;
>         description
>           "Indicates whether the BFD is enabled.";
>       }
>       uses base-cfg-parms;
>     }
>
> >From Jürgen Schönwälder:
>
> I have reviewed this document both as ops-dir reviewer and as yang doctor. A
> more detailed review has been submitted as part of the yang doctor review. Here
> I am focusing on more general questions from an operational perspective.
>
> - There are a number of parameters without defined defaults. Is the
>    idea that every vendor augments in their defaults? Would it not
>    overall be simpler if the PIM WG can find agreement on common
>    defaults? (Vendors can still publish deviations I think.)
>
> - I wonder how these YANG modules relate to the PIM MIB modules. Are
>    for example counters the same or different? I think it would be good
>    if the text would discuss relationship of the YANG modules relate to
>    corresponding MIB modules.
>
> -  There are no example configurations provided, demonstration how, for
>    example, a simple PIM installation would be configured is not
>    present in the document (e.g., as an appendix).
>
>
> .
>

---

From: Xufeng Liu <[email-masked]>
Date: Fri, 16 Feb 2018 16:17:28 +0000

Hi Benoit,

The authors are working on it, and will post an update to address the comments next week.
Thanks,
- Xufeng

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Friday, February 16, 2018 5:38 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Juergen Schoenwaelder <j.schoenwaelder@jacobs-
> university.de>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: Benoit Claise's Discuss on draft-ietf-pim-yang-13: (with DISCUSS
> and COMMENT)
> 
> Dear authors,
> 
> > email addresses included in the To and CC lines. (Feel free to cut
> > this introductory paragraph, however.)
> >
> >
> > Please refer to
> > https://www.ietf.org/iesg/statement/discuss-criteria.html
> > Thanks to Jürgen, who reminded me that the YANG doctor feedback has
> > not been addressed or replied to.
> > I have reviewed this document both as ops-dir reviewer and as yang
> > doctor. A more detailed review has been submitted as part of the yang
> > doctor review. Here I am focusing on more general questions from an
> operational perspective.
> >