Subject: Re: [pim] draft-ietf-pim-igmp-mld-snooping-yang-01 comments

From: Hongji Zhao <[email-masked]>
Date: Tue, 24 Apr 2018 02:59:11 +0000

Hi Stig,

Thanks a lot for your comments.

Regarding your main comment about the robustness variable. I have checked the RFC 3376

Quote:

8.1. Robustness Variable

The Robustness Variable allows tuning for the expected packet loss on

a network. If a network is expected to be lossy, the Robustness

Variable may be increased. IGMP is robust to (Robustness Variable -

1) packet losses. The Robustness Variable MUST NOT be zero, and

SHOULD NOT be one. Default: 2   ------------------------Here it says the value should not be one. So I set the range for the robustness variable between 2 and 7.  I will modify the range to 1..7. Is it ok?

I will check other comments and revise the draft later on.

BR/Hongji

赵宏吉

-----Original Message-----
From: Stig Venaas [mailto:[email-masked]]
Sent: Tuesday, April 24, 2018 6:06 AM
To: [email-masked]; [email-masked]
Subject: draft-ietf-pim-igmp-mld-snooping-yang-01 comments

Hi

After reading through the draft I have some comments.

The main comment I have is regarding the robustness variable. I see it says the value must be in the range 2..7. But RFC 3376 does allow 1,

quote:

   The Robustness Variable allows tuning for the expected packet loss on

   a network.  If a network is expected to be lossy, the Robustness

   Variable may be increased.  IGMP is robust to (Robustness Variable -

   1) packet losses.  The Robustness Variable MUST NOT be zero, and

   SHOULD NOT be one.  Default: 2

Shouldn't this document, and also the IGMP-MLD model allow the value 1?

Below are various less important comments.

In section 2:

   The goal of this document is to define a data model that provides a

   common user interface to IGMP and MLD Snooping.  There is very

   information that is designated as "mandatory", providing freedom for

   vendors to adapt this data model to their respective product

   implementations.

It seems something is wrong with this sentence "There is very information...". Are there some words missing?

In 2.1, I'm not sure what this sentence means:

   The YANG module includes IGMP and MLD Snooping instances

   definition, instance references in the scenario of BRIDGE, VPLS.

Note that in 2.3 it says "bridge, L2VPN".

In 2.1 it says "clearing the specified IGMP and MLD Snooping". I think it should say something more, perhaps "IGMP and MLD Snooping group tables".

In 2.1, 2 dots at the end "data modeling language..".

In 2.2, double space "to configure IGMP and  MLD".

In 2.2, maybe find a better way to phrase "The attribute who could be read and written shows configuration data."

Section 3 comments.

It says "fowarding" several places.

It says "Outgoing ac in l2vpn fowarding". Should "ac" be "AC"? Same question regarding "pw". Also, should "mac"

be "MAC" in the descriptions? Also "l2vpn" should be "L2VPN" I think.

It says "VSI" in one place. What is VSI?

"leaf require-router-alert", is it to set RA, and/or requiring RA on received messages.

I think "The time after the device created L2 multicast record."

should be "The time elapsed since".

For last reporter it says "The last host address which has sent the report"... It should say "address of the last host which has.."

or perhaps better "address of the last report received...".

What is the name/key used for a snooping instance? Can a user choose an arbitrary name, or do implementations somehow decide the name?

In many descriptions it says "IP address", but some places it says "IPv4 address" or "IPv6 address". I think it is best to include the version in the description when the leaf is for a particular version.

Section 4 Security considerations probably need to be expanded. At the least explain why no issues if that's the case.

Section 5 needs to be updated, there is some work for IANA.

Mahesh's affiliation and address need to be updated.

Stig

BR/Hongji
赵宏吉

---

From: Stig Venaas <[email-masked]>
Date: Tue, 24 Apr 2018 12:47:09 -0700

Hi

Thanks, I do think it should be 1..7 since 1 is a valid value. It
would have been different if the RFC said MUST NOT.

Thanks for making this and other changes. I hope the same change can
be made in the IGMP/MLD (not snooping) model.

Stig

On Mon, Apr 23, 2018 at 7:59 PM, Hongji Zhao <[email-masked]> wrote:
> SHOULD NOT be one. Default: 2   ------------------------Here it says the
> value should not be one. So I set the range for the robustness variable
> between 2 and 7.  I will modify the range to 1..7. Is it ok?
>
>
>
>
>
> The main comment I have is regarding the robustness variable. I see it says
> the value must be in the range 2..7. But RFC 3376 does allow 1,
>
> quote:
>
>
>
> It seems something is wrong with this sentence "There is very
> information...". Are there some words missing?
>
>
>
> In 2.1 it says "clearing the specified IGMP and MLD Snooping". I think it
> should say something more, perhaps "IGMP and MLD Snooping group tables".
>
>
>
> For last reporter it says "The last host address which has sent the
> report"... It should say "address of the last host which has.."
>
> What is the name/key used for a snooping instance? Can a user choose an
> arbitrary name, or do implementations somehow decide the name?
>
>
>
> In many descriptions it says "IP address", but some places it says "IPv4
> address" or "IPv6 address". I think it is best to include the version in the
> description when the leaf is for a particular version.
>
>
>
> Section 4 Security considerations probably need to be expanded. At the least
> explain why no issues if that's the case.
>
>
>