Subject: [pim] Alvaro/PIM: Policy for standards rev selection (IGMP / MLD)

From: Toerless Eckert <[email-masked]>
Date: Wed, 6 Jun 2018 16:30:25 +0200

IETF process / current practices question

So, i was writing some 'MUST use MLDv2 (RFC3810)' into some draft (ACP),
and was challenged if MLDv1 was not also working. And in this case it was
for an ASM (link-local discovery case). Obviously, i would never want
to write that MLDv1 is sufficient unless being waterboarded. So i wonder:

Given how IGMPv2/MLDv3 are just "updating" IGMPv2/MLDv1, and both the
old and new specs are PROPOSED STANDARD, could someone rightfully
argue that a spec for an app using ASM (as in this case) should really
only require the oldest working protocol of the highest standards
level ? Or if not, are there any rules how to decide what to require ? 
"WG choice" ?

Could we / should we (we = PIM WG) try to get IGMPv1/IGMPv2 and MLDv1 obsoleted
to eliminate this type of discussion and ensure IGMPv3/MLDv2 will be required ?
Whats the process / requirements to get protocols like these obsoleted ?
Why should we / could we not do it ? ;-)

Cheers
    Toerless

---

From: Stig Venaas <[email-masked]>
Date: Thu, 7 Jun 2018 10:51:47 -0700

Hi

It would be a great idea to deprecate IGMPv2/MLDv1.

Perhaps it is also time to start working on progressing IGMPv3/MLDv2
to Internet Standard?

Stig

On Wed, Jun 6, 2018 at 7:30 AM, Toerless Eckert <[email-masked]> wrote:
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Leonard Giuliano <[email-masked]>
Date: Mon, 11 Jun 2018 05:19:44 -0700

Agree about deprecating IGMPv2/MLDv1, as it would give clear direction to 
vendors of devices like set-tops about the need to support IGMPv3/MLDv2.  
And it would nicely complement the work being done in mboned to deprecate 
ASM for interdomain mcast.

On Thu, 7 Jun 2018, Stig Venaas wrote:

| Hi
| 
| It would be a great idea to deprecate IGMPv2/MLDv1.
| 
| Perhaps it is also time to start working on progressing IGMPv3/MLDv2
| to Internet Standard?
| 
| Stig
| 
| 
| On Wed, Jun 6, 2018 at 7:30 AM, Toerless Eckert <[email-masked]> wrote:
| > IETF process / current practices question
| >
| > So, i was writing some 'MUST use MLDv2 (RFC3810)' into some draft (ACP),
| > and was challenged if MLDv1 was not also working. And in this case it was
| > for an ASM (link-local discovery case). Obviously, i would never want
| > to write that MLDv1 is sufficient unless being waterboarded. So i wonder:
| >
| > Given how IGMPv2/MLDv3 are just "updating" IGMPv2/MLDv1, and both the
| > old and new specs are PROPOSED STANDARD, could someone rightfully
| > argue that a spec for an app using ASM (as in this case) should really
| > only require the oldest working protocol of the highest standards
| > level ? Or if not, are there any rules how to decide what to require ?
| > "WG choice" ?
| >
| > Could we / should we (we = PIM WG) try to get IGMPv1/IGMPv2 and MLDv1 obsoleted
| > to eliminate this type of discussion and ensure IGMPv3/MLDv2 will be required ?
| > Whats the process / requirements to get protocols like these obsoleted ?
| > Why should we / could we not do it ? ;-)
| >
| > Cheers
| >     Toerless
| >
| > _______________________________________________
| > pim mailing list
| > [email-masked]
| > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pim&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=iw2TU3OZ0CDpCbqeV23zdah2FoG9Do-zEmGgWTaavDg&m=UN-ulG9LS8kIFuoDpy3F-wm8UWOXJXsFpiJver--Hxg&s=VHZQlEyWA8R7R4dTYg4OirpS0sJAuyJx7JofhAIfan4&e=
| 
| _______________________________________________
| pim mailing list
| [email-masked]
| https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pim&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=iw2TU3OZ0CDpCbqeV23zdah2FoG9Do-zEmGgWTaavDg&m=UN-ulG9LS8kIFuoDpy3F-wm8UWOXJXsFpiJver--Hxg&s=VHZQlEyWA8R7R4dTYg4OirpS0sJAuyJx7JofhAIfan4&e=
|

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 14 Jun 2018 00:21:59 +0200

Are there any rules/guidelines for deprecating protocols ?

-- 
---
[email-masked]