Subject: Re: [pim] Alvaro/PIM: Policy for standards rev selection (IGMP / MLD)

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Sat, 28 Jul 2018 21:31:05 +0000

Hi Every one, 
What is the final call to move IGMPv3 towards standard track.  As discussed during last IETF 

  * Lightweight IGMP V3 is standard track document and it excludes the option of source list with Exclude mode. 

So question would be , 

* Should we have single document which would include some more detail in lightweight IGMP V3 and create standard track document ? 
* New Document MUST inherit all state machine from existing IGMP V3 document. 

Mankamana 

> On Jun 7, 2018, at 10:51 AM, Stig Venaas <[email-masked]> wrote:
> 
> Hi
> 
> It would be a great idea to deprecate IGMPv2/MLDv1.
> 
> Perhaps it is also time to start working on progressing IGMPv3/MLDv2
> to Internet Standard?
> 
> Stig
> 
> 
> On Wed, Jun 6, 2018 at 7:30 AM, Toerless Eckert <[email-masked]> wrote:
>> IETF process / current practices question
>> 
>> So, i was writing some 'MUST use MLDv2 (RFC3810)' into some draft (ACP),
>> and was challenged if MLDv1 was not also working. And in this case it was
>> for an ASM (link-local discovery case). Obviously, i would never want
>> to write that MLDv1 is sufficient unless being waterboarded. So i wonder:
>> 
>> Given how IGMPv2/MLDv3 are just "updating" IGMPv2/MLDv1, and both the
>> old and new specs are PROPOSED STANDARD, could someone rightfully
>> argue that a spec for an app using ASM (as in this case) should really
>> only require the oldest working protocol of the highest standards
>> level ? Or if not, are there any rules how to decide what to require ?
>> "WG choice" ?
>> 
>> Could we / should we (we = PIM WG) try to get IGMPv1/IGMPv2 and MLDv1 obsoleted
>> to eliminate this type of discussion and ensure IGMPv3/MLDv2 will be required ?
>> Whats the process / requirements to get protocols like these obsoleted ?
>> Why should we / could we not do it ? ;-)
>> 
>> Cheers
>>    Toerless
>> 
>> _______________________________________________
>> pim mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/pim
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Linus Lüssing <[email-masked]>
Date: Sun, 29 Jul 2018 00:59:14 +0200

Hi,

I would love to see IGMPv2/MLDv1 deprecated, too.

For batman-adv, a layer 2 mesh routing protocol available in the Linux
kernel, it was a pain to introduce multicast awareness due to the
difficulties caused by the report suppression mechanism specified in
IGMPv2/MLDv1 [0].

And the solution/workaround currently implemented is still not
100% satisfactory.

Regards, Linus

[0]: https://www.open-mesh.org/projects/batman-adv/wiki/Multicast-optimizations-report-suppresion