Subject: Re: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

From: Hongji Zhao <[email-masked]>
Date: Tue, 8 Jan 2019 07:15:55 +0000

Hi Mikael,

 Regarding the leaf expire, we have changed type into rt-types:timer-value-seconds16.  This type could express "infinity".
 Thanks a lot ! 

BR/Hongji
赵宏吉

-----Original Message-----
From: Mikael Abrahamsson <[email-masked]> 
Sent: Friday, December 21, 2018 5:37 PM
To: Hongji Zhao <[email-masked]>
Cc: Stig Venaas <[email-masked]>; Michael McBride <[email-masked]>; [email-masked]
Subject: RE: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

On Fri, 21 Dec 2018, Hongji Zhao wrote:

> Hi Mikael,
>
> This is a "mandatory true", it means all the dynamic groups need expire. The group(who is read-only)  list only includes dynamic groups.
> I suppose it won't be a statically configured group.
>
> Do you think it should not be "mandatory true"?  OR the group (who is read-only) should include the statically configured group?

I believe operational data should show all groups currently being handled, regardless if they're statically configured or not. I want to be able to see other aspects of them, so it would be a bad idea if they were omitted from the list just because they're statically configured.

Minimum change could be to either remove the "mandatory true;" and say that groups without known expiry time doesn't report this value, or one could say that uint32 max value means "infinity". There could be other ways.

I have no strong opinion how to handle this, but I'd like to see it defined in the model how to handle statically configured groups with no defined expiry time.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Stig Venaas <[email-masked]>
Date: Tue, 8 Jan 2019 10:26:01 -0800

Hi

There have been some changes to draft-ietf-pim-igmp-mld-yang based on
YANG doctor input, and I believe some more are planned. Please
consider whether any of these changes might apply here as well. I'm
wondering in particular if there are any high level design changes.

Thanks,
Stig

---

From: Hongji Zhao <[email-masked]>
Date: Wed, 9 Jan 2019 02:40:28 +0000

Hi Stig,

 All the existing YANG doctor's comments for draft-ietf-pim-igmp-mld-yang have been applied on the latest draft-ietf-pim-igmp-mld-snooping-yang (version 07).
 And there is no high level design change of igmp snooping model for these comments.
 
 Thanks a lot!

BR/Hongji
赵宏吉

-----Original Message-----
From: Stig Venaas <[email-masked]> 
Sent: Wednesday, January 09, 2019 2:26 AM
To: Hongji Zhao <[email-masked]>
Cc: Mikael Abrahamsson <[email-masked]>; Michael McBride <[email-masked]>; [email-masked]
Subject: Re: [pim] Apply for WGLC about draft-ietf-pim-igmp-mld-snooping-yang

Hi

There have been some changes to draft-ietf-pim-igmp-mld-yang based on YANG doctor input, and I believe some more are planned. Please consider whether any of these changes might apply here as well. I'm wondering in particular if there are any high level design changes.

Thanks,
Stig

On Mon, Jan 7, 2019 at 11:16 PM Hongji Zhao <[email-masked]> wrote:
> Cc: Stig Venaas <[email-masked]>; Michael McBride 
> <[email-masked]>; [email-masked]