Subject: [pim] Publication has been requested for draft-ietf-pim-reserved-bits-02

From: Mike McBride via Datatracker <[email-masked]>
Date: Wed, 07 Aug 2019 15:36:10 -0700

Mike McBride has requested publication of draft-ietf-pim-reserved-bits-02 as Proposed Standard on behalf of the PIM working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-pim-reserved-bits/

---

From: Anish Peter <[email-masked]>
Date: Fri, 9 Aug 2019 09:33:47 +0530

Hi Authors,
 This draft is very much needed and it gives a simple solution.
 Few suggestions/thoughts on this draft.
1. Could you please consider reserving a few types are experimental /
vendor specific usage
2. Though obvious, it might be better to mention that the order of usage
recommended is 13.0, 13.1, . . . rather than 13.0, 14.0.
3. Thought 48 types is a very big space to expand wouldn't it be better to
keep 15.x as reserved for the time being.
 Over all my suggestion is
13.0 -14.11 unassigned
14.12-14.15 experimental
15.x reserved
 4. Should this draft make a recommendation to use the reserved bits
starting from LSB rather than the present usage pattern of MSB first?

Thanks,
Anish Peter

On Thu, Aug 8, 2019 at 4:06 AM Mike McBride via Datatracker <
[email-masked]> wrote:

> Mike McBride has requested publication of draft-ietf-pim-reserved-bits-02
> as Proposed Standard on behalf of the PIM working group.
>
> Please verify the document's state at
> https://datatracker.ietf.org/doc/draft-ietf-pim-reserved-bits/
>
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>

---

From: Stig Venaas <[email-masked]>
Date: Fri, 9 Aug 2019 10:01:53 -0700

Hi

Re point 1:
Rather than delaying this draft several months, probably at least
until after next IETF, I would suggest that we have a separate
discussion on experimental/vendor reservations. We already have one WG
draft that might need a type soon. I think we've avoided
experimental/vendor reservations in the past since we had so little
space, but it is something to consider now. If we decide to do this,
that can be a separate small draft.

Point 2 and 4:
We can put in the recommended order of usage. We also got the chance
to suggest this to IANA if needed when they assign types to future
drafts. I agree about using LSB bits first since that may help future
type expansion if needed. We can put it in the draft, but this is also
something we as a WG should keep in mind.

Point 3:
Given that we should use the space in the order 13.0, 13.1, ... it
would be many years until we would potentially consider touching 15.
Since the types are only used for RFCs approved by the pim WG, we are
in control of this. If we do a draft for experimental/vendor
reservations, then that could maybe also mark 15 as reserved. I think
"reserved" mostly makes sense when assignments don't require IETF/WG
approval in general, and the IETF/WG wants to ensure they have control
of at least parts of the space.

The draft will go to IETF last call and we can take your input as part
of the last call input. I'll address at least points 2 and 4 then.

Thanks for the input. If you have further thoughts, or anyone else in
the WG does, please follow-up.
Stig

I stripped the cc-list a bit, removing the IETF wide addresses.

On Thu, Aug 8, 2019 at 9:04 PM Anish Peter <[email-masked]> wrote:
> 1. Could you please consider reserving a few types are experimental / vendor specific usage
> 2. Though obvious, it might be better to mention that the order of usage recommended is 13.0, 13.1, . . . rather than 13.0, 14.0.
> 3. Thought 48 types is a very big space to expand wouldn't it be better to keep 15.x as reserved for the time being.
>  4. Should this draft make a recommendation to use the reserved bits starting from LSB rather than the present usage pattern of MSB first?
>
> Thanks,
> Anish Peter
>
> On Thu, Aug 8, 2019 at 4:06 AM Mike McBride via Datatracker <[email-masked]> wrote:
>>

---

From: Anish Peter <[email-masked]>
Date: Tue, 13 Aug 2019 14:42:47 +0530

Thank you!

On Fri, Aug 9, 2019 at 10:32 PM Stig Venaas <[email-masked]> wrote:

> > 3. Thought 48 types is a very big space to expand wouldn't it be better
> to keep 15.x as reserved for the time being.
> >> Mike McBride has requested publication of
> draft-ietf-pim-reserved-bits-02 as Proposed Standard on behalf of the PIM
> working group.
> >>