Subject: Re: [pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

From: Hongji Zhao <[email-masked]>
Date: Tue, 15 Oct 2019 02:53:43 +0000

Support as a co-author.  

BR/Hongji

-----Original Message-----

Message: 2
Date: Mon, 14 Oct 2019 13:31:37 -0700
From: Stig Venaas <[email-masked]>
To: [email-masked]
Subject: [pim] Adoption call for
	draft-zhao-pim-igmp-mld-proxy-yang-03.txt
Message-ID:
	<[email-masked]>
Content-Type: text/plain; charset="UTF-8"

Hi

As discussed last meeting, we are doing an adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt.

Please respond by October 25th whether you think this draft should be adopted as a WG item.

Stig

------------------------------

---

From: Liuyisong <[email-masked]>
Date: Tue, 15 Oct 2019 07:40:32 +0000

I support the adoption as a co-author.

Thanks
Yisong

Hi

Stig

---

From: Sarah Wang Y <[email-masked]>
Date: Thu, 17 Oct 2019 06:59:03 +0000

Support adoption of this draft.

BR / Sarah

-----Original Message-----

Message: 2

From: Stig Venaas <[email-masked]<mailto:[email-masked]>>

To: [email-masked]<mailto:[email-masked]>

Message-ID:

                <[email-masked]<mailto:[email-masked]>>

Hi

Stig

---

From: Hongji Zhao <[email-masked]>
Date: Mon, 21 Oct 2019 09:45:27 +0000

Hi Med,

 Thank you very much for your supporting.
 We will do further research about your comment and address it in the next iteration of the draft.

BR/Hongji

------------------------------
Date: Thu, 17 Oct 2019 12:16:32 +0000
From: <[email-masked]>
To: Stig Venaas <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, JACQUENET Christian TGI/OLN
	<[email-masked]>
Subject: Re: [pim] Adoption call for
	draft-zhao-pim-igmp-mld-proxy-yang-03.txt
Message-ID:
	<[email-masked]>
	
Content-Type: text/plain; charset="utf-8"

Hi Stig, all,

I support.

There is still a pending action from the authors to address the comment at:
https://protect2.fireeye.com/v1/url?k=69f18971-352582da-69f1c9ea-864b0d136b87-58fb1825031d20ba&q=1&e=7b7757a9-5dd6-4e35-9655-739937ec8f2d&u=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fpim%2FDrMDlsJXnVl3BW7sQM-QeIZRNvo

I hope the comment will be addressed in the next iteration of the draft.

Cheers,
Med

On Mon, Oct 14, 2019 at 1:32 PM Stig Venaas <[email-masked]<mailto:[email-masked]>> wrote:
Hi

Stig

_______________________________________________
pim mailing list
[email-masked]<mailto:[email-masked]>
https://protect2.fireeye.com/v1/url?k=68d33e76-340735dd-68d37eed-864b0d136b87-805b21d5905e9cea&q=1&e=7b7757a9-5dd6-4e35-9655-739937ec8f2d&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim

---

From: Hongji Zhao <[email-masked]>
Date: Thu, 24 Oct 2019 02:37:05 +0000

Hi Anish,

Thank you for the review and comments. We will address them in the next revision of the document.
All the replies are inline.

BR/Hongji

-----Original Message-----

Date: Thu, 17 Oct 2019 17:29:17 +0530
From: Anish Peter <[email-masked]>
To: Stig Venaas <[email-masked]>
Cc: [email-masked]
Subject: Re: [pim] Adoption call for
	draft-zhao-pim-igmp-mld-proxy-yang-03.txt
Message-ID:
	<CAA6qS9r+CbRFwupB6K4OP=[email-masked]>
Content-Type: text/plain; charset="utf-8"

Hi Authors,
 I went through the draft and have these comments.

module: ietf-igmp-mld-proxy
  augment /rt:routing/rt:control-plane-protocols/rt:control-plane-protocol:
    +--rw igmp-proxy {feature-igmp-proxy}?
       +--rw interfaces
          +--rw interface* [interface-name]
             +--rw interface-name    if:interface-ref
             +--rw version?          uint8
             +--rw enable?           boolean

AP> upstream igmp message sender source address may be an optional config entity
[Authors] Accept

           +--ro group* [group-address]
                +--ro group-address    inet:ipv4-address
                +--ro up-time?         uint32
                +--ro filter-mode?     enumeration
                +--ro source* [source-address]
                   +--ro source-address          inet:ipv4-address
                   +--ro up-time?                uint32
                   +--ro filter-mode?            enumeration

AP> Do not understand the semantics of this filter-mode? Guess filter
mode stated in the group level alone is relevant
[Authors] Accept, and we will delete other filter-mode.      
                              
                   +--ro downstream-interface* [interface-name]
                      +--ro interface-name    if:interface-ref
                      +--ro filter-mode?      enumeration
  
AP> I disagree with this hierarchy. IGMP is a per interface protocols
and source states must be build on per interface basis. Over different
downstream interfaces there are chances for different igmp versions.
[Authors] Any improvement can be further discussed.

AP> Do not understand the semantics of this filter-mode? Guess filter mode
stated in the group level alone is relevant
[Authors] Accept, and we will delete other filter-mode
 
AP> Do we have some vendor experience with this data model as proxy is
mostly implemented in access/edge devices?
[Authors]  Some vendors are interested and authors and contributors from different vendors (including cisco, juniper, ericsson, huawei, and volta) are working on the community consensus about the igmp proxy model.

Thanks,
Anish

On Tue, Oct 15, 2019 at 2:01 AM Stig Venaas <[email-masked]> wrote:

> Hi
>
> As discussed last meeting, we are doing an adoption call for 
> draft-zhao-pim-igmp-mld-proxy-yang-03.txt.
>
> [email-masked]
> https://protect2.fireeye.com/v1/url?k=b152ea30-ed86e19b-b152aaab-864b0
> d136b87-92dfb13f10a9ad27&q=1&e=7b7757a9-5dd6-4e35-9655-739937ec8f2d&u=
> https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fpim
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://protect2.fireeye.com/v1/url?k=5b80aa24-0754a18f-5b80eabf-864b0d136b87-00771c16ca6a8f09&q=1&e=7b7757a9-5dd6-4e35-9655-739937ec8f2d&u=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fbrowse%2Fpim%2Fattachments%2F20191017%2Fbe639ac0%2Fattachment.html>