Subject: [pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

From: Stig Venaas <[email-masked]>
Date: Mon, 14 Oct 2019 13:31:37 -0700

Hi

As discussed last meeting, we are doing an adoption call for
draft-zhao-pim-igmp-mld-proxy-yang-03.txt.

Please respond by October 25th whether you think this draft should be
adopted as a WG item.

Stig

---

From: Mahesh Sivakumar <[email-masked]>
Date: Tue, 15 Oct 2019 10:41:15 -0700

Support as co-author.

Thanks
Mahesh

On Mon, Oct 14, 2019 at 1:32 PM Stig Venaas <[email-masked]> wrote:

> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>

---

From: "Mani Panchanathan (mapancha)" <[email-masked]>
Date: Thu, 17 Oct 2019 06:02:45 +0000

I support the adoption as a co-author of this.

Thanks, Mani

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Stig Venaas
Sent: Tuesday, October 15, 2019 2:02 AM
To: [email-masked]
Subject: [pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

Hi

As discussed last meeting, we are doing an adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt.

Please respond by October 25th whether you think this draft should be adopted as a WG item.

Stig

---

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Thu, 17 Oct 2019 06:24:55 +0000

This is useful work, have read the document and support its adoption as WG draft.

Thanks
Prasad

-----Original Message-----
From: pim <[email-masked]> On Behalf Of Stig Venaas
Sent: Tuesday, October 15, 2019 2:02 AM
To: [email-masked]
Subject: [pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

Hi

Stig

---

From: "Xiejingrong (Jingrong)" <[email-masked]>
Date: Thu, 17 Oct 2019 06:33:29 +0000

I support the adoption of this draft.

Thanks
Jingrong

-----Original Message-----
From: pim [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: Tuesday, October 15, 2019 4:32 AM
To: [email-masked]
Subject: [pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

Hi

Stig

---

From: <[email-masked]>
Date: Thu, 17 Oct 2019 17:17:55 +0800 (CST)

Support the adoption of this draft.

Thanks,

Sandy

原始邮件

发件人：StigVenaas <[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2019年10月15日 04:32
主 题 ：[pim] Adoption call for draft-zhao-pim-igmp-mld-proxy-yang-03.txt

Hi

Stig

---

From: Anish Peter <[email-masked]>
Date: Thu, 17 Oct 2019 17:29:17 +0530

Hi Authors,
 I went through the draft and have these comments.

module: ietf-igmp-mld-proxy
  augment /rt:routing/rt:control-plane-protocols/rt:control-plane-protocol:
    +--rw igmp-proxy {feature-igmp-proxy}?
       +--rw interfaces
          +--rw interface* [interface-name]
             +--rw interface-name    if:interface-ref
             +--rw version?          uint8
             +--rw enable?           boolean
AP> upstream igmp message sender source address may be an optional config entity

           +--ro group* [group-address]
                +--ro group-address    inet:ipv4-address
                +--ro up-time?         uint32
                +--ro filter-mode?     enumeration
                +--ro source* [source-address]
                   +--ro source-address          inet:ipv4-address
                   +--ro up-time?                uint32
                   +--ro filter-mode?            enumeration
AP> Do not understand the semantics of this filter-mode? Guess filter
mode stated in the group level alone is relevant
                   +--ro downstream-interface* [interface-name]
                      +--ro interface-name    if:interface-ref
                      +--ro filter-mode?      enumeration

AP> I disagree with this hierarchy. IGMP is a per interface protocols
and source states must be build on per interface basis. Over different
downstream interfaces there are chances for different igmp versions.

AP> Do not understand the semantics of this filter-mode? Guess filter mode
stated in the group level alone is relevant
AP> Do we have some vendor experience with this data model as proxy is
mostly implemented in access/edge devices?

Thanks,
Anish

---

From: <[email-masked]>
Date: Thu, 17 Oct 2019 12:16:32 +0000

Hi Stig, all,

I support.

There is still a pending action from the authors to address the comment at:
https://mailarchive.ietf.org/arch/msg/pim/DrMDlsJXnVl3BW7sQM-QeIZRNvo

I hope the comment will be addressed in the next iteration of the draft.

Cheers,
Med

On Mon, Oct 14, 2019 at 1:32 PM Stig Venaas <[email-masked]<mailto:[email-masked]>> wrote:
Hi

Stig

_______________________________________________
pim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pim

---

From: "Mankamana Mishra (mankamis)" <[email-masked]>
Date: Thu, 17 Oct 2019 13:01:23 +0000

Support. 

On 10/14/19, 1:32 PM, "pim on behalf of Stig Venaas" <[email-masked] on behalf of [email-masked]> wrote:

    Hi

    
    Stig

---

From: Xufeng Liu <[email-masked]>
Date: Sat, 19 Oct 2019 15:18:08 -0400

Support as a co-author.
Thanks,
- Xufeng

On Thu, Oct 17, 2019 at 9:02 AM Mankamana Mishra (mankamis) <
[email-masked]> wrote:

> Support.
>
> On 10/14/19, 1:32 PM, "pim on behalf of Stig Venaas" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Hi
>

---

From: Stig Venaas <[email-masked]>
Date: Fri, 25 Oct 2019 16:21:13 -0700

Hi

We have sufficient support for adoption. Please resubmit the latest
version as a WG document (draft-ietf-pim-igmp-mld-proxy-yang-00.txt).

Stig

On Sat, Oct 19, 2019 at 12:18 PM Xufeng Liu <[email-masked]> wrote:
>
> Support as a co-author.
> Thanks,
> - Xufeng
>
> On Thu, Oct 17, 2019 at 9:02 AM Mankamana Mishra (mankamis) <[email-masked]> wrote:
>>
>> Support.
>>