Subject: [pim] I-D Action: draft-ietf-pim-drlb-11.txt

From: [email-masked]
Date: Fri, 11 Oct 2019 14:27:32 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Protocols for IP Multicast WG of the IETF.

        Title           : PIM Designated Router Load Balancing
        Authors         : Yiqun Cai
                          Heidi Ou
                          Sri Vallepalli
                          Mankamana Mishra
                          Stig Venaas
                          Andy Green
	Filename        : draft-ietf-pim-drlb-11.txt
	Pages           : 20
	Date            : 2019-10-11

Abstract:
   On a multi-access network, one of the PIM-SM routers is elected as a
   Designated Router.  One of the responsibilities of the Designated
   Router is to track local multicast listeners and forward data to
   these listeners if the group is operating in PIM-SM.  This document
   specifies a modification to the PIM-SM protocol that allows more than
   one of the PIM-SM routers to take on this responsibility so that the
   forwarding load can be distributed among multiple routers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pim-drlb/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-pim-drlb-11
https://datatracker.ietf.org/doc/html/draft-ietf-pim-drlb-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pim-drlb-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Gyan Mishra <[email-masked]>
Date: Tue, 15 Oct 2019 10:07:01 -0400

Hi Mankamana

In the DR improvements draft this is what I was looking for a LB capabilities for all multicast ASM or SSM environments where both DR and BDR are now deemed GDR capable in hello exchange and both DRs would perform the modulo hash for RP for ASM and for both ASM and SSM SPT bit set built SPT tree for S,G based on hash output.  I did notice that if the number of DRs is odd number like 3 5 7 then the LB is not even which exists for all hashing type algorithms have that issue but as long as even number 2 4 6 then the LB algorithm can get close to 50/50.

With the modifications with PIM assert to pick the FHR in dual homes source scenario now with load sharing would that now not occur but would you end up with a permanent double stream on the network.

I do see this GDR capability fully supports IPv6.

With PIM spec the higher IP or priority is the PIM DR and lower IP is IGMP querier.  

Is their any enhancement improvements with load balancing for the L2 IPv4 IGMP snooping or IPv6 MLD snooping or L3 IPv4 IGMP querier and IPv6 MLDv2 querier.

Does the PIM GDR capability extend to receiver and source side PIM c-signaling for MVPN profiles for PMSI inclusive,  inclusive aggregate or selective trees.  

Thanks 

Gyan
Sent from my iPhone

> On Oct 11, 2019, at 5:27 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim