Subject: [pim] Hi Hitoshi, we have discussed your comments about draft-ietf-pim-igmp-mld-proxy-yang on ietf106, and have some questions. Thanks!

From: Hongji Zhao <[email-masked]>
Date: Tue, 10 Dec 2019 07:29:21 +0000

Hi Hitoshi,

For IGMP proxy, would you prefer to enable explicit tracking on the upstream interface? or downstream interface?   Thanks a lot!

In the IGMP proxy yang model, we enable IGMP proxy on the upstream interface. 

module: ietf-igmp-mld-proxy
  augment /rt:routing/rt:control-plane-protocols/rt:control-plane-protocol:
    +--rw igmp-proxy {feature-igmp-proxy}?
       +--rw interfaces
          +--rw interface* [interface-name]
             +--rw interface-name           if:interface-ref
             +--rw version?                 uint8
             +--rw enable?                  boolean
             +--rw sender-source-address?   inet:ipv4-address
             +--ro group* [group-address]
                +--ro group-address    inet:ipv4-address
                +--ro up-time?         uint32
                +--ro filter-mode?     enumeration
                +--ro source* [source-address]
                   +--ro source-address          inet:ipv4-address
                   +--ro up-time?                uint32
                   +--ro downstream-interface* [interface-name]
                      +--ro interface-name    if:interface-ref

BR/Hongji

---

From: Hitoshi Asaeda <[email-masked]>
Date: Tue, 10 Dec 2019 16:17:14 -1000

Hi Hongji,

Usually, the upstream interface works as a host interface and the downstream interface(s) work as router interface(s); therefore it'd be reasonable to enable the explicit tracking function on the downstream interface(s).
The draft was expired three years ago, but you may want to refer the following I-D for the explicit tracking function specification.
https://tools.ietf.org/html/draft-ietf-pim-explicit-tracking
(I hope I will resume it after we address the issue of the intended status of this doc.)

BTW, is there a way to configure upstream or downstream for all available interfaces at the proxy?
If yes, is it allowed or disallowed to configure multiple upstream interfaces per IGMP/MLD proxy?
As we shortly discussed in the last PIM meeting, we proposed the extension of configuring multiple upstream interfaces for IGMP/MLD proxy.
Both drafts are still in progress, but if useful, you may want to consider them.
https://tools.ietf.org/html/draft-ietf-pim-multiple-upstreams-reqs-08
https://tools.ietf.org/html/draft-asaeda-pim-multiif-igmpmldproxy-03

Regards,

Hitoshi

> On Dec 9, 2019, at 21:29, Hongji Zhao <hongji.zhao=[email-masked]> wrote:
> 
> Hi Hitoshi,
> 
> _______________________________________________
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim

---

From: Hongji Zhao <[email-masked]>
Date: Wed, 11 Dec 2019 04:00:53 +0000

Hi Hitoshi,

If explicit tracking function should be enabled on the downstream interface(s),  I think the current implementation could handle it.

We could enable IGMP under the downstream interfaces,  and IGMP model has the explicit tracking function. In the IGMP proxy yang model, we enable IGMP proxy on the upstream interface.
In other words, we combine IGMP proxy model and IGMP model to implement it.

The current IGMP proxy model allows to configure multiple upstream interfaces, because it has an interface list. Just setting enable value true will achieve the goal.

module: ietf-igmp-mld
  augment /rt:routing/rt:control-plane-protocols/rt:control-plane-protocol:
    +--rw igmp {feature-igmp}?
       +--rw global
       |  +--rw enable?          boolean {global-admin-enable}?
		...
       +--rw interfaces
		...
       |  +--rw interface* [interface-name]
       |     +--rw interface-name                if:interface-ref
		...
       |     +--rw explicit-tracking?            empty {intf-explicit-tracking}?

A YANG Data Model for the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD)
https://datatracker.ietf.org/doc/rfc8652/

BR/Hongji

-----Original Message-----
From: Hitoshi Asaeda <[email-masked]> 
Sent: Wednesday, December 11, 2019 10:17 AM
To: Hongji Zhao <[email-masked]>
Cc: [email-masked]
Subject: Re: [pim] Hi Hitoshi, we have discussed your comments about draft-ietf-pim-igmp-mld-proxy-yang on ietf106, and have some questions. Thanks!

Hi Hongji,

Regards,

Hitoshi