Subject: [pim] Unambiguous IPv4 Multicast to Ethernet Address mapping?

From: "James A. (Jim) Stevens" <[email-masked]>
Date: Mon, 27 Jul 2020 00:43:43 -0500

RFC 1112 maps the 28 unique IPv4 multicast address bits to 23 bits within
the Ethernet address so that there is not a unique one to one mapping.

According to
https://networklessons.com/multicast/multicast-ip-address-to-mac-address-mapping,
this was because it would have cost $16,000 in 1990 to have reserved 16
OUIs (Organizational Unique Identifiers) to IP multicast MAC addresses so
that the IPv4 multicast to Ethernet multicast addressing would be unique.

IPv6 in RFC 2464, maps the lower 32 bits of the IPv6 multicast addresses
into the lower 32 bits of the Ethernet Address - so it looks like IEEE
supports other IP address to ethernet multicast address mappings.

Question - Is any interest within IETF about working with IEEE to come up
with an IPv4 to Ethernet multicast address mapping so that the 28 unique
IPv4 addresses map uniquely to Ethernet Addresses?

For example, this could be a new Proposed Standard RFC that also allows the
existing RFC 1112 to continue to be used for backwards compatibility?

Jim Stevens

---

From: Joe Touch <[email-masked]>
Date: Sun, 26 Jul 2020 23:30:54 -0700

First question - why?

As in, what problem has been observed that this would solve?

Note that the IPv6 is a locally administered Ethernet address, not one registered by the IEEE for the IETF.

Joe

> On Jul 26, 2020, at 10:44 PM, James A. (Jim) Stevens <james.a.stevens=[email-masked]> wrote:
> 
> 
> RFC 1112 maps the 28 unique IPv4 multicast address bits to 23 bits within the Ethernet address so that there is not a unique one to one mapping.
> 
> According to https://networklessons.com/multicast/multicast-ip-address-to-mac-address-mapping, this was because it would have cost $16,000 in 1990 to have reserved 16 OUIs (Organizational Unique Identifiers) to IP multicast MAC addresses so that the IPv4 multicast to Ethernet multicast addressing would be unique.
> 
> IPv6 in RFC 2464, maps the lower 32 bits of the IPv6 multicast addresses into the lower 32 bits of the Ethernet Address - so it looks like IEEE supports other IP address to ethernet multicast address mappings.
> 
> Question - Is any interest within IETF about working with IEEE to come up with an IPv4 to Ethernet multicast address mapping so that the 28 unique IPv4 addresses map uniquely to Ethernet Addresses?
> 
> For example, this could be a new Proposed Standard RFC that also allows the existing RFC 1112 to continue to be used for backwards compatibility?
> 
> Jim Stevens
> 
> 
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned