Subject: [pim] RFC 9186 on Fast Failover in Protocol Independent Multicast - Sparse Mode (PIM-SM) Using Bidirectional Forwarding Detection (BFD) for Multipoint Networks

From: [email-masked]
Date: Wed, 26 Jan 2022 19:21:04 -0800 (PST)

A new Request for Comments is now available in online RFC libraries.

        RFC 9186

        Title:      Fast Failover in Protocol Independent 
                    Multicast - Sparse Mode (PIM-SM) Using 
                    Bidirectional Forwarding Detection (BFD)
                    for Multipoint Networks 
        Author:     G. Mirsky,
                    X. Ji
        Status:     Standards Track
        Stream:     IETF
        Date:       January 2022
        Mailbox:    [email-masked],
                    [email-masked]
        Pages:      7
        Updates/Obsoletes/SeeAlso:   None

        I-D Tag:    draft-ietf-pim-bfd-p2mp-use-case-10.txt

        URL:        https://www.rfc-editor.org/info/rfc9186

        DOI:        10.17487/RFC9186

This document specifies how Bidirectional Forwarding Detection (BFD)
for multipoint networks can provide sub-second failover for routers
that participate in Protocol Independent Multicast - Sparse Mode
(PIM-SM). An extension to the PIM Hello message used to bootstrap a
point-to-multipoint BFD session is also defined in this document.

This document is a product of the Protocols for IP Multicast Working Group of the IETF.

This is now a Proposed Standard.

STANDARDS TRACK: This document specifies an Internet Standards Track
protocol for the Internet community, and requests discussion and suggestions
for improvements.  Please refer to the current edition of the Official
Internet Protocol Standards (https://www.rfc-editor.org/standards) for the 
standardization state and status of this protocol.  Distribution of this 
memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://www.ietf.org/mailman/listinfo/ietf-announce
  https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist

For searching the RFC series, see https://www.rfc-editor.org/search
For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk

Requests for special distribution should be addressed to either the
author of the RFC in question, or to [email-masked].  Unless
specifically noted otherwise on the RFC itself, all RFCs are for
unlimited distribution.

The RFC Editor Team
Association Management Solutions, LLC

---

From: Michael McBride <[email-masked]>
Date: Thu, 27 Jan 2022 05:17:04 +0000

Well done! Thanks to the authors for hanging in there to see this through.

mike

-----Original Message-----
From: IETF-Announce <[email-masked]> On Behalf Of [email-masked]
Sent: Wednesday, January 26, 2022 7:21 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RFC 9186 on Fast Failover in Protocol Independent Multicast - Sparse Mode (PIM-SM) Using Bidirectional Forwarding Detection (BFD) for Multipoint Networks

        RFC 9186

        URL:        https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Finfo%2Frfc9186&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043524793%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=7xTRQY%2FFns6To5oAnIrvpbYd465u02623WWcC%2FM7c%2FY%3D&amp;reserved=0

        DOI:        10.17487/RFC9186

This document specifies how Bidirectional Forwarding Detection (BFD) for multipoint networks can provide sub-second failover for routers that participate in Protocol Independent Multicast - Sparse Mode (PIM-SM). An extension to the PIM Hello message used to bootstrap a point-to-multipoint BFD session is also defined in this document.

STANDARDS TRACK: This document specifies an Internet Standards Track protocol for the Internet community, and requests discussion and suggestions for improvements.  Please refer to the current edition of the Official Internet Protocol Standards (https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fstandards&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=pz%2BVtA%2BQ1X59y7ljagLF4zl2YAp5UuV6lb%2BgoRS%2B4eY%3D&amp;reserved=0) for the standardization state and status of this protocol.  Distribution of this memo is unlimited.

This announcement is sent to the IETF-Announce and rfc-dist lists.
To subscribe or unsubscribe, see
  https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-announce&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=7z8qVUgjFE27EKJ7ijwJuG%2Bt6G0ulqbbIlFu8Ib6OBU%3D&amp;reserved=0
  https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailman.rfc-editor.org%2Fmailman%2Flistinfo%2Frfc-dist&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=2MjhVyHubojPgG9Q4IaO7Di2R%2FIyGraV56RFa1D1mWw%3D&amp;reserved=0

For searching the RFC series, see https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fsearch&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=c9%2FPUDO8lf%2Bww1leRtFIeW7P8GBeXiJys%2FQxXimXD4s%3D&amp;reserved=0
For downloading RFCs, see https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fretrieve%2Fbulk&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=g7NVTJqKQww91Wd0K3lUVSt%2BIBVcSbD8ysj7TKka6oc%3D&amp;reserved=0

Requests for special distribution should be addressed to either the author of the RFC in question, or to [email-masked].  Unless specifically noted otherwise on the RFC itself, all RFCs are for unlimited distribution.

The RFC Editor Team

_______________________________________________
IETF-Announce mailing list
[email-masked]
https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fietf-announce&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=7z8qVUgjFE27EKJ7ijwJuG%2Bt6G0ulqbbIlFu8Ib6OBU%3D&amp;reserved=0

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 27 Jan 2022 06:42:17 -0800

Thank you, Mike!

And many thanks to everyone in the group for sharing your expertise and
helping make this document useful and technically sound.

Regards,
Greg

On Wed, Jan 26, 2022 at 9:17 PM Michael McBride <
[email-masked]> wrote:

> Subject: RFC 9186 on Fast Failover in Protocol Independent Multicast -
> Sparse Mode (PIM-SM) Using Bidirectional Forwarding Detection (BFD) for
> Multipoint Networks
>
>         URL:
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Finfo%2Frfc9186&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043524793%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=7xTRQY%2FFns6To5oAnIrvpbYd465u02623WWcC%2FM7c%2FY%3D&amp;reserved=0
>
>         DOI:        10.17487/RFC9186
>
> This document specifies how Bidirectional Forwarding Detection (BFD) for
> multipoint networks can provide sub-second failover for routers that
> participate in Protocol Independent Multicast - Sparse Mode (PIM-SM). An
> extension to the PIM Hello message used to bootstrap a point-to-multipoint
> BFD session is also defined in this document.
>
> protocol for the Internet community, and requests discussion and
> suggestions for improvements.  Please refer to the current edition of the
> Official Internet Protocol Standards (
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fstandards&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=pz%2BVtA%2BQ1X59y7ljagLF4zl2YAp5UuV6lb%2BgoRS%2B4eY%3D&amp;reserved=0)
> for the standardization state and status of this protocol.  Distribution of
> this memo is unlimited.
>
> For searching the RFC series, see
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fsearch&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=c9%2FPUDO8lf%2Bww1leRtFIeW7P8GBeXiJys%2FQxXimXD4s%3D&amp;reserved=0
> For downloading RFCs, see
> https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fretrieve%2Fbulk&amp;data=04%7C01%7Cmichael.mcbride%40futurewei.com%7C9360e941bb19423ca2ed08d9e1442304%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637788505043681026%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=g7NVTJqKQww91Wd0K3lUVSt%2BIBVcSbD8ysj7TKka6oc%3D&amp;reserved=0
>
> Requests for special distribution should be addressed to either the author
> of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for unlimited
> distribution.
>
>
> The RFC Editor Team
> pim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pim
>