Subject: RE: OIDs of MACing algorithms

From: "chandrasekaran natarajan" <[email-masked]>
Date: Thu, 06 Apr 2000 02:42:15 -0700

hello,

Check out for OID's in  this site...

 www.alvestrand.no/objectid

chandar
--

On Thu, 6 Apr 2000 09:06:33    1G?kC6 wrote:
>> PKCS#5 might be what you're looking for. Check out 
>> www.rsasecurity.com/rsalabs 
>> - Tolga
>> >>> "Christopher Williams" <[email-masked]> 4/4/00 
>> 3:43:38 >>>
>> Does anybody know the algorithm identifiers for MACing 
>> algorithms such as
>> DES-MAC, Triple-DES-MAC, etc. that might be used as the basis 
>> of a password based MAC?
>
>	Thanks christopher! That's what I want to ask! :-)
>	Tolga, I read the PKCS#5 but it doesn't help me.
>
>	It specify PBE, but we just want to know the OID of DES-MAC and
>	Triple-DES-MAC in FIPS-113. 
>
>	I guess if the OID exsists, it may be under 1.3.14.3.2.(it's algorithms)
>	and 1.3.14.3.2.10 is desMAC we can use it but PKCS#11 specifies
>	3-DES-MAC doesn't require parameter and there is no way to specify
>	the key length if we use desMAC oid(that's why I looking for the OID of
>	3-DES-MAC :-( ).
>
>	I hope that the new PKCS#11 release contains the OIDs but I couldn't
>	download it from RSA ftp - it was shutdowned in these 2 days :-(.
>
>	Does any body knows it?
>
>	Thanks!
>

Send FREE April Fool's Greetings to your friends!
http://www.whowhere.lycos.com/redirects/American_Greetings.rdct

---

From: "±Ç¿ëÃ¶" <[email-masked]>
Date: Thu, 6 Apr 2000 21:22:31 +0900

>  www.alvestrand.no/objectid

	sorry. I have already known the site. 

	but it doesn't have. :-(