Subject: OIDs of MACing algorithms

From: "Christopher Williams" <[email-masked]>
Date: Tue, 4 Apr 2000 10:43:38 +0100

Does anybody know the algorithm identifiers for MACing algorithms such as
DES-MAC, Triple-DES-MAC, etc. that might be used as the basis of a password
based MAC?

Cheers

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 07 Apr 2000 13:20:03 -0400

>DES-MAC, Triple-DES-MAC, etc. that might be used as the basis of a password

Buried in Senario B2 it says for IR the manditory is HMAC-SHA1:

PasswordBasedMac:
   {1 2 840 113533 7 66 13}, with SHA-1 {1 3 14 3 2 26} as the owf
     parameter and HMAC-SHA1 {1 3 6 1 5 5 8 1 2} as the mac parameter;

A few others have missed this piece of information.

Robert Moskowitz
ICSA
Security Interest EMail: [email-masked]