Subject: RE: Current signature formats insufficient

From: Frank Balluffi <[email-masked]>
Date: Tue, 11 Jul 2000 08:05:44 -0700

Ben,

You are signing something you understand or have the right to understand
(before you sign it). I only hope that the man does not ask you sign a
message stating, "I agree to pay the man ..."

I hope that I will never knowingly sign anything I do not understand.

For example, there is a tremendous difference between signing "..." and "I
received [or forwarded] a message whose SHA-1 digest is ...".

I would only sign something that is bound to one or more verbs that I
understand.

For the life of me, I can't imagine a protocol that would expect a device or
person to sign a message that only states "...".

Frank

> -----Original Message-----
> From: Ben Laurie [mailto:[email-masked]]
> Sent: Tuesday, July 11, 2000 11:04 AM
> To: Frank Balluffi
> Cc: [email-masked]'; [email-masked]
> Subject: Re: Current signature formats insufficient
> 
> 
> Frank Balluffi wrote:
> > 
> > Denis,
> > 
> > You refer to non-binding signatures. Why would I bother 
> signing something if
> > it were non-binding?
> 
> When a man comes to the door with a package, I sign it because he asks
> for a signature. I do not consider that signature to be binding in any
> sense I understand the word.
> 
> Cheers,
> 
> Ben.
> 
> --
> http://www.apache-ssl.org/ben.html
> 
> Coming to ApacheCon Europe 2000? http://apachecon.com/
>

---

From: Ben Laurie <[email-masked]>
Date: Tue, 11 Jul 2000 17:09:20 +0100

> I hope that I will never knowingly sign anything I do not understand.

I didn't say I didn't understand it.

Cheers,

Ben.

---

From: "denis bider" <[email-masked]>
Date: Tue, 11 Jul 2000 19:04:53 +0200

[Frank Balluffi in response to Ben Laurie:]
> For the life of me, I can't imagine a protocol that would expect
> a device or person to sign a message that only states "...".

Oh, but there is such a protocol and it is used every day by thousands of
people. It's called 'a smart card reader'.

"..." is exactly what a smart card sees when it performs a signature
operation. Anyone who manages to break the security of the PC (which is
trivial) can tell the smart card to sign virtually anything.

This is why I think that we need a more elaborate signature format - one
which will take the real world, not the ideal world, into account.

denis