Subject: Re: X509 ACs - Too late, too little

From: [email-masked]
Date: Wed, 8 Nov 2000 08:32:21 -0500

No, it's really a joint effort, with folks from both organizations
participating.  At the risk of alienating others, for example, let
me point out Mr. Solo's prominent participation in both XML DSIG
and PKIX.  Other recent participants (notable to me) include extensive
commentary and example Gindin of IBM and Merlin from baltimore.ie.

>  I understand that IETF will convert the relatively =
> nice W3C HTML document into an ugly 7-bit ASCII RFC.

With any luck, the base document is XML which can easily be translated
to HTML and IETF-RFC. :)

>If the documents are (information-wise) identical,
>one is redundant and if they differ there is a potential
>interoperability problem in the works.

Joint publication happens all the time.  I am much less worried about incon-
sistencies between the IETF and W3C versions, than I am about inconsistencies
internal to the document itself.

	/r$

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 8 Nov 2000 15:49:30 +0100

Rick,

> With any luck, the base document is XML which can easily be translated
 
I don't want to waste too much PKIX-bamdwidth on this issue as I understand
it is rather "sensitive", but the statement above more or less dictates documents
without pictures of any complexity.  I.e. long-term I see some problems with the
IETF-RFC format.  The more complex thing gets, the worse it will be.

> internal to the document itself.

BTW, joint publication would be greatly simplified if the parties put their marks in the very
same document instead of doing their own versions.

Then by allowing a slightly more advanced way of describing things than offered
by plain-text you *may* even limit some problems with draft interpretation itself.

I have yet to see any really valid arguments (except for the absolute need for 7-bit ASCII
plain-text and "politics") for having TWO documents.

And in contrast to the AC-draft, there is a whole industry waiting for XML-DSIG!

/Anders

---

From: "Phillip H. Griffin" <[email-masked]>
Date: Wed, 08 Nov 2000 10:33:56 -0500

> IETF-RFC format.  The more complex thing gets, the worse it will be.

Your response still begs the question. Will 
the base W3C document be published as XML?

Phil

---

From: Rich Salz <[email-masked]>
Date: Wed, 08 Nov 2000 10:46:21 -0500

> Will the base W3C document be published as XML?

Looking at http://www.w3.org/TR/REC-xml which is the XML recommendation,
they seem to be trying to publish simultaneously in XML HTML XHTML and
PDF.  I am not sure which is definitive, nor what they'd do if errors
occured between formats.
	/r$