Subject: RE: OIDs as URIs

From: Peter Sylvester <[email-masked]>
Date: Mon, 27 Nov 2000 12:26:16 +0100 (MET)

> > 
> > in the last ETSI ESI meeting we discussed how we could 
> > represent OID (ASN.1)
> > as URIs. i proposed two schemes that seem reasonable. we 
> > would also like to
> > hear other opinions.

What about just making a reverse order OID in numeric form
and have some  OID-rev.oid.int  as a domain name. This
allows to make whetever delegation possible. It requires
of course, that the top level entities operate some
DNS servers. 

The relavite parts of the URL could then be used in a fixed
global method to point to different types of descriptions.

  http://1.4.1.1773.0.4.0.oid.int/specification.xml

where 4.0.oid.int would be delegated to ETSI.

---

From: Michael Zolotarev <[email-masked]>
Date: Thu, 30 Nov 2000 14:57:40 +1100

> 
> [snip]
> > A better deal for XML encoding would be to denote OIDs as 
> numbers only (so
> > that a machine is happy), and to have an attribute with a 
> human-readable
> > context - for example, friendlyName="dsaWithSha1encryption".
> > 
> > <OID  id="urn:oid:1.3.14.2.2.27" 
> friendlyName="dsaWithSha1Encryption"/>
> 
> While I like your suggestion very much, I would take it one 
> step further as
> follows:
> 
> <OID id="1.3.14.2.2.27" friendlyName="dsaWithSha1Encryption"/>
> 
> I don't see what the "urn:oid:" adds.
> 

I don't see either, frankly. The OID element will be always defined within a
particular namespace. Within that namespace (probably the only and single
one, referenced by every XML shema requiring using of oids), the meaning of
"id" attribute is unambiguous enough. So that we don't need to put any extra
qualifiers in front of the numbers, explaining what the numbers are.

---

From: Frank Balluffi <[email-masked]>
Date: Wed, 29 Nov 2000 21:00:01 -0800

Karl Scheibelhofer said:

> one main reason for expressing OIDs as URIs is that we want to use the
> within XML documents.

Then why not just define one or more XML elements. One possibility would be
to define an element that contains one number form for which its name may be
specified as an attribute:

<oid>
<oid-number name="iso">1</oid-number>
<oid-number name="member-body">2</oid-number>
<oid-number name="US">840</oid-number>
<oid-number name="rsadsi">113549</oid-number>
<oid-number name="pkcs">1</oid-number>
<oid-number name="pkcs-1">1</oid-number>
<oid-number name="rsaEncryption">1</oid-number>
</oid>

[I think I got that right.]

I am still confused as to the purpose of a Uniform Resource Identifier (URI)
for an object identifier. It seems to me that a URI identifies a way to use
a resource whereas an object identifier just identifies something (e.g., an
algorithm).

For example, suppose I have a URI for the RSA encryption algorithm, what can
I do with it?

Frank

---

From: Frank Balluffi <[email-masked]>
Date: Wed, 29 Nov 2000 21:09:49 -0800

Phil,

So it sounds like pot://1-800-CALL-ROB?1.3.14.3.2.27 (where pot stands for
plain-old telephone) may be more useful than oid://1.3.14.3.2.27 :-)?

Frank

> -----Original Message-----
> From: Phillip H. Griffin [mailto:[email-masked]]
> Sent: Thursday, November 30, 2000 4:30 AM
> To: [email-masked]
> Subject: Re: OIDs as URIs
> 
> 
> Turns out that even if you're an old geezer that
> knows oiw is open implementors workshop, you still
> wouldn't have a clue to contact Rob. And if you did
> he'd tell you as former registrar that the registry 
> has long been closed down.
> 
> The numbers are all that a program needs to switch 
> off of. Either the application knows what the number
> means or it doesn't. Very simple.
> 
> Phil
> 
> 
> 
> Karl Scheibelhofer wrote:
> > 
> > > -----Original Message-----
> > > From: Rich Salz [mailto:[email-masked]]
> > > Sent: Wednesday, November 29, 2000 12:52 PM
> > > To: Karl Scheibelhofer
> > > Cc: [email-masked]
> > > Subject: Re: OIDs as URIs
> > >
> > >
> > > > it should at least be possible to use a kind of 
> NameAndNumberForm.
> > >
> > > Why?  Under what circumstances is "enterprise-mib" better 
> than "2"?
> > > We already know that names will hurt machine processing, 
> and humans can
> > > clearly read numbers.  What is the point of having the 
> name?  Who will
> > > be helped, and what will they do with it?
> > 
> > within XML documents. normally one can read a XML document 
> with a text
> > editor and get a good idea of what it is all about.
> > if you use pure number OIDs in it, you have normally no 
> idea, what that
> > means.
> > try to guess waht 1.3.14.3.2.27 means (without browsing into some
> > web-directory).
> > then try to read {iso(1) identified-organization(3) oiw(14) 
> secsig(3)
> > algorithms(2) sha1(27)}.
> > i think we do not need discuss, what is easier to read for humans.
> > 
> > regards
> > 
> >   Karl Scheibelhofer
> > 
> > --
> > 
> > Karl Scheibelhofer, <mailto:[email-masked]>
> > Institute for Applied Information Processing and 
> Communications (IAIK)
> > at Technical University of Graz, Austria, http://www.iaik.at
> > Phone: (+43) (316) 873-5540
> 
> -- 
> Phil
> ----
> Phillip H. Griffin      Griffin Consulting
> http://asn-1.com        Secure ASN.1 Design & Implementation
> +1-919-832-7008         1625 Glenwood Avenue, Five Points
> +1-919-832-7390 [fax]   Raleigh, North Carolina  27608  USA
> ------------------------------------------------------------
>