Subject: RE: Scope of PKIXML-WG. Was: Should PKIX protocols support XML w ell?

From: Michael Zolotarev <[email-masked]>
Date: Wed, 22 Nov 2000 15:03:38 +1100

Let me say that XMLDSIG is not a replacement for PKCS#7-signing either:
PKCS#7 is a general-purpose structure for signing data blobs. And XMLDSIG is
a format which was designed specifically to be 'native' for signing XML
documents. 
As much as you wouldn't normally use PKCS#7 to sign XML documents today, you
wouldn't use XMLDSIG to sign a random binary data block. We are talking
practical use, of course, not a theory.

> -----Original Message-----
> From: Peter Lipp [mailto:[email-masked]]
> Sent: Tuesday, 21 November 2000 18:06
> To: EKR; Anders Rundgren
> Cc: PKIX-List
> Subject: AW: Scope of PKIXML-WG. Was: Should PKIX protocols 
> support XML
> well?
> 
> 
> Eric,
> 
> >XMLDSIG is certainly not a replacement for PKCS-7. How could it
> >be, since it does not provide for encryption?
> Ok, let it be half a replacement and the other half currently 
> being worked
> on in the XML-encryption-(list,WG?) - so what's the point...
> 
> Peter
>

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 22 Nov 2000 08:59:23 +0100

> practical use, of course, not a theory.

I don't get this at all.  PKCS #7 is indeed used to sign documents like EDI data which
is not binary.  It is a part of the OBI standard which I am actively working with.

Regarding XMLDSIG it is equally well fitted to sign "blob" data although it must be converted to
BASE64 and inserted in an XML container document.  This is how you must treat a lot of
non-xml data like word-documents etc. A part from using 30% more space than native
blobs do, this will happen. Today it may be theory due to the short time XMLDSIG has
been avialable.  Yes, it is not even RFC yet.

Anders