Subject: I-D ACTION:draft-ietf-pkix-scvp-04.txt

From: [email-masked]
Date: Wed, 29 Nov 2000 06:31:12 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Public-Key Infrastructure (X.509) Working Group of the IETF.

	Title		: Simple Certificate Validation Protocol (SCVP)
	Author(s)	: A. Malpani, P. Hoffman, R. Housley
	Filename	: draft-ietf-pkix-scvp-04.txt
	Pages		: 
	Date		: 28-Nov-00
	
The SCVP protocol allows a client to offload certificate handling to a
server. The server can give a variety of valuable information about the
certificate, such as whether or not the certificate is valid, a chain
to a trusted root, and so on. SCVP has many purposes, including
simplifying client implementations and allowing companies to centralize
their trust and policy managment.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pkix-scvp-04.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-pkix-scvp-04.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-pkix-scvp-04.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Anders Rundgren" <[email-masked]>
Date: Wed, 29 Nov 2000 15:52:13 +0100

I took a short look into this (and may have got it all wrong), as I have heard that it would
support XML.  It apparently does, what I wonder if, if this is the way to do XML support.
That X509 certs are coded as Base64 blobs is OK, but why must requests
be coded as OIDs?

I.e. all protocols have som kind of implicit API that in ASN.1 is mapped through
OID-based structures but I don't think this is the most appropriate for XML.

This is similar requiring that Java and VisualBasic implementations of an API
must be identically structured in spite of very different language features.

Maybe the idea is that the ASN.1 and XML implementations should always be
aligned and pushed together?  I would not base future and potentially
evolving standards like SCVP on such ideas.   I.e. a vendor should have the option to
only support one of the paths.

Anders