Subject: RE: OIDs as URIs

From: Michael Zolotarev <[email-masked]>
Date: Thu, 30 Nov 2000 13:26:53 +1100

I dare to say that for a human eye {iso(1) identified-organization(3)
oiw(14) secsig(3) algorithms(2) sha1(27)} is too much as well. And a human
doesn't make sense of it - even if the length of it pleases.

A better deal for XML encoding would be to denote OIDs as numbers only (so
that a machine is happy), and to have an attribute with a human-readable
context - for example, friendlyName="dsaWithSha1encryption".

<OID  id="urn:oid:1.3.14.2.2.27" friendlyName="dsaWithSha1Encryption"/>

Michael

> -----Original Message-----
> From: Karl Scheibelhofer [mailto:[email-masked]]
> Sent: Wednesday, 29 November 2000 22:09
> To: Rich Salz
> Cc: [email-masked]
> Subject: RE: OIDs as URIs
> 
> 
> > -----Original Message-----
> > From: Rich Salz [mailto:[email-masked]]
> > Sent: Wednesday, November 29, 2000 12:52 PM
> > To: Karl Scheibelhofer
> > Cc: [email-masked]
> > Subject: Re: OIDs as URIs
> >
> >
> > > it should at least be possible to use a kind of NameAndNumberForm.
> >
> > Why?  Under what circumstances is "enterprise-mib" better than "2"?
> > We already know that names will hurt machine processing, 
> and humans can
> > clearly read numbers.  What is the point of having the 
> name?  Who will
> > be helped, and what will they do with it?
> 
> one main reason for expressing OIDs as URIs is that we want to use the
> within XML documents. normally one can read a XML document with a text
> editor and get a good idea of what it is all about.
> if you use pure number OIDs in it, you have normally no idea, 
> what that
> means.
> try to guess waht 1.3.14.3.2.27 means (without browsing into some
> web-directory).
> then try to read {iso(1) identified-organization(3) oiw(14) secsig(3)
> algorithms(2) sha1(27)}.
> i think we do not need discuss, what is easier to read for humans.
> 
> regards
> 
>   Karl Scheibelhofer
> 
> --
> 
> Karl Scheibelhofer, <mailto:[email-masked]>
> Institute for Applied Information Processing and Communications (IAIK)
> at Technical University of Graz, Austria, http://www.iaik.at
> Phone: (+43) (316) 873-5540
>

---

From: Aram Perez <[email-masked]>
Date: Wed, 29 Nov 2000 18:55:51 -0800

Michael Zolotarev wrote:

[snip]
> <OID  id="urn:oid:1.3.14.2.2.27" friendlyName="dsaWithSha1Encryption"/>

While I like your suggestion very much, I would take it one step further as
follows:

<OID id="1.3.14.2.2.27" friendlyName="dsaWithSha1Encryption"/>

I don't see what the "urn:oid:" adds.

Feliz Navidad,
Aram Perez