Subject: RE: OCSP-X vs SCVP

From: Michael Zolotarev <[email-masked]>
Date: Fri, 10 Nov 2000 11:34:10 +1100

>  But that ain't how the world works, and 
> that ain't how
> people want it to work.

Proof, please. I want the proof.

> 
> Of course people will use APIs.  But one way to judge the success of a
> protocol is by the number of toolkits that support it.  I 
> believe that it's
> important to design a protocol to be easy to implement, even 
> if the vast
> majority of the protocol's users will never care.
> 
As one of the vendors, I dare to claim that it absolutely does not matter
for *a vendor* whether to deal with ASN1 or XML. There are other problems to
tackle, much more serious, than specifics of the encoding. And every vendor
has tools to handle encoding. There are tools for XML, and tools ASN. You
want one - ask me. Nobody starts from scratch.

> (No flames, please!  I'm quite happy with either standard.  
> If I've one
> criticism, it's that the ASN.1 specs are not free.)
> 
> 		Marc
> 
> +-------------------------------------------------------------
> -----------+
>  Marc Branchaud                                  \/
>  Chief PKI Architect                             /\CERT 
> INTERNATIONAL INC.
>  [email-masked]        PKI References page:              
> www.xcert.com
>  604-640-6227          www.xcert.com/~marcnarc/PKI/
> +-------------------------------------------------------------
> -----------+
>

---

From: Marc Branchaud <[email-masked]>
Date: Thu, 09 Nov 2000 16:54:19 -0800

> Proof, please. I want the proof.

The fact that people seem to care about this is proof enough for me...

> want one - ask me. Nobody starts from scratch.

It seems to me that many *non-vendors* might want to implement the protocol.

But I see your point.  You weren't talking about an OCSP API, but instead an
ASN.1 (as opposed to XML) API.  At that level, I agree: people can pick up
toolkits to work with either.

Many, though, seem to be reluctant to have to work with both.  I suppose
there this is where the crux of the issue lies.  Most PKI folk work in ASN.1,
while many non-PKI folk use XML.  The non-PKI folk want their XML apps to use
PKI (as do the PKI folks, I might add), but they don't want to bloat their
apps with an ASN.1 toolkit.  Similarly, the PKI folk don't want to bloat
their apps with an XML toolkit.

Either some non-PKI folk have to want PKI badly enough to accept the bloat,
or the PKI folk have to want to spread PKI badly enough to adopt XML.  Either
way, someone has to give.

		Marc

+------------------------------------------------------------------------+
 Marc Branchaud                                  \/
 Chief PKI Architect                             /\CERT INTERNATIONAL INC.
 [email-masked]        PKI References page:              www.xcert.com
 604-640-6227          www.xcert.com/~marcnarc/PKI/
+------------------------------------------------------------------------+

---

From: Michael Ströder <[email-masked]>
Date: Fri, 10 Nov 2000 08:14:56 +0100

Marc Branchaud wrote:
> 
> The non-PKI folk want their XML apps to use
> apps with an ASN.1 toolkit.

Most times it's easier to find a mature XML kit than a ASN.1 kit.
But IMHO ASN.1 is not the main problem when deploying this
X.509-based stuff.

Ciao, Michael.

---

From: Timothy Fisher <[email-masked]>
Date: Sat, 11 Nov 2000 17:23:08 -0500

A general comment:

A gradual move towards XML and away from ASN1 in the PKI world would
be a great benefit to the developer community and I believe the
e-business community at large...
XML would be a great step in opening this technology to a wider base
of expertise.

-- 
Sincerely,
 Timothy Fisher                       mailto:[email-masked]

Friday, November 10, 2000, 2:14:56 AM, you wrote:

>> apps with an ASN.1 toolkit.

MS> Most times it's easier to find a mature XML kit than a ASN.1 kit.
MS> But IMHO ASN.1 is not the main problem when deploying this
MS> X.509-based stuff.

MS> Ciao, Michael.