Subject: RE: OCSP-X vs SCVP

From: Ambarish Malpani <[email-masked]>
Date: Fri, 10 Nov 2000 14:26:20 -0800

Agreed, we are talking about XML vs DER.

I don't know that XER has enough traction/usage to make it a
viable solution in XML land (even though it would make things
very simple in the ASN.1 land).

Regards,
Ambarish

---------------------------------------------------------------------
Ambarish Malpani
Architect                                                650.567.5457
ValiCert, Inc.                                  [email-masked]
339 N. Bernardo Ave.                          http://www.valicert.com
Mountain View, CA 94043

> -----Original Message-----
> From: Paul Koning [mailto:[email-masked]]
> Sent: Friday, November 10, 2000 11:26 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: OCSP-X vs SCVP
> 
> 
> >>>>> "Ambarish" == Ambarish Malpani <[email-masked]> writes:
> 
>  Ambarish> Hi Guys, Just to keep things simple, it would be good to
>  Ambarish> break up this debate into 2 separate discussions:
> 
>  Ambarish> 1. Should PKIX protocols/work items support XML well or
>  Ambarish> should they just stay with ASN.1
> 
> Are we talking about XML vs. ASN.1 or XML vs. BER/XER/*ER ?   It
> sounds more like the latter, and given that "ASN.1" is sometimes
> mentioned when a more precise reference would be to
> BER/DER/etc. instead, I wonder...
> 
>        paul
>

---

From: Rich Salz <[email-masked]>
Date: Fri, 10 Nov 2000 20:04:49 -0500

> Agreed, we are talking about XML vs DER.

I don't think so.  I think it's XML "versus" ASN.1 and DER: the whole system.

With the advent of XML-Schema, there is now an XML datatype description
language that supports complex types (struct), constraints, inheritance, etc. 
(It's an interesting combination of pragmatism -- constraints can be expressed
as Perl regular expressions -- and elegance: an XML schema follows XML syntax
and is therefore a valid XML document.)

I can see that XER is of interest to ASN.1 folks, but I dont' see any real
interest from the XML development community.  It's useful to perserve existing
legacy (sic) ASN.1 definitions, but XML folks who want to describe data will
use DTD's and schema's.  (If only because the specifications are free.)  I
strongly believe the XML community will not enlarge the ASN.1 community.
	/r$

---

From: "Phillip H. Griffin" <[email-masked]>
Date: Fri, 10 Nov 2000 22:34:29 -0500

> I don't think so.  I think it's XML "versus" ASN.1 and DER: the whole system.

Well, if you're talking of politics I agree. 
But if you only consider the technical aspects
then XML (markup) is only a textual transfer
syntax and DER is a binary transfer syntax.

> and is therefore a valid XML document.)

If there were but one XML schema life would 
be easy. But there are many XML schema, and 
more seem to be popping up in various XML
communities.

Currently, there are communities that wish 
to use only XML markup and those that wish to
use XML markup with DTDs (which carry only
the structure component on ASN.1 notation,
but no data type or constraint information).

Then there are those relying on XML-schema
and those betting on some earlier schema
like derivative like BizTalk, and others in
the process of building DT4-DTDs (Data Types
for DTDs), etc.

As for constraint capabilities, ASN.1 has just
adopted a PATTERN constraint, which is used in
X9.68:

DNSName ::= VisibleString (SIZE(1..MAX)) 
               (PATTERN "[A-Za-z0-9 .-]*")

There are several contraints available in ASN.1 
that have no counterpart in XML-schema. And XML
schema is still under development, with notable
changes made just recently to accommodate the 
XMLDSIG efforts.

> strongly believe the XML community will not enlarge the ASN.1 community.

Agreed. Free specifications are an important 
consideration. The X.500 Group and the ASN.1 
group are both working to have the current 
ASN.1 specifications made free. Of course, 
the ones that are being relied upon by the 
IETF are already freely available.

Phil
----
Phillip H. Griffin      Griffin Consulting
http://asn-1.com        Secure ASN.1 Design & Implementation
+1-919-832-7008         1625 Glenwood Avenue, Five Points
+1-919-832-7390 [fax]   Raleigh, North Carolina  27608  USA
------------------------------------------------------------

---

From: "Anders Rundgren" <[email-masked]>
Date: Sat, 11 Nov 2000 10:18:44 +0100

Rich (et al).

> and is therefore a valid XML document.)

I don't get it.

When I some days ago launched the idea that AC's should (or could) be based on XML schemas
there were hardly any sentiment for that.

Some even cocluded that XML was not a PKIX-item!

Now I see a lot of XML "promotion" in an other PKIX-area which is interesting but slightly puzzling.

IMO ACs have at least the same "informational content" as OCSP-X and SCVP. 
Each AC "authorization profile", "receipt" or "ticket" ought to be just perfect to express
as an XML schema.  Wouldn't it?

Anders

---

From: Timothy Fisher <[email-masked]>
Date: Sat, 11 Nov 2000 17:37:51 -0500

Agreed.

-- 
Sincerely,
 Timothy Fisher                       mailto:[email-masked]

>> Agreed, we are talking about XML vs DER.

RS> I don't think so.  I think it's XML "versus" ASN.1 and DER: the whole system.

RS> With the advent of XML-Schema, there is now an XML datatype description
RS> language that supports complex types (struct), constraints, inheritance, etc. 
RS> (It's an interesting combination of pragmatism -- constraints can be expressed
RS> as Perl regular expressions -- and elegance: an XML schema follows XML syntax
RS> and is therefore a valid XML document.)

RS> I can see that XER is of interest to ASN.1 folks, but I dont' see any real
RS> interest from the XML development community.  It's useful to perserve existing
RS> legacy (sic) ASN.1 definitions, but XML folks who want to describe data will
RS> use DTD's and schema's.  (If only because the specifications are free.)  I
RS> strongly believe the XML community will not enlarge the ASN.1 community.
RS>         /r$

---

From: Timothy Fisher <[email-masked]>
Date: Sat, 11 Nov 2000 17:40:44 -0500

Agreed there are currrently competing "schema/DTD" like efforts...
But this is exactly where standards would help...   These issues
could certainly be addressed within PKI standards documents that were
based on XML.

Friday, November 10, 2000, 10:34:29 PM, you wrote:

>> I don't think so.  I think it's XML "versus" ASN.1 and DER: the whole system.

PHG> Well, if you're talking of politics I agree. 
PHG> But if you only consider the technical aspects
PHG> then XML (markup) is only a textual transfer
PHG> syntax and DER is a binary transfer syntax.

>> and is therefore a valid XML document.)

PHG> If there were but one XML schema life would 
PHG> be easy. But there are many XML schema, and 
PHG> more seem to be popping up in various XML
PHG> communities.

PHG> Currently, there are communities that wish 
PHG> to use only XML markup and those that wish to
PHG> use XML markup with DTDs (which carry only
PHG> the structure component on ASN.1 notation,
PHG> but no data type or constraint information).

PHG> Then there are those relying on XML-schema
PHG> and those betting on some earlier schema
PHG> like derivative like BizTalk, and others in
PHG> the process of building DT4-DTDs (Data Types
PHG> for DTDs), etc.

PHG> As for constraint capabilities, ASN.1 has just
PHG> adopted a PATTERN constraint, which is used in
PHG> X9.68:

PHG> DNSName ::= VisibleString (SIZE(1..MAX)) 
PHG>                (PATTERN "[A-Za-z0-9 .-]*")

PHG> There are several contraints available in ASN.1 
PHG> that have no counterpart in XML-schema. And XML
PHG> schema is still under development, with notable
PHG> changes made just recently to accommodate the 
PHG> XMLDSIG efforts.

>> strongly believe the XML community will not enlarge the ASN.1 community.

PHG> Agreed. Free specifications are an important 
PHG> consideration. The X.500 Group and the ASN.1 
PHG> group are both working to have the current 
PHG> ASN.1 specifications made free. Of course, 
PHG> the ones that are being relied upon by the 
PHG> IETF are already freely available.

PHG> Phil
PHG> ----
PHG> Phillip H. Griffin      Griffin Consulting
PHG> http://asn-1.com        Secure ASN.1 Design & Implementation
PHG> +1-919-832-7008         1625 Glenwood Avenue, Five Points
PHG> +1-919-832-7390 [fax]   Raleigh, North Carolina  27608  USA
PHG> ------------------------------------------------------------