Subject: RE: Security with XML vs ASN.1. Was: Should PKIX protocols suppo rt XML well

From: Michael Zolotarev <[email-masked]>
Date: Thu, 16 Nov 2000 14:49:42 +1100

> 
>            AttributeCertificateInfo ::= SEQUENCE {
>                 version              AttCertVersion DEFAULT v1,
>                 holder               Holder,
>                 issuer               AttCertIssuer,
>                 signature            AlgorithmIdentifier,
>                 serialNumber         CertificateSerialNumber,
>                 attrCertValidityPeriod   AttCertValidityPeriod,
> // PKIX:
>                 attributes           SEQUENCE OF Attribute,
> // XML-AC: 
>                 attributes           
> embedded-XML-data-using-a-unique-identifyable-app-defined-attr
> ibute-schema, 
>                                                  // No 
> predefined attributes (or extensions) whatsoever
> 

Anders,

Why do you say "predefined"?
The draft says: "Some standard attribute types are defined in section 4.5."
<<BTW it must be 4.4. Editorial.>>

It does not imply that these attributes, all or some of them, must be
present in every AC. By no means so. An AC may contain a single attribute
called "MyDog'sMumMaidenName".

The profile defined by PKIX is as flexible as anything else, and using ASN1
makes no difference in this regards compared to XML.

M

---

From: "Anders Rundgren" <[email-masked]>
Date: Thu, 16 Nov 2000 05:42:35 +0100

Michael,

> called "MyDog'sMumMaidenName".

Pre-defined refers to the fact that they have OIDs already while other types
requires new OIDs.
 
> makes no difference in this regards compared to XML.

For market acceptance (=deployment) some people in this list do not share your views entirely.

On a hard-core bit-level you are right.  But you still don't have an ASN.1 schema and
even if there is one, there is no support in my computer, nor in java AFAIK.

When will you make this available?  Will Bill put in W2K? Not a chance in hell!

Windows won over OS/2 due to pre-install (default).  XML will do the same with ASN.1.

I told OS/2 "zelots" that Windows would win *years* before it actually did.  I was always
put down by their view that OS/2 was so much better, that Windows would have no chance.
I said sure, but if it is not on most computers by default it will stay marginal. In spite of 
possible technical advantages.

Pardon me for refraining to "marketing BS" but if the majority of PKIX still believe that schemas
is a largely redundant feature created for an ignorant e-business developer community, 
marketing BS is all that is left... :-) :-)

Anders

---

From: "Phillip H. Griffin" <[email-masked]>
Date: Thu, 16 Nov 2000 15:45:02 -0500

Anders Rundgren wrote (in part):
 
> When will you make this available?  Will Bill put in W2K? Not a chance in hell!

Several Windows components use ASN.1 that may be on
your computer. The logon screen for Windows NT uses
ASN.1, as do Internet Explorer, Microsoft Netmeeting, 
Microsoft Outlook. For example, if you go into IE,
click on Help, then About, then Licences, and scroll
down a little, you'll see that it uses ASN.1 tools 
from OSS (Open Systems Solutions).

There are probably others as well. ASN.1 is very much
core technology. It is deployed so far down inside of
products that it doesn't get much notice.

Phil
----
Phillip H. Griffin      Griffin Consulting
http://asn-1.com        Secure ASN.1 Design & Implementation
+1-919-832-7008         1625 Glenwood Avenue, Five Points
+1-919-832-7390 [fax]   Raleigh, North Carolina  27608  USA
------------------------------------------------------------

---

From: "Anders Rundgren" <[email-masked]>
Date: Fri, 17 Nov 2000 08:11:07 +0100

Steve,

> So, if you were willing to put you money where your mouth was long 
> ago, I assume you invested heavily in MS, made lots of money, and 
> thus your involvement in PKI technology is merely an avocation, right?

Unfortunately I did not invest a cent in MS.  However, I have invested quite a
bit of time, money, and prestige in own PKI ventures and intend to make a fortune on that  :-)

That's I why I am so keen on marketing issues like XML etc.

Anders