Subject: Re: ASN.1 readability (was Re: Semi-annual reminder: dumpasn1 utility available)

From: "Robert Klerer" <[email-masked]>
Date: Mon, 11 Dec 2000 11:23:52 -0500

But this is where the argument for efficiency breaks.  The relaying party
for the PKI is often a human being not always a computer program.  Often
when my browser (or email client) asks me if I want to trust a certificate,
I have a hard time finding my trusty ASN.1 decoder ring in that limited
dialog box.  I certainly cannot trust the browser to do it, since they can
not even display the subject name in a consistent way.  If I could read the
certificate source itself, I could resolve whatever suspicion I have to the
validity of the information and let my software validate the cryptographic
validity of the signature.

From: "Phillip H. Griffin" <[email-masked]>
>
>
> Anders Rundgren wrote (in part):
>
> snip
>
> >  Using XML I would neither have had to "guess" element
> >  usage, nor use a "debugger".
>
> Really? Consider the ASN.1 value
>
>    concord INTEGER ::= 3
>
> which could be transferred directly as text or DER
> encoded into the binary value 0x020103.
>
> What does representing this value using XML mark
> up such as
>
>    <concord> 3 </concord>
>
> tell you?
>
> Do I mean a how I rate a city, a quantity of grapes,
> or that the treaty is behind door number number three?
>
> I agree of course that the mark up format may be easier
> for programmers who lack tools or reasonable skills and
> training to debug. But consider actual usage.
>
> I may debug this message for a short while during a
> program development period, then deploy the program
> and transfer this message billions of times with no
> human intervention.
>
> Why would I wish to transfer 22 bytes of information
> instead of three?
>
> What advantage does transferring 19 extra bytes give
> my application?
>
> Once deployed, will it matter to the performance of
> the program whether or not this message can be easily
> read by a human?
>
> If a client should receive a broken message from my
> program, will the users lot be improved if they can
> correct the broken message with NotePad?
>
> Phil
>

---

From: Aram Perez <[email-masked]>
Date: Mon, 11 Dec 2000 09:16:50 -0800

> validity of the signature.

You may be able to "resolve whatever suspicion" you "have to the validity of
the information." But how about your grandmother? I know my grandmother will
not, whether the information is displayed in XML or some textual version of
ASN.1/BER/DER.

Regards,
Aram Perez

[snip]