Subject: Permanet identifier assignement

From: Juan Carlos Pérez Aguayo <[email-masked]>
Date: Thu, 21 Dec 2000 16:02:40 -0400

Is the id-at-dnQualifier attribute a suitable assignement for a single name
used for PI?

By example, think that a subject has a unique identifier like this :
"12523912-9" (my own :) ):

  Subject:
     C=CL, O=My org, OU = My unit, CN= Jhon Davis

  PI:

     assignerAuthority:i.e OID for authority in the domain
     identifier:
        OID.2.5.4.46 = '12523912-9'

regards

Juan Carlos

> -----Mensaje original-----
> De: Juan Carlos Pérez Aguayo [mailto:[email-masked]]
> Enviado el: Miércoles, 20 de Diciembre de 2000 17:38
> Para: Denis. Pinkas
> Asunto: Permanet identifier syntax
>
>
> From the the PI draft:
>
>    PermanentIdentifier ::=     SEQUENCE {
>            assignerAuthority        GeneralName OPTIONAL,
>            identifier               Name
>    }
>
>
> I my country, we have national unique identifiers like
> "12523912-9" (my own identifier) a PrintableString.
>
> Which is the RDN suitable for using for it identifier? Into
> CN,SerialNumber, GivenName...?
>
> Why need a RDN into identifier and not a single attribute?
>
> Regards
>
> Juan Carlos
>

---

From: "Tom Gindin" <[email-masked]>
Date: Thu, 21 Dec 2000 14:39:02 -0500

There was a lengthy discussion last year on which attribute to use in
such cases, involving many messages.  The decision made was to prefer the
use of X.520's serialNumber attribute over DNQualifier or any possible new
attribute for this purpose (DNQualifier was the only standard attribute
frequently suggested as a possible alternative).  The message recording the
decision was http://www.imc.org/ietf-pkix/old-archive-99/msg03140.html.

          Tom Gindin

Juan Carlos Pérez Aguayo <[email-masked]> on 12/21/2000
03:02:40 PM

Please respond to <[email-masked]>

To:   "Ietf-Pkix" <[email-masked]>
cc:   "Denis. Pinkas" <[email-masked]>, Tom Gindin/Watson/IBM@IBMUS
Subject:  Permanet identifier assignement

  Subject:

  PI:

regards

Juan Carlos