Subject: Who can help me?

From: pki_wby_cn <[email-masked]>
Date: Tue Dec 5 07:55:10 2000

hello, all:

In rfc2459, there are two methods to calculate authority key identifier:
(1) 160-bit SHA-1 hash of the value of the BIT STRING subjectPublicKey
    (excluding the tag,length,and number of unused bits)
(2) a four bit type field with the value 0100 followed by the least 
    significant 60 bits of SHA-1 hash of the value of the BIT STRING
    subjectPublicKey

Here is the public key of a thawte CA cert
(the attchment contain this public key) :
	3081 8902 8181 00B3 695A 
	97D4 D016 0B7A B5C5 5DE9 
	219C 2372 CD12 4C4B F77E 
	CFC7 FBCA 7224 F442 52AC 
	5795 E37B 617A 1784 E7FD 
	7239 3894 B4EA ED65 A792 
	065E BDE0 65F6 19BB 9479 
	764C 3EB9 6870 7584 1CF4 
	1174 00BC 052C 4F09 0317 
	31CC F441 D472 C6A6 5DE2 
	8844 B08B 2EC4 4DF1 F0D6 
	853E 6CF3 9594 7891 7E40 
	E99C D18D 1557 8EC2 73E5 
	30DE 46F5 4F02 0301 0001

In the user certificate, the authority key identifier is :
	88AB F160 8366 55F4 E458 C746 1DC0 61BD 23D7 C38C

I calculate according the first method, but got the result:
	4B7E E315 BBE3 2BEA 15C8 5F3C AB2E 3F36 880E 64A3
	~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Please tell me why I cannot got the correct result ????????
______________________________________

---

From: Peter Hesse <[email-masked]>
Date: Tue, 5 Dec 2000 10:53:59 -0500

The methods you mention are only recommendations:  "Where a key identifier
has not been previously established, this specification recommends use of
one of these methods for generating keyIdentifiers."

The issuer can put anything in their subjectKeyIdentifier as long as it
matches all the authorityKeyIdentifiers that it creates.  You should never
attempt to calculate authorityKeyIdentifiers, only use the values that are
present in the certificates.

--Peter

---------------------------------------------------------------- 
Peter M. Hesse   [email-masked]   http://www.cygnacom.com
      CygnaCom Solutions, An Entrust Technologies Company
      (703)270-3523(voice) (703)848-0960(fax) ICQ#1942828 
"Pay no attention to what the critics say; there has never been 
a statue set up in honor of a critic." --Jean Sibelius

-----Original Message-----
From: pki_wby_cn [mailto:[email-masked]]
Sent: Tuesday, December 05, 2000 2:55 AM
To: [email-masked]
Subject: Who can help me?

hello, all: