Subject: Ordering of RDN's within the DN

From: "Covey, Carlin" <[email-masked]>
Date: Fri, 22 Dec 2000 08:58:20 -0800

Does anyone know of a standard ordering for the RDN's for locality, state,
and postalCode when they appear in a DN?

- Carlin Covey
  Cylink Corp.

---

From: Russ Housley <[email-masked]>
Date: Sat, 23 Dec 2000 15:43:25 -0500

Carlin:

You local schema determines the ordering.  The X.500 series of 
recommendations does not impose an ordering.

Russ

---

From: Peter Williams <[email-masked]>
Date: Wed, 27 Dec 2000 11:00:17 -0800

NADF was one standards organization (defunct, but at one
time respected by our leaders) that specifies a naming architecture
that structures and organizes certain namespaces, by RDN. The
architecture was founded on the need for cooperative
management of a shared namespace by competitive providers. The
NBDF addressed the issues in focus in a public directory in which 
otherwise privately-managed names(disclosing considerable intelligence 
about a company) would be partially disclosed.

NADF essentially specified a "Bridge-Directory". There
was a specific naming concept that interact with PKI
DN naming - where cert DNs and directory DNs are not
the same, to accomodate realworld needs for name
management and name distribution privacy requirements.

http://www.cis.ohio-state.edu/htbin/rfc/rfc1417.html

-----Original Message-----
From: Covey, Carlin [mailto:[email-masked]]
Sent: Friday, December 22, 2000 8:58 AM
To: [email-masked]
Subject: Ordering of RDN's within the DN

- Carlin Covey
  Cylink Corp.

---

From: Paul Lambert <[email-masked]>
Date: Wed, 27 Dec 2000 11:58:21 -0800

The ftp archive referenced in rfc1417 no longer contain the documents.  

Try: http://www.ten-34.net/np/ds/nadf.html

Paul

-----Original Message-----
From: Covey, Carlin [mailto:[email-masked]]
Sent: Friday, December 22, 2000 8:58 AM
To: [email-masked]
Subject: Ordering of RDN's within the DN

- Carlin Covey
  Cylink Corp.