Subject: RE: WG Last Call, PKI Repository Locator

From: Philip Hallam-Baker <[email-masked]>
Date: Wed, 10 Jan 2001 10:51:28 -0800

This sounds like a good plan, the SRV draft is not really adapted to a
multi-layer protocol, but it really does not matter too much I guess so long
as clients are consistent.

The options are (I guess):

1) _pkix._http._tcp
2) _pkix_http._tcp
3) _pkixhttp._tcp

I don't really care which we do... (1) seems cleanest???

		Phill

> -----Original Message-----
> From: Oscar Jacobsson [mailto:[email-masked]]
> Sent: Tuesday, January 09, 2001 5:27 AM
> To: Tim Polk
> Cc: [email-masked]
> Subject: Re: WG Last Call, PKI Repository Locator
> 
> 
> Tim Polk wrote:
> > As most of you know, there is no requirement for a WG Last Call for
> > experimental RFCs.  However, this specification has been 
> through only a
> > single draft, and has drawn a very small number of 
> comments.  I am hoping
> > that a Last Call will prompt some of you to review the 
> specification.
> 
> I'm afraid I seem to have missed the previous batch of 
> comments, and was
> wondering if you might help me clear out a minor niggle or two.
> 
> The repository locator draft and RFC 2782 seem to refer to different
> layers of protocols. Where 2782 refers to protocols in the transport
> layer, such as TCP, UDP, etc. the draft apparently uses application
> layer protocols like HTTP, LDAP, and OCSP. These application layer
> protocols are referred to as services by RFC 2782, where the draft in
> stead uses the name "PKIXREP".
> 
> I assume the intention is to differentiate between generic 
> directory or
> web services and PKI repositories, but would it in such a case not be
> more prudent to restrict the usage of PKIX defined names to just
> services instead of both to services and protocols. This could be
> accomplished, say, by defining the service definitions "PKIXHTTP",
> "PKIXLDAP", and "PKIXOCSP", which compliant applications could then
> query at their leisure.
> 
> Granted, it *is* perfectly possible to employ both RFC 2782 and the
> locator draft schemes independently to indicate the same directory or
> web server, but I was curios about these apparent 
> discrepancies between
> the two documents and was wondering if anybody would care to 
> explain the
> reasoning behind it to me.
> 
> Thanks in advance,
> 
> //oscar
>

---

From: Oscar Jacobsson <[email-masked]>
Date: Thu, 11 Jan 2001 11:38:11 +0100

> I don't really care which we do... (1) seems cleanest???

It does indeed, and seems intuitive enough. BIND 8.2.2 doesn't appear to
have a problem with it either.

//oscar