Subject: RE: Attribute Certificate for IP address allocation object

From: "Housley, Russ" <[email-masked]>
Date: Wed, 2 Jan 2002 08:26:31 -0500

Sanjaya:

Yes.  You will need to define a new attribute.  You may want to define two 
attributes, one for IPv4 address blocks and another for IPv6 address blocks.

I will be glad to review the syntax of your new attribute.

Russ

At 10:18 AM 1/2/2002 +1000, Sanjaya wrote:

>Hi Russ,
>Thanks for the quick response! I have been studying the
>draft but don't have a clue where to put the IP block
>information. Should we just create a new attribute field
>in the AC?
>
>Cheers,
>Sanjaya
>
> > -----Original Message-----
> > From: Housley, Russ [mailto:[email-masked]]
> > Sent: Selasa, Januari 01, 2002 00:01
> > To: Sanjaya
> > Cc: [email-masked]
> > Subject: Re: Attribute Certificate for IP address allocation object
> >
> >
> > Sanjaya:
> >
> > This seems like a straightforward application of
> > draft-ietf-pkix-ac509prof-09.txt.
> >
> > Russ
> >
> >
> > At 11:49 AM 12/31/2001 +1000, Sanjaya wrote:
> >
> > >Hi,
> > >We are investigating the use of Attribute Certificate for IP address
> > >allocation object. The idea is to bind the right to use certain IP
blocks
> > >to the organization that receives the allocation from an IP registry
> > >(e.g APNIC/ARIN/RIPE). This certificate can be validated by
> > >the service provider before inserting the block into the routing table.
> > >
> > >Is this topic within the scope of PKIX working group? Appreciate
> > >any advise. Thanks!
> > >
> > >Happy New Year 2001!
> > >Sanjaya
> > >Senior Project Manager
> > >APNIC (http://www.apnic.net)
> >

============================================================================
================
This e-mail, its content and any files transmitted with it are intended
solely for the addressee(s) and are PRIVILEGED and 
CONFIDENTIAL.  Access by any other party is unauthorized without the express
prior written permission of the sender.  If 
you have received this e-mail in error you may not copy, disclose to any
third party or use the contents, attachments or 
information in any way, Please delete all copies of the e-mail and the
attachment(s), if any and notify the sender. 
Thank You.
============================================================================
================

---

From: Stephen Kent <[email-masked]>
Date: Wed, 2 Jan 2002 09:35:31 -0500

>I will be glad to review the syntax of your new attribute.

Sanjaya,

My colleagues developed syntax for representing this info, for v4 and 
v6 addresses, and for AS numbers, as part of the Secure BGP work BBN 
has been doing under DARPA sponsorship.  We defined these as private 
extensions for X.509 certs, vs. ACs., but the syntax should be 
applicable. I'll forward a copy of the proposed syntax.

Steve

---

From: "Sanjaya" <[email-masked]>
Date: Thu, 3 Jan 2002 10:14:21 +1000

Russ, Stephen,
Thanks for the offer and pointers!
I am aware of the draft by Clynn/BBN about PKC extension
which have the same objective as what we have in mind.
What is the current status of that draft? I'd be happy to
discuss that draft further and combine our efforts.
Also what would be the advantage/disadvantage of using
X509 ID certs compared to using ACs?

Cheers,
Sanjaya

---

From: Teddy A Purwadi <[email-masked]>
Date: Sat, 05 Jan 2002 11:19:43 +0700

Sanjaya:
How long will you go with the draft related to
the object to IP indexes? Or no correlations?.
-teddy