Subject: New-PKIX-Part1 conflict with X.509 (2000)

From: "Nicholas, Richard" <[email-masked]>
Date: Mon, 4 Feb 2002 12:18:44 -0500

All,

Even though the new PKIX part 1 Internet Draft references X.509 (06/1997),
rather than X.509 (03/2000), I wanted to point out the following conflict
between the new PKIX part 1 text and X.509 (2000).

Annex B to X.509 (2000) provides detailed CRL processing rules for
validating CRLs prior to their use.  Specifically, for complete CRLs, Annex
B requires the following to be true:

   Issuing distribution point extension may be present; and
   Issuing distribution point extension shall not contain
   distribution point field;

However, the algorithm used in the draft-ietf-pkix-new-part1-12.txt, section
6.3.3, allows a distribution point field in an IDP CRL extension of a
complete CRL as long as it matches the either the certificate issuer DN or
one of the issuer alternative names in the cert.

The result:  Software that processes complete CRLs in accordance with X.509
(2000) will reject PKIX-compliant complete CRLs that contain distribution
point fields in the IDP extension.

Recommend the new PKIX part1 Internet Draft be updated to be consistent with
the algorithm used in X.509 (2000).

- Rich
---------------------------
Richard E. Nicholas
Principal Secure Systems Engineer
Getronics Government Solutions, LLC
[email-masked]
(301) 939-2722

---

From: "David A. Cooper" <[email-masked]>
Date: Mon, 04 Feb 2002 13:49:14 -0500

Rich,

The important question is not whether a CRL is complete, but whether it covers the certificate of interest. On this issue, I believe that PKIX and X.509 are in agreement.

The text in section 6.3.3 does not say anything about whether a CRL is complete. It merely says that a CRL containing a distribution point field in an IDP CRL extension covers a certificate if the DP name matches the certificate issuer's name.

In X.509, section B.5.1 provides rules for determining whether a certificate is covered by a CRL. If a CRL meets the criteria in section B.5.1.1 (Complete CRL) then it is a complete CRL and thus covers all certificates issued by the CRL issuer.

If the CRL contains an IDP extension with a distribution point name, then section B.5.1.4 (Distribution point based CRL/EPRL/CARL) applies. This section states that if the distribution point name in the IDP extension is present, it must match one of the names in the distribution point or CRL issuer field in the CRL DP in the certificate.

Section 8.6.2.1 in X.509 states that if the distribution point name is absent from the CRL DP extension then "the distribution point name defaults to the CRL issuer name". Thus, under the scenario that you mentioned, an algorithm that follows X.509 will accept the CRL as covering the certificate.

Dave