Subject: Re: I-D ACTION:draft-ietf-pkix-certstore-http-02.txt

From: Peter Sylvester <[email-masked]>
Date: Fri, 8 Feb 2002 17:52:19 +0100 (MET)

> Andreas Sterbenz <[email-masked]> writes:
> 
> Most respondents were in favour of multipart, because they didn't want to build
> an ASN.1 encoder into their database.

It seems to me that implementing an encoder for a sequence like

30 80 cert1 cert2 ... 00 00

isn't really a big task, 
and even surrounding this with some fixed magic octets
representing a p7c message, thus allowing to reuse an 
already existing content-type.

Or, I seem to share Andreas' disagreement.

---

From: "David P. Kemp" <[email-masked]>
Date: Fri, 08 Feb 2002 12:43:45 -0500

> Or, I seem to share Andreas' disagreement.

If we are taking a straw poll, I agree with Peter, Andreas,
and Phil Griffin.  Multipart is excessive overhead and complexity;
four fixed octets is trivial.