Subject: RE: About Proof of Private Key

From: Javier Bernardo - Decidir IT <[email-masked]>
Date: Tue, 4 Jun 2002 09:55:20 -0300

The CA doesn´t checks the validity of the public key against the private
key, because the private key stays in the users computer and only sends to
the CA the public key. The CA is used as Third Party in the authentication
of the public keys, so the users must trust the CA (this is done when you
import the CAs public key, to verify the digital signature of the CA with
its private key)

I hope this helps you...

Javier I. Bernardo
Security Technical Analyst
Research and Development
________________________________________
mailto:[email-masked] <mailto:[email-masked]> 
mailto:[email-masked] <mailto:[email-masked]> 
Tel 47035050 (44)
Visitenos en http://www.decidir.com 
Decidir International Ltd.

-----Mensaje original-----
De: narendra [mailto:[email-masked]]
Enviado el: Martes, 04 de Junio de 2002 02:31 a.m.
Para: Ietf-Pkix
Asunto: About Proof of Private Key

Dear Group Members,
      How CA checks the validity of public key against corresponding private
Key?

regards,
narendra.

--------------------------------------------
Parmar Narendrasinh Abhesinh
Numen Technologies Pvt.Ltd,
505 "ADITYA"
Opp.Sardar Patel Seva Samaj,
Off.C.G.Road,Ahmedabad-380 006.India
Phone no:- +91-79-6466136/6466310 ex-46,47,48

---

From: "Esposito Alfredo" <[email-masked]>
Date: Tue, 4 Jun 2002 16:33:39 +0200

The proof of possession is required in order to certify a key pair, usually
signing the Certification Request with the corrisponding Private Key (see
PKCS#10)

Alfredo Esposito
InfoCamere S.C.p.A.
E-business - Digital Signature
Via Morgagni 30H
00161 Roma
Phone +390644285415
Fax   +390644285255

-----Messaggio originale-----
Da: [email-masked]
[mailto:[email-masked]]Per conto di Javier Bernardo -
Decidir IT
Inviato: martedì 4 giugno 2002 14.55
A: [email-masked]; Ietf-Pkix
Oggetto: RE: About Proof of Private Key

I hope this helps you...

Javier I. Bernardo

-----Mensaje original-----
De: narendra [mailto:[email-masked]]
Enviado el: Martes, 04 de Junio de 2002 02:31 a.m.
Para: Ietf-Pkix
Asunto: About Proof of Private Key

Dear Group Members,

regards,
narendra.

---

From: Denis Pinkas <[email-masked]>
Date: Tue, 04 Jun 2002 16:50:32 +0200

> signing the Certification Request with the corrisponding Private Key (see

Not exactly. As an example, when ESSCertID from RFC 2634 is always being
used, then proof of possession is no more required by the CA.

Russ provided the right answer:

In general, the CA should have the potential subscriber prove that they can 
perform private key operations with the key that corresponds to the public 
key submitted for certification.  

Denis