Subject: Re: I-D ACTION:draft-ietf-pkix-logotypes-03.txt

From: "DUBUISSON Olivier" <[email-masked]>
Date: Thu, 4 Jul 2002 11:55:00 +0200

"Housley, Russ" wrote:
> 
> Juergen:
> 
> Right after sending my last reply, I realized that I was much too
hasty
> in
> my reply to this comment.  Please disregard my previous response.
> 
> In general, I do not like EXPLICIT tagging.  But you are correct that
> there
> is a problem here.  I want to consider alternative solutions and get
> advice
> from others about how this has been handled in other protocols.  I
will
> post a proposed fix soon.
> 
> Russ
> 
> >**** ASN.1:
> >You declare the Module as IMPLICIT TAGS. But the only use of tags is
> >LogotypeExtn ::= SEQUENCE {
> >          communityLogo  [0] LogotypeInfo OPTIONAL,
> >          issuerLogo     [1] LogotypeInfo OPTIONAL,
> >          subjectLogo    [2] LogotypeInfo OPTIONAL,
> >          otherLogos     [3] SEQUENCE OF OtherLogotypeInfo OPTIONAL }
> >
> >       LogotypeInfo ::= CHOICE {
> >          direct          LogotypeData,
> >          indirect        LogotypeReference }
> >
> >Here, the tags are converted silently by clause 30.6 c) of X.680 into
> >EXPLICIT tags because LogotypeInfo is a CHOICE (IMPLICIT tags on
> CHOICEs
> >are implicitely EXPLICIT or something like that). In my opinion the
> >module would be better readable for implementors if you would declare
> it
> >as EXPLICIT.

Implementors do not have to bother with tagging when they use an
ASN.1 compiler!

> >The LogotypeInfo CHOICE misses a tag when you use module-wide
IMPLICIT
> >or EXPLICIT tagging. LogotypeData and LogotypeReference are both
> >SEQUENCEs, and for the CHOICE to be parseable, you have to tag the
> >elements (Clause 28.2. of X.680).
> 
> How about:
> 
>     LogotypeInfo ::= CHOICE {
>        direct          [0] LogotypeData,
>        indirect        [1] LogotypeReference }

And what about sticking "AUTOMATIC TAGS" in the module header (if it's
a new ASN.1 module that you're producing), and not bother with tags
any more?
-- 
Olivier DUBUISSON
france telecom R&D

DTL/TAL - 22307 Lannion Cedex - France
t: +33 2 96 05 38 50 - f: +33 2 96 05 39 45 - http://asn1.elibel.tm.fr/

---

From: Juergen Brauckmann <[email-masked]>
Date: Thu, 04 Jul 2002 12:14:08 +0200

> DUBUISSON Olivier wrote:
> > > In my opinion the

Sure. But obviously too many people don't use one and produce invalid
encodings, and other people than have to deal with this defect stuff.

I had to discuss the "IMPLICIT, that turns implicitely in an
EXPLICIT"-thing several times with partners of our company; and I know
of at least one implementation in the wild that does it wrong.

It's my hope that a little hint in standard documents may help to
prevent this mess.

> a new ASN.1 module that you're producing), and not bother with tags

Of course that does not work with old compilers... .

Regards,
   Juergen