Subject: "Web Services" PKI RFC

From: "Anders Rundgren" <[email-masked]>
Date: Fri, 3 Jan 2003 23:13:27 +0100

Dear all,

I am interested in creating an RFC (or similar) for a certificate-
profile matching the needs of the emerging "Web Services" technology.

The major reason for creating a specific profile is that Web Services
are plug-and-play while plain-vanilla X.509 is not.

Some initial work has already been carried out but I would like to
get in contact with other people who:

- Know SQL, XML, Java, X.509, and to some extent ASN.1
- Are genuinely interested in PKI-enabling business systems
- See user- and market-acceptance as the #1 issue

Exactly where the possible result will land is still open, it could be
in OASIS as well as this seems to be the "Home of Web Services".

Anders Rundgren
Senior Internet e-Commerce Architect
+46 70 - 627 74 37 (CET 9.00-21.00)

---

From: "Alice Sturgeon" <[email-masked]>
Date: Sat, 4 Jan 2003 11:47:49 -0500

Anders,
FYI, ISO/IEC JTC 1 is initiating a 'study period' to consider whether JTC 1
and its sub-committees should work on standardization in the area of Web
services.  This is at the point of soliciting interest from the national
bodies that participate in JTC 1.  We should know probably by the end of
January whether there is sufficient interest to go ahead with this.  If we
do, then there would clearly be synergy on this issue between JTC 1 and any
work by IETF.  I volunteered to participate because it is of interest to me.
Concerning your call for interest, I would say 'yes' to the last two points
(genuine interest in PKI-enabling business systems and consider user/market
acceptance as the number one issue), but not the first (except for the X.509
part).
I will let you know the outcome of the JTC 1 initiative.

Alice

Alice Sturgeon
Chair
Canadian Advisory Committee - Information Technology Security
ISO/IEC JTC1 SC 27
and
System Policy Architect
SPYRUS
Phone:     613-232-2350
Cell:         613-291-0331

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Anders Rundgren
Sent: January 3, 2003 5:13 PM
To: [email-masked]
Subject: "Web Services" PKI RFC

Dear all,

Anders Rundgren

---

From: "Anders Rundgren" <[email-masked]>
Date: Sat, 4 Jan 2003 18:09:57 +0100

Thanx Alice,
You are the third person indicating interest in this!

Maybe Web Services is really as "red hot" as I always claim it is :-)

BTW, there are some outstanding warranty-issues to cater
for as well...

More to read : http://www.verisign.com/netsure
"Limited Liability Warranty" (!)

Best
Anders

----- Original Message ----- 
From: "Alice Sturgeon" <[email-masked]>
To: "Anders Rundgren" <[email-masked]>; <[email-masked]>
Sent: Saturday, January 04, 2003 17:47
Subject: RE: "Web Services" PKI RFC

Anders,

Alice

Alice Sturgeon
Chair

-----Original Message-----

Dear all,

Anders Rundgren