Subject: RE: LDAP PKI Schema (was Re: No-op LDAP ;binary option)

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 2 Jan 2003 18:11:20 +1100

Component matching, however, does not address the problem of returning multiple certificates.

That is, if component matching were to be used, and if the entry contains a matching certificate, then all certificates in the entry would be returned. Using subordinate entries ensures only one certificate is returned.

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Tuesday, 31 December 2002 18:38
To: Peter Gietz
Cc: [email-masked]
Subject: Re: LDAP PKI Schema (was Re: No-op LDAP ;binary option)

>Nevertheless two different solutions to one problem might be preferable here.

My primary objection to standardizing the child entry approach
for PKI is that it is a PKI-specific solution to a general problem,
component matching of complex attribute values.   We should be
looking for general solutions to our general problems.  Steven's
component matching I-D details a general solution which I believe
is suitable for standardization.

My recommendation is that the PKI "child entry" approach be
pursued individually as an Experimental (or possibly Informational)
solution to the PKI component matching problem with a note that
a more general solution, component matching, is being standardized.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 02 Jan 2003 09:01:25 -0800

>Component matching, however, does not address the problem of returning multiple certificates.

We have a general solution to that general problem in the LDAP
matched values control extension [draft-ietf-ldapext-matchedval]. 

Kurt