Subject: Fw: PKI "not working"

From: "todd glassey" <[email-masked]>
Date: Thu, 12 Jun 2003 07:28:26 -0700

This is a cross posting from the ISC's mailing lists of the Bar Association.

Why it is important here is that it documents perceived problems in the PKI
marketplace and I perceive that a number of these issues are failures in the
IETF's and potentially the ETSI standards processes, since they allow
processes that are at best incomplete from a deployment stance to be
elevated into standards status IMHO.

My concern is that the value of the IETF and ETSI is growing less and less
with these types of realizations in the marketplace.

Todd

To: <[email-masked]>
Sent: Thursday, June 12, 2003 7:00 AM
Subject: UK: PKI "not working"

> PKI is 'not working'
>
> Inadequate technology for online transactions is a 'huge problem' for
those
> in charge of e-government, admits a leading Whitehall official The
e-envoy's
> office has started searching for new ways to authenticate the users of
> e-services as the existing technology being used is "not working", a
senior
> Government official revealed on 11 June 2003. Although PKI (public key
> infrastructure) and digital certificate technology has played a major role
> in leading projects such as the Government Gateway, there is now growing
> recognition that it is unsuited for wider public use. While digital
> certificates would not be scrapped, and would be retained as an option for
> e-service users, one possible alternative being suggested is that
employers,
> banks, the voluntary sector and other "trusted organisations" would verify
a
> person's identity before transacting online for services. Speaking on
> condition of anonymity, the official said the Government is now looking at
> "radical ways" of solving the authentication problem. "Trust and
> authentication has been a huge problem for us. We haven't got a solution
for
> authentication. We've been trying with PKI for about 10 years now and its
> not working because it's a pain to implement and to use. We've been
looking
> to take the pain out of PKI. "What we are saying with authentication is
that
> if another trusted organisation such as a bank can provide proof saying
you
> are who you say you are that should take the need away for digital
> certificates." The move comes as the e-envoy's office is acutely aware
that
> it needs to step up the pace of e-government leading up to the 2005
target.
http://www.kablenet.com/kd.nsf/Frontpage/2FBC229CDE8C5A1680256D43004176EA?Op
> enDocument
<http://www.kablenet.com/kd.nsf/Frontpage/2FBC229CDE8C5A1680256D43004176EA?O
> penDocument>
>
> Michael Power
>
> Partner & Chief Privacy Officer
> Gowling Lafleur Henderson LLP
> Barristers & Solicitors
> Patent & Trade Mark Agents
> Suite 2600
> 160 Elgin Street
> Ottawa, Ontario, CANADA
> K1P 1C3
>
>
>

---

From: "Anders Rundgren" <[email-masked]>
Date: Sat, 21 Jun 2003 19:56:15 +0200

Todd,
May I comment on the UK e-envoy's complaints?

Firstly, the UK do not have the concept of a "citizen identity".
It is IMHO fairly impossible to create useful TTP PKIs for on-line
authentication and signing without working naming schemes.
Not to mention creating multi-authority work-flow tasks
(or "one-stop shopping" as it is coined in Sweden).

Secondly, in Sweden 3 million citizens out of 9 million total can
get a citizen certificate at the click of a button in their on-line bank
which is an indication that "not working" is not a universal truth.

To be honest the Swedish bank consortium do not rely on the
browsers' built-in crypto-functions as these were considered as
unwieldy, and not sufficiently standardized.  Here your comments
regarding lacking or not accepted standards apply, as "web-sign"
is a major activity since years backs but still not covered by any
standards WG!  To circumvent this blatant deficiency, the banks
selected a proprietary Java applet from an IBM lab in Zurich.

What indeed is not working [on a practical and wide scale] is the
concept of mobile PKI resources that can be used at home, in an
Internet café or at work.  Here I believe ETSI's and EU's work in
the field of smart cards has generally failed.

What is also not working is many-to-many encrypted e-mail.
But that does not really matter as the on-line paradigm using
https + web has effectively replaced encrypted e-mail for
both on-line banking and e-government services.

Anders R

----- Original Message -----
From: "todd glassey" <[email-masked]>
To: <[email-masked]>; "el-sign: electronic signatures - open discussion" <[email-masked]>
Sent: Thursday, June 12, 2003 16:28
Subject: Fw: PKI "not working"

Todd

those
e-envoy's
senior
employers,
a
for
looking
that
you
that
target.

---

From: "todd glassey" <[email-masked]>
Date: Sat, 21 Jun 2003 20:18:59 -0700

Anders, you are certainly a powerful force in the development of
cryptography in Europe (and I do mean this, no sarcasm intended), so I
respect the commentary.

I do however respectfully disagree.  People use PKI because they have to not
because it makes sense to yet and that is the problem in a nut shell. It is
still not commercially viable to rely on PKI systems... and there is no
proof yet that any of the EU's stringent privacy directives are ever going
to be met. So even though some of the smaller nations have started to force
their population to rely on PKI's in the form of Public x.509 certs (ala
Verisign/Thawte etc etc etc)...

My feeling from a higher-ground perspective is that PKI as a whole to date
has failed to address 2000 years of human process and legal development and
has actually sought to eliminate much of the ceremony in favor of a
mechanical infrastructure ... i.e. to replace "it". But in response to that,
I want to point out that PKI processes can be made to conform to paper
signing ceremonies and that is the best way to get people to feel
comfortable with PKI...because so far the only reasons to use a certificate
are the ones where its mandated by law.  Which leads me to think that PKI is
still years away from commercial desirability.

In closing, I want to reiterate that in all the examples you cited we were
talking about a legal mandate, not generally a choice, so that implies to me
that so far the only reason to use PKI is for the Force of Law that the
eSign legislation brought into it...

Todd

---

From: Mitchell Arnone <[email-masked]>
Date: Sun, 22 Jun 2003 08:26:34 -0400

While PKI certainly has significant value with regards to applying digital 
signatures and other issues regarding non-repudiation, I believe that we 
often seem to overlook the main benefits that are used to justify deploying 
PKI today.

PKI is the core component of any real Identity Management 
infrastructure.  It provides for strong authentication to networking 
systems and applications.  It serves to help reduce the number of managed 
identities for corporate employees and thereby improve security by 
eliminating passwords.  It provides integrity and confidentiality of email 
and assures recipients as to who actually sent the message.  It is used to 
validate software and make it more difficult to spread viruses.

We are all familiar with these well advertised benefits but for some reason 
we seem to constantly dismiss them when talking about whether of not PKI is 
ready for prime time and or commercial desirability.

Trust me... it is commercially desirable today.  Maybe one day we can 
figure out how to incorporate it into the legal infrastructure but that is 
not the driving force, at least not today.

Identity management is the driving force for PKI and identity management is 
one of the most desirable solutions on the market today.

At 11:18 PM 6/21/2003, todd glassey wrote:

><http://www.kablenet.com/kd.nsf/Frontpage/2FBC229CDE8C5A1680256D43004176EA?O>  
> > penDocument>
> > >
> > > Michael Power
> > >

***********************************************************
Mitchell Arnone
Managing Consultant
SchlumbergerSema
Technical Consulting Practice, Northeast Region

[email-masked]
www.slb.com/nws

SchlumbergerSema
Network & Infrastructure Solutions
194 Wood Avenue, South
Iselin, NJ 08830
Direct Line- (410) 579-8691
Mobile - (443) 864-1590

---

From: "todd glassey" <[email-masked]>
Date: Sun, 22 Jun 2003 09:53:30 -0700

Mitchell - My apologies to you and the group - that last posting of mine was a mistake - this is what should have been send out.

----
Mitchell - having already been sanctioned in the IPR wg for too many postings I need to be careful of how many of these responses I answer while we are sorting out damages due to RFC2418's discriminatory use. But in response to your posting, come up to 100000 feet and look down and try and make these same comments. I don't believe that they hold water at this altitude. Sorry.
  ----- Original Message ----- 
  From: Mitchell Arnone 
  To: todd glassey ; Anders Rundgren ; [email-masked] 
  Sent: Sunday, June 22, 2003 5:26 AM
  Subject: Re: UK: PKI "not working"

  While PKI certainly has significant value with regards to applying digital signatures and other issues regarding non-repudiation, I believe that we often seem to overlook the main benefits that are used to justify deploying PKI today.

I agree generally, but there is a flaw in this as a blanket statement, and that is that there is an implication that PKI is the entirety of the crypto process. In short that simply is not true. PKI is a Public Key Infrastructure, which mandates the use of a split-key (public/private keys) model for the use of cryptographic functions. 

It (PKI) is not the only, nor is it the most efficient use of cryptographic keying  for proofing in transaction models, and in fact PKI has any number of liabilities (including OCSP or CRL overhead) specific to the key management processes which other keying systems simply don't face, like symmetric or PAD systems as just two of the many examples available ... 

  PKI is the core component of any real Identity Management infrastructure.  

So how much of your own personal money are you willing to risk on this statement of yours? - we will come back to this later.

  It provides for strong authentication to networking systems and applications.  It serves to help reduce the number of managed identities for corporate employees and thereby improve security by eliminating passwords.  

No offense meant by this next comment but - Garbage - you talk about PKI as if this was a universally rolled out product and its not. Yes, the use of a PKI model for addressing these issues of managed identities can and in many instances does involve PKI but that is because products have been built that use x509 rather than DH or other types of keying solutions. And this is a statement of productization and not by developing a market by the creation of a standard.

  It provides integrity and confidentiality of email and assures recipients as to who actually sent the message.  

Only if the email is encrypted. If SSL or OpenSSH tools are used to provide these functions then they too are PKI-less in nature. So my response is probably something like "No it doesn't. SSL is used more than anything to insure confidentiality." and although it may use an x509 certificate, it (the process) does not use the formal PKI you are talking about. It  (the SSL Process) can be used to encrypt and sign mail but most people don't use it for these options.  By the way - notice that most people equate VPN's as better than encrypted email and that is why the comment above holds water.

As to whether PKI is ready for prime time, if we assume that your commentary is right, then ask yourself why when you toggle through this list why you only see one in 1000 postings having any use of this PKI you are fond of telling us that is ready for use. What this says to me is that the totality of your retort is simply untrue or we would all be seeing notices about the certificates that were used to sign our email.

  It is used to validate software and make it more difficult to spread viruses.

Well, it could be - Code Authentication (Authenticode) can use Microsoft official Certs, but any x509 cert can be made to be used herein. So I would say that this is true only of "Microsoft Installer Packages".  by contrast, most all UNIX packages *(RPM, HP Depot Packages, Sun or other UNIX PgkAdd formats etc), only use MD5 Hashes so where is the PKI here?  The hashes may additionally be signed to insure that they are not altered, but in most instances a hashed finger print is all that is distributed with a code package so that its installer routine or the person installing it can perform these task inline.

  We are all familiar with these well advertised benefits but for some reason we seem to constantly dismiss them when talking about whether of not PKI is ready for prime time and or commercial desirability.  

You missed the point here. Business does not do things because they like it. Business does things because (1) they can, and WILL make more money that way(and you have to prove both of these assertions to qualify here), or (2) because someone forces it on them through regulation or through some other legal channel like a lawsuit's settlement as has been done by several governments in mandating their citizens MUST have a eEntity under their eSign legislation whatever that is.

  Trust me... it is commercially desirable today.  

Ahahahahahaha - your funny. Again - are you or your employer's willing to back that statement with money? 

  Maybe one day we can figure out how to incorporate it into the legal infrastructure but that is not the driving force, at least not today.

Hmmm- Here again I would disagree. In fact I would day that this is exactly 180 degrees out of synch with reality... right now the legal reasons are the only ones to bear the costs of PKI today, and if you doubt that look at the people that are ramming PKI down their citizens throats and why!.

  Identity management is the driving force for PKI and identity management is one of the most desirable solutions on the market today.

OK that is something I can agree with. But what PKI really brings to the party is a recognized set of rules for applying legal status to a digital signature as though it were a wet one, and all that this implies and means. 

lets keep our eyes on the ball here.

Todd

---

From: "todd glassey" <[email-masked]>
Date: Sun, 22 Jun 2003 09:40:15 -0700

Mitchell - come up to 100000 feet and look down and try and make these same comments. They simply don't hold water. Sorry.
  ----- Original Message ----- 
  From: Mitchell Arnone 
  To: todd glassey ; Anders Rundgren ; [email-masked] 
  Sent: Sunday, June 22, 2003 5:26 AM
  Subject: Re: UK: PKI "not working"

I agree gernerally,but there is a flaw in this as a blanket statement, and that is that there is an implication that PKI is the entirety of the crypto process. In short that simply is not true. PKI is a Public Key Infrastructure, which mandates the use of a split-key (public/private keys) model for the use opf cryptographic functions. It (PKI) is not the only nor is it the most efficient use of cryptographic keying  for proofing in transaction models, and in fact PKI has any number of liabilities specific to the key management processes which other keying systems simply dont face, like symmetric or PAD systems as just two of the many examples avalible ... 

So how much of your own personal money are you willing to risk on this statement of yours?

No offense ment by this next comment but - Garbage - you talk about PKI as if this was a rolled out product and its not. Yes the use of a PKI model for addressing these issues of managed identities, can and in many instances does involve PKI but that is becuase products have been built that use x509 rather than DH or other types of keying solutions. And this is a statement of productization and not by developing a market by the creation of a standard.

Only if the email is encrypted. If SSl is used to provide these functions too, it is likely that no formal PKI service is used. So my response is probably somethinglike "No it doesnt. SSL is used more than anything to insure confdentiality." and although it may use an x509 certificate, it (the process) does not use the formal PKI you are talking about. It  (the SSL Process) can be used to encrypt and sign mail but most people dont use it for these options. 

As to whether PKI is ready for prime time, if we assume that your commentary is right, then ask yourself why when you toggle through this list why you only see one in 1000 postings having any use of this PKI you are fond of telling us that is ready for use. What this says to me is that the totality of your retort is simply untrue or we would all be seeing notinces about the certificates that were used to sign our email.

Well, it could be - Code Authentication (Authnticode) can use Microsoft official Certs, but any x509 cert can be made to be used herein. So I would say that this is true only of "Micosoft Installer Packages".  by contrast, most all UNIX packages *(RPM, HP Depot Packages, Sun or other UNIX PgkAdd formats etc), only use Md5 Hashes so where is the PKI here?  The hashes may additionally be signed to insure that they are not altered, but in most instances a hashed finger print is all that is distributed with a code package so that its installer routine or the person installing it can perform these task inline.

You missed the point here. Business does not do things becuase they like it. Business does things becuasse (1) they can, and WILL make more money that way(and you have to prove both of these assertions to qualify here), or (2) becuase someone forces it on them through regulation or through some other legal channel like a lawsuit's settlement as has been done by several governments in mandating their citizens MUST have a eEntity under their eSign legislation whatever that is.

Ahahahahahaha - your funny. Are you or your employer's willing to back that statement with money? 

Boy is this wrong. In fact I think its exactly 180 degrees out of synch with reality... The legal reasons are right now the only ones to bear the costs of PKI today and if you doubt that look at the people that are ramming PKI down their citizens throats and why!.

Todd

---

From: Jean-Marc Desperrier <[email-masked]>
Date: Sun, 22 Jun 2003 20:37:33 +0200

todd glassey wrote:

> *(RPM, HP Depot Packages, Sun or other UNIX PgkAdd formats etc), only 
> use Md5 Hashes so where is the PKI here?  The hashes may additionally 
> be signed to insure that they are not altered, but in most instances a 
> hashed finger print is all that is distributed with a code package so 
> that its installer routine or the person installing it can perform 
> these task inline.

You seem to be ignorant there has been cases of corrupted archives with 
a trojan horse being somehow uploaded to a public ftp server, and they 
have shown the limits of the system, administrator don't always go check 
the hash value on the main source site.

Here a pki based system could significantly improve the result.
That would ring a bell to a not too stupid administrator if when 
installing the nth package from RH, he suddenly had a message "The 
certificate used to sign this package is not in your trust list. Do you 
want to accept it anyway ?" if all the packages before did not trigger 
such a message, because _they_ were signed with a genuine certicate.

---

From: "todd glassey" <[email-masked]>
Date: Sun, 22 Jun 2003 22:13:02 -0700

Jean-Marc,
Am I right in assuming that you think that it really matters what is
uploaded to a public FTP server???... Ones operated in the public interest
require stronger levels of certification and I have no complaint that in
instances where a Government wants to assign an individual identity token to
identify you, what i have is a statement that you nor anyone else here has
yet to refute, and that simply is that there are very few commercial reasons
for PKI's and even fewer for public PKI's beyond those of a national
identity system.

What is really funny to me is the about face across the European Continent.
This would NEVER have flown 20 years ago...
----- Original Message ----- 
From: "Jean-Marc Desperrier" <[email-masked]>
To: <[email-masked]>
Sent: Sunday, June 22, 2003 11:37 AM
Subject: Re: UK: PKI "not working"

> the hash value on the main source site.

This has to do with sloppy operating processes and procedures and not
whether the package was encrypted for upload with a PKI bassed crypto
system.

> Here a pki based system could significantly improve the result.

Sure - at a significant cost to manage it as well.

> such a message, because _they_ were signed with a genuine certicate.

SW installers have to work offline too.

---

From: Michael Ströder <[email-masked]>
Date: Mon, 23 Jun 2003 07:41:44 +0200

Jean-Marc Desperrier wrote:
>> use Md5 Hashes so where is the PKI here?

RPM packages can be signed with PGP (gpg). E.g. SuSE Linux does it that way.

> such a message, because _they_ were signed with a genuine certicate.

Already done but not with X.509-based PKI. Many source distribution files 
are also signed with PGP, e.g. the Linux kernel.

Ciao, Michael.

---

From: "Anders Rundgren" <[email-masked]>
Date: Mon, 23 Jun 2003 09:44:48 +0200

I fully agree with Mitchell's conclusions of what PKI is good for as it stands today.  To be able to serve millions of citizens at thousands of independent e-government portals, either requires TTP identity-portals (using SAML etc.), or client-side PKI using TTP CAs.  No other methods have proven to be technically or economically feasible.

I cannot verify any major 100000-foot legal problems, but quite a bunch of down-to-earth (zero-foot?) problems like "lousy browsers", and the lack of ubiquitous, secure, and mobile key-containers.  IMO, it is really only the latter that hampers enterprise-PKIs as a userid/password-replacement on a wider scale.  This problem is neither a standards problem, nor a technical ditto.   It is rather an example of blatant stupidity among "certain manufacturers".

Regarding "legally binding", virtually anything that offers reasonable technical integrity is likely to be applicable as evidence in a court trial in most countries.  Examples of this are phone-operators' call-lists that may prove "association" or DNA-fingerprints that may prove "It wasn't me".   What is a bit puzzling is that non-PKI e-solutions never seem to be questioned regarding their.merits in courts...

A "legal" aspect that though really is an issue, is TTP CA liability.  However, this is mostly a US issue where suing people is a part of the system.  I believe this will have a negative impact on PKI usage in the US, unless there is a way to automatically accomplish what Identrus et al "achieves" by requiring relying parties to sign agreements freeing the issuer from liability.  Here I would like to address the PKIX WG with a request for some kind of remedy.

Anders
  ----- Original Message ----- 
  From: Mitchell Arnone 
  To: todd glassey ; Anders Rundgren ; [email-masked] 
  Sent: Sunday, June 22, 2003 14:26
  Subject: Re: UK: PKI "not working"

  PKI is the core component of any real Identity Management infrastructure.  It provides for strong authentication to networking systems and applications.  It serves to help reduce the number of managed identities for corporate employees and thereby improve security by eliminating passwords.  It provides integrity and confidentiality of email and assures recipients as to who actually sent the message.  It is used to validate software and make it more difficult to spread viruses.

  Trust me... it is commercially desirable today.  Maybe one day we can figure out how to incorporate it into the legal infrastructure but that is not the driving force, at least not today.

    Todd
    ----- Original Message ----- 
    From: "Anders Rundgren" <[email-masked]>
    To: "todd glassey" <[email-masked]>; <[email-masked]>
    Sent: Saturday, June 21, 2003 10:56 AM
    Subject: Re: UK: PKI "not working"

    > > enDocument
    <http://www.kablenet.com/kd.nsf/Frontpage/2FBC229CDE8C5A1680256D43004176EA?O> > penDocument>

  [email-masked]
  www.slb.com/nws

  SchlumbergerSema

---

From: "todd glassey" <[email-masked]>
Date: Mon, 23 Jun 2003 13:41:09 -0700

Actually - the real issue is that the US Digital Signature Act, nor any others that I am aware of "brought into  the play" that there would be protected signatures along side unprotected ones, since to invoke eSign it would take both parties making an "informed consent decision" to do...

So no, PKI is still a long way from prime-time availability. 

Todd

  ----- Original Message ----- 
  From: Anders Rundgren 
  To: [email-masked] 
  Sent: Monday, June 23, 2003 12:44 AM
  Subject: Re: UK: PKI "not working"

  Anders
    ----- Original Message ----- 
    From: Mitchell Arnone 
    To: todd glassey ; Anders Rundgren ; [email-masked] 
    Sent: Sunday, June 22, 2003 14:26
    Subject: Re: UK: PKI "not working"

      Todd
      ----- Original Message ----- 
      From: "Anders Rundgren" <[email-masked]>
      To: "todd glassey" <[email-masked]>; <[email-masked]>
      Sent: Saturday, June 21, 2003 10:56 AM
      Subject: Re: UK: PKI "not working"

    [email-masked]
    www.slb.com/nws

    SchlumbergerSema