Subject: RE: SCVP additions

From: Stephen Kent <[email-masked]>
Date: Fri, 19 Sep 2003 09:26:38 -0400

At 16:18 -0700 9/18/03, Trevor Freeman wrote:
>Hi Steve,
>Sounds like a good idea. I am about to go on vacation for a couple of
>weeks, but I will start this on my return.
>Trevor
>

Thanks,

Steve

---

From: "Michael Myers" <[email-masked]>
Date: Wed, 24 Sep 2003 07:38:09 -0700

All,

Recent list traffic indicates there might be some confusion out
there regarding the use of nonces in OCSP.  This is
understandable since RFC 2560 is regrettably silent on the
point.  It seems that most folks correctly inferred our original
intent but absent normative language there's a possibility that
some may not.

After some discussion with the Chairs and the AD, we will take
action to clarify our original intent in one fashion or another
but first need to poll IMPLEMENTORS to determine how many, if
any, implementations of OCSP would break as a consequence of the
following normative language:

    "Clients that elect to include a request nonce
     SHALL reject responses that fail to include
     the client's nonce from the associated request."

    "Correspondingly, upon receipt of a request
     containing a nonce, a responder SHALL include
     the value of such nonce in the production of
     the associated response."

IMPLEMENTORS ONLY, please, and just yes/no or equivalent.

Mike

---

From: Dr Stephen Henson <[email-masked]>
Date: Wed, 24 Sep 2003 16:46:28 +0100

No.

(OpenSSL OCSP 0.9.7 and later)

Steve.
-- 
Dr Stephen N. Henson.
Core developer of the   OpenSSL project: http://www.openssl.org/
Freelance consultant see: http://www.drh-consultancy.co.uk/
Email: [email-masked], PGP key: via homepage.

---

From: Richard Levitte - VMS Whacker <[email-masked]>
Date: Wed, 24 Sep 2003 18:47:16 +0200 (CEST)

In message <[email-masked]> on Wed, 24 Sep 2003 07:38:09 -0700, "Michael Myers" <[email-masked]> said:

mmyers> After some discussion with the Chairs and the AD, we will take
mmyers> action to clarify our original intent in one fashion or another
mmyers> but first need to poll IMPLEMENTORS to determine how many, if
mmyers> any, implementations of OCSP would break as a consequence of the
mmyers> following normative language:
mmyers> 
mmyers>     "Clients that elect to include a request nonce
mmyers>      SHALL reject responses that fail to include
mmyers>      the client's nonce from the associated request."
mmyers> 
mmyers>     "Correspondingly, upon receipt of a request
mmyers>      containing a nonce, a responder SHALL include
mmyers>      the value of such nonce in the production of
mmyers>      the associated response."

For OpenSSL, the answer is no, as far as I can tell.

-- 
Richard Levitte     | http://richard.levitte.org/ | Tunnlandsv. 3
Levitte Programming | http://www.lp.se/           | S-168 36 Bromma
T: +46-708-26 53 44 |                             | SWEDEN
     "Price, performance, quality...  choose the two you like"

---

From: Dr Stephen Henson <[email-masked]>
Date: Wed, 24 Sep 2003 18:16:20 +0100

> No.

I'd better clarify that: I mean "It wont break".

Steve.

---

From: "Ambarish Malpani" <[email-masked]>
Date: Wed, 24 Sep 2003 10:13:33 -0700

Hi Mike,
    Neither will the Valicert one.

A

> -----Original Message-----
> From: Richard Levitte - VMS Whacker [mailto:[email-masked]]
> Sent: Wednesday, September 24, 2003 9:47 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: POLL: Use of nonces in OCSP
> 
> 
> In message <[email-masked]> on 
> Wed, 24 Sep 2003 07:38:09 -0700, "Michael Myers" <[email-masked]> said:
>

---

From: "Terry Hayes" <[email-masked]>
Date: Wed, 24 Sep 2003 11:02:16 -0700

The Netscape security library (NSS) includes an OCSP client, and the 
Netscape Certificate Management product includes an OCSP responder. 
Neither of these implementations will break as a result of the new language.

Terry Hayes

---

From: "Florian Oelmaier" <[email-masked]>
Date: Wed, 24 Sep 2003 22:21:05 +0200

Short answer for the POLL:

No, our client will not break
No, our responder will not break

>      the client's nonce from the associated request."

No. Our client will not break - as its behaviour is configurable
(accept/warning/reject). The behaviour described is NOT the default. Our
default is to issue a warning to the user and not reject it. This can be
changed easily.

>      the associated response."

No. Our responder will not break - as its behaviour is configurable
(always nonce, nonce on request, never nonce). Due to security reasons
the current default behaviour is to send a nonce for every request. As
far as I can see this would be in compliance with the new wording. On
the other hand, taking the new client requirement into account, there is
no reason for the "always" setting anymore and we will change our
default to "nonce on request" once all clients have adopted the changes.

With this change, the user / client can determine what "assurance" level
regarding the OCSP response it needs. This also means, that the users /
clients dictate to what amount an OCSP-Responder is allowed to use
pre-produced responses. We should discuss if this is pratical in real
world installations / services. Maybe the other way round will meet
todays requirements easier: the PKI operator / responder tells the user
what "assurance" level regarding the validity he is willing to give. But
this is up to you - from a technical point of view I wholeheartly
welcome the proposed clarifications.

Thanks for your work,

-- 
Florian Oelmaier
SyTrust

---

From: Marius Marian <[email-masked]>
Date: Fri, 26 Sep 2003 08:49:16 +0200

>IMPLEMENTORS ONLY, please, and just yes/no or equivalent.

Our implementation (here at Politecnico di Torino) will not break as a 
consequence of
the above mentioned statements.

Regards,
    Marius Marian.