Subject: TSA certificate content

From: Peter Sylvester <[email-masked]>
Date: Mon, 24 Nov 2003 14:30:05 +0100 (MET)

I would like to hear some opinion about the setting
of the extension keyUsage in a certificate for a
3161 TSA. 

The question is whether a certificate contain no
keyUsage extension at all and only an extended
key usage with the appropriate key purpose
is conformant with 3161 and 3280. 

Peter

---

From: "Santosh Chokhani" <[email-masked]>
Date: Mon, 24 Nov 2003 21:40:56 -0500

Peter:

Based on a review of 3280 and 3161, I would say that absence of keyUsage
extension is permissible.

3161 requires extended key usage to be present as well as critical.  It also
requires only one key purpose in the extension, that for time stamping.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Peter Sylvester
Sent: Monday, November 24, 2003 8:30 AM
To: [email-masked]
Subject: TSA certificate content

Peter

---

From: "Ing. Raffaello Galli" <[email-masked]>
Date: Tue, 25 Nov 2003 09:54:29 +0100

Peter,

According to rfc3161:

   2.3. Identification of the TSA

   The TSA MUST sign each time-stamp message with a key reserved
   specifically for that purpose.  A TSA MAY have distinct private keys,
   e.g., to accommodate different policies, different algorithms,
   different private key sizes or to increase the performance.  The
   corresponding certificate MUST contain only one instance of the
   extended key usage field extension as defined in [RFC2459] Section
   4.2.1.13 with KeyPurposeID having value:

   id-kp-timeStamping.  This extension MUST be critical.
.

According to  rfc3280:

4.2.1.13  Extended Key Usage
...........................
id-kp-timeStamping            OBJECT IDENTIFIER ::= { id-kp 8 }
   -- Binding the hash of an object to a time
   -- Key usage bits that may be consistent: digitalSignature
   -- and/or nonRepudiation

So according to the RFCs the TSA certificate

1)  MUST have only one instance  "extended key usage" extension with the
value
      id-kp-timeStamping  and this must be Critical.

2) The value of the extension "key usage" may be consistent.
     (i.e. digitalSignature e/o nonRepudiation   - Critical it is
recommended
      but not mandatory)

Regards

Raffaello

->-----Messaggio originale-----
->Da: [email-masked]
->[mailto:[email-masked]]Per conto di Santosh Chokhani
->Inviato: Tuesday, November 25, 2003 3:41 AM
->A: 'Peter Sylvester'; [email-masked]
->Oggetto: RE: TSA certificate content
->
->
->
->Peter:
->
->Based on a review of 3280 and 3161, I would say that absence of keyUsage
->extension is permissible.
->
->3161 requires extended key usage to be present as well as
->critical.  It also
->requires only one key purpose in the extension, that for time stamping.
->
->>-----Original Message-----
->>From: [email-masked]
->>[mailto:[email-masked]] On
->>Behalf Of Peter Sylvester
->>Sent: Monday, November 24, 2003 8:30 AM
->>To: [email-masked]
->>Subject: TSA certificate content
->>
->>
->>
->>
->>I would like to hear some opinion about the setting
->>of the extension keyUsage in a certificate for a
->>3161 TSA.
->>
->>The question is whether a certificate contain no
->>keyUsage extension at all and only an extended
->>key usage with the appropriate key purpose
->>is conformant with 3161 and 3280.
->>
->>Peter
->>

---

From: Masaki SHIMAOKA <[email-masked]>
Date: Tue, 25 Nov 2003 18:20:50 +0900

Hi Peter,

As the specification actually, I also think that absence of keyUsage is
permissible.

But I wonder why a certificate do not include keyUsage extension, though
the certificate declares extendedKeyUsage.
What kind of situation does it apply in?

I have no idea about the reason to use only extendedKeyUsage extension
for a certificate without using keyUsage extension...

On Mon, 24 Nov 2003 21:40:56 -0500

> is conformant with 3161 and 3280. 

-----
Masaki SHIMAOKA

SECOM Trust.net
System Engineering Dpt.
Tel: +81 422 91 8498 (ext.3605)
Fax: +81 422 45 0536
e-mail: [email-masked]

---

From: "Miguel Rodriguez" <[email-masked]>
Date: Tue, 25 Nov 2003 09:56:59 -0600

I think key usage is not relevant here, can even be absent. The relevant
one is the EKU extension. That's how we do it in our implementation.

Miguel A Rodriguez
SeguriDATA
Mexico

> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Peter Sylvester
> Sent: Monday, November 24, 2003 7:30 AM
> To: [email-masked]

---

From: "Santosh Chokhani" <[email-masked]>
Date: Mon, 24 Nov 2003 21:40:56 -0500

Peter:

-----Original Message-----

Peter