Subject: RE: WG Last Call: Additional Algorithms for RSA cryptography

From: "Manger, James H" <[email-masked]>
Date: Thu, 18 Dec 2003 12:29:21 +1000

Are the ASN.1 values going to be reformatted (to include field names)?
Is the reference to a withdrawn ASN.1 standard going to be changed?

----------
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, 17 December 2003 6:31 AM
Subject: WG Last Call: Additional Algorithms for RSA cryptography

This message initiates working group Last Call for "Additional Algorithms and 
Identifiers for RSA Cryptography". As a reminder, here is the Abstract:

   This document supplements RFC 3279.  It describes the conventions 
   for using the RSASSA-PSS signature algorithm, the RSAES-OAEP key 
   transport algorithm and additional one-way hash functions with the 
   PKCS #1 version 1.5 signature algorithm in the Internet X.509 Public 
   Key Infrastructure (PKI).  Encoding formats, algorithm identifiers, 
   and parameter formats are specified. 

This is a three week Last Call.  That means it will close sometime on or after 
January 9, 2004.   The schedule has been padded with an additional week in 
light of the holidays. 

** Do not count on any further extension to Last Call!!! **

I intend to close Last Call promptly on January 9, since an S/MIME WG document 
is blocked on this document.

The URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pkix-rsa-pkalgs-01.txt

----------
From: Steven Legg [mailto:[email-masked]]
Sent: Thursday, 4 December 2003 3:04 PM

> The changes you are claming as non-compliant are not required for the 1988 version.

But they're not disallowed either. Why use a notation from 1988 which is deprecated by later editions of ASN.1 when there is alternative notation that is valid in 1988 and all later editions of ASN.1. ?

----------
From: Phillip H. Griffin [mailto:[email-masked]]
Sent: Friday, 5 December 2003 12:26 AM

X.208 and X.209 are no longer merely deprecated. They have been withdrawn as international standards since last year.

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 17 Dec 2003 20:13:10 -0800

James,

We will be updating the ASN.1 to use the field names.

We will not be changing the reference to the ASN.1 standard.   If you
believe this is an issue then it needs to be discussed by the IESG and
the Area Directors for the Security Area.  They have not indicated that
this is a change that needs to be made.

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Manger, James H
> Sent: Wednesday, December 17, 2003 6:29 PM
> To: [email-masked]
> Subject: RE: WG Last Call: Additional Algorithms for RSA cryptography
> 
> 
> 
> Are the ASN.1 values going to be reformatted (to include 
> field names)? Is the reference to a withdrawn ASN.1 standard 
> going to be changed?
> 
> 
> ----------
> http://www.ietf.org/internet-drafts/draft->
ietf-pkix-rsa-pkalgs-01.txt
> > The changes you are claming as non-compliant are not 
> required for the 
> > 1988 version.
> 
> But they're not disallowed either. Why use a notation from 
> 1988 which is deprecated by later editions of ASN.1 when 
> there is alternative notation that is valid in 1988 and all 
> later editions of ASN.1. ?
> 
> ----------
> X.208 and X.209 are no longer merely deprecated. They have 
> been withdrawn as international standards since last year.
>