Subject: RE: Legal Notice on RFC3161 Uses and their possible infringement against Glassey/Mcneil Patents(et al).

From: "Vainikainen Saku EINT" <[email-masked]>
Date: Fri, 26 Mar 2004 01:31:10 +0200

Good discussion on patenting "computer-implemented inventions" here in
Europe:

http://europa.eu.int/comm/internal_market/en/indprop/comp/index.htm

Rgrds,
Saku Vainikainen
PKI Specialist

Elisa Corporation
Products / Identity Management
FINLAND

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of todd glassey
> Sent: Thursday, March 25, 2004 11:29 PM
> To: [email-masked]; [email-masked]
> Subject: Legal Notice on RFC3161 Uses and their possible 
> infringement against Glassey/Mcneil Patents(et al).
> 
> 
> Lets talk about legal stuff for a minute... and I don't 
> really need anyone
> to respond to this unless they want to do so with my lawyers.
> 
> ---------------------------------------------------
> 
> Be advised that I am claiming there is an unauthorized 
> identified use of
> RFC3161 that appears to violate parts of the Glassey/McNeil 
> Timestamping
> patent ("Controlling Access to Stored Information" - US 6370629 and EP
> 0997808, et al).  As such, I am formally putting the 
> IETF/IESG on notice
> thereof.
> 
> Further, these same uses may also violate any number of other 
> "Receipt"
> patents issued (including, but not limited to, the original 
> Fisher and Haber
> patents; those of others in the Time Management and in the XML
> Receipt Business), as well as other patents still in the works.
> 
> In light of this notification, please be aware that it is the 
> responsibility
> of the developers to do proper diligence prior to releasing 
> commercial or
> free services using RFC3161 as its base.
> 
> Be advised that we are currently very concerned. If any such RFC3161
> application is used for evidentiary purposes or if it is used 
> to enable
> control of any access to any data, or data in any record structure,
> such use may be in violation of these globally issued patents.
> 
> Obviously, in instances where such violation is evident, we 
> will take swift
> legal steps to protect our patent(s) while preventing any further
> unauthorized use. This would include any violations and 
> damages resulting
> from all those responsible, even National Governments using 
> RFC3161 for
> commercial and audit purposes (including the EU and its 
> member States).
> 
> Please feel free to have the IETF's or IESG's or any other appropriate
> attorney (or Developers wishing to avoid the legal complications of an
> authorized use) contact me regarding this matter for my point 
> of service so
> appropriate licensing can be arranged to protect these 
> patents against such
> infringement involving those Developer's Application Systems .
> 
> Todd Glassey
> Patent Rights Owner and Inventor -US 6370629
> 
>

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Thu, 25 Mar 2004 16:39:01 -0800

Could some remind us which of the claims in Habber/Stornetta were
invalidated during the Entrust lawsuit?

> [mailto:[email-masked]]On Behalf Of todd glassey
> Sent: Thursday, March 25, 2004 4:29 PM
> Subject: Legal Notice on RFC3161 Uses and their possible infringement
> against Glassey/Mcneil Patents(et al).
> 
> 
>

---

From: "Vainikainen Saku EINT" <[email-masked]>
Date: Fri, 26 Mar 2004 02:51:46 +0200

> http://europa.eu.int/comm/internal_market/en/indprop/comp/index.htm

..and even better in here:

http://swpat.ffii.org

Rgrds,
Saku Vainikainen.

---

From: "Vainikainen Saku EINT" <[email-masked]>
Date: Fri, 26 Mar 2004 02:38:03 +0200

Hello all!

Here's some more details on the patent:

http://swpat.ffii.org/pikta/txt/ep/0997/808/

Rgrds,
Saku Vainikainen
PKI Specialist

Elisa Corporation

> [mailto:[email-masked]] On Behalf Of Stephen Kent
> Sent: Friday, March 26, 2004 12:21 AM
> To: [email-masked]
> Subject: Re: Legal Notice on RFC3161 Uses and their possible 
> Folks,
> Attached is the abstract for Todd's latest patent in this 
> area, which he alluded to in his posting to this list.
> 
> Since RFC 3161 makes no mention of using time stamp info for 
> access control, the likelihood of this RFC infringing seems 
> questionable to me, but that, of course is not a legal opinion.
> 
> If Todd wanted to follow established IETF procedure, as per 
> RFC 2606 he should have sent this message to 
> [email-masked]. In fact Todd did post such a message for 
> his previous IPR assertions in this general area, but maybe 
> he didn't feel that such posting had sufficient dramatic effect.
> 
> Steve
> -------
> 
> 
> 
> Controlling access to stored information based on 
> geographical location and  date and time
> 
> Abstract
> 
> Access to stored information by a user is controlled by 
> comparing an actual  geographic position and/or an actual 
> date/time with a geographic region  and/or a date/time 
> interval within which access to the stored information  is 
> authorized. The actual geographic position where the stored 
> information  is located, and the actual date/time can be 
> determined, for example, based  on signals received at a 
> receiver supplying reliable position and time  information, 
> such as a GPS receiver. Access to the stored information is  
> authorized if the actual geographic position and/or date/time 
> falls within  the authorized geographic region and/or 
> date/time interval. The position  and date/time information 
> supplied by the receiver may be  cryptographically signed and 
> encrypted.
>