Subject: Can we make this kind of certificate?

From: "Jaeho Yoon" <[email-masked]>
Date: Sat, 6 Mar 2004 09:31:49 +0900

Dear experts,

I have been studying the PKI in various environment. In doing that, I am troubled with the needs of this kind of certificate.

'a certificate issued by multiple CAs'

for example, RFC3280 certificate is
Certificate = entity dependent field + CA dependent field + Signature(entity+CA field)

this certificate is
Certificate = entity dependent field + [CA1 dependent field + Signature(entity+CA1 field)] + [CA2 dependent field + Signature(entity+CA2 field)] + ... 

At first sight, it may have many problems, ex. path related things.
But in some cases, it would be very useful, I think. 

Can we make this kind of certificate? I'd like to have your opinion.
It is just my curiosity.

Thanks.

---

From: Richard Levitte - VMS Whacker <[email-masked]>
Date: Sat, 06 Mar 2004 08:08:58 +0100 (CET)

In message <[email-masked]> on Sat, 06 Mar 2004 08:03:56 +0100 (CET), Richard Levitte - VMS Whacker <[email-masked]> said:

levitte> In message <002e01c40312$69fe3aa0$810410ac@somethingnew> on Sat, 6 Mar 2004 09:31:49 +0900, "Jaeho Yoon" <[email-masked]> said:
levitte> 
levitte> jhyoon> Dear experts,
levitte> jhyoon> 
levitte> jhyoon> I have been studying the PKI in various environment. In doing
levitte> jhyoon> that, I am troubled with the needs of this kind of
levitte> jhyoon> certificate.
levitte> jhyoon> 
levitte> jhyoon> 'a certificate issued by multiple CAs'
levitte> 
levitte> ...  However, there's nothing stopping you from having
levitte> several certificates, signed by several CAs, from the same
levitte> certificate request.  How that would be handled by software
levitte> is a different question, though...

Note that this idea is probably not recommended, it's something I
pulled from my bag-o'-gags to possibly give you a way to get around to
what you want.  I haven't analysed the effects of such action in any
way, and before rushing to do what I said, I'd give it some extra
careful thought if I were you.  Oh, and for the rest of you on this
list, if what I wrote is truly horrific, feel free to pounce :-).

-----
Please consider sponsoring my work on free software.
See http://www.free.lp.se/sponsoring.html for details.

-- 
Richard Levitte     | http://richard.levitte.org/ | Tunnlandsv. 52
Levitte Programming | http://www.lp.se/           | S-168 36 Bromma
T: +46-708-26 53 44 |                             | SWEDEN
     "Price, performance, quality...  choose the two you like"

---

From: Richard Levitte - VMS Whacker <[email-masked]>
Date: Sat, 06 Mar 2004 08:03:56 +0100 (CET)

In message <002e01c40312$69fe3aa0$810410ac@somethingnew> on Sat, 6 Mar 2004 09:31:49 +0900, "Jaeho Yoon" <[email-masked]> said:

jhyoon> Dear experts,
jhyoon> 
jhyoon> I have been studying the PKI in various environment. In doing
jhyoon> that, I am troubled with the needs of this kind of
jhyoon> certificate.
jhyoon> 
jhyoon> 'a certificate issued by multiple CAs'

Within the framework of X.509, there no such thing.  However, there's
nothing stopping you from having several certificates, signed by
several CAs, from the same certificate request.  How that would be
handled by software is a different question, though...

HTH.  HAND.

-----

---

From: Jean-Marc Desperrier <[email-masked]>
Date: Sat, 06 Mar 2004 11:01:32 +0100

Richard Levitte - VMS Whacker wrote:

>levitte> certificate request.  [...]
>
>[...]  I haven't analysed the effects of such action in any
>careful thought if I were you. [...]
>
It better be correctly interpreted correctly by software, because it's 
susceptible to happen all the time.
This said it can be a cause for problems with Microsoft CAPI that relies 
too much on key based AKI/SKI.

One case were it could happen even if not intented is the earlier 
Gemplus smart card some years ago (the GPK4000  model), that were not 
able to do on-board generation, so they would pretend to generate a key 
and give back always the same one.

Moreover, this case is very similar to cross-certificates.

---

From: Russ Housley <[email-masked]>
Date: Sun, 07 Mar 2004 16:17:32 -0500

X.509 certificates do not have the capacity for multiple signatures, one 
from each of the "issuers."

Russ

At 09:31 AM 3/6/2004 +0900, Jaeho Yoon wrote:
>Dear experts,
>
>I have been studying the PKI in various environment. In doing that, I am 
>troubled with the needs of this kind of certificate.
>
>Certificate = entity dependent field + [CA1 dependent field + 
>Signature(entity+CA1 field)] + [CA2 dependent field + Signature(entity+CA2 
>field)] + ...
>