Subject: XML schema or dtd for X.509?

From: Bob Wheeler <[email-masked]>
Date: Tue, 19 Apr 2005 21:26:58 -0700 (PDT)

Without starting a religious war, does anyone know of existing XML XSD or DTD specifications for X.509 certificates. Ideally, I'm looking for something that tracks closely to X.509 including the standard extensions and their contents. I'd appreciate any references or links to such specifications. I have seen some "toy" descriptions that barely describe basic certificates without any consideration of the standard extensions. Thanks.
 
Bob

---------------------------------
Do you Yahoo!?
 Make Yahoo! your home page

---

From: Steven Legg <[email-masked]>
Date: Wed, 20 Apr 2005 17:29:01 +1000

Bob,

Bob Wheeler wrote:
> Without starting a religious war, does anyone know of existing XML XSD 
> or DTD specifications for X.509 certificates. Ideally, I'm looking for 
> something that tracks closely to X.509 including the standard extensions 
> and their contents. I'd appreciate any references or links to such 
> specifications. I have seen some "toy" descriptions that barely describe 
> basic certificates without any consideration of the standard extensions. 
> Thanks.

I've been working on a set of specifications for XML-enabling LDAP and
X.500 directories:

http://www.ietf.org/internet-drafts/draft-legg-xed-roadmap-03.txt

One aspect of this is a set of XML encoding rules for ASN.1 (RXER),
which allow me to encode any X.500 directory data in XML. This of
course encompasses X.509. Another aspect of more interest to you
is an algorithmic procedure for generating XML Schemas from ASN.1
modules. The XML Schemas validate the RXER encodings. I haven't yet
got around to writing up that procedure but I do have an implementation
of an ASN.1 to XML Schema translator. In time I will be publishing
the XML Schema translations for all the X.500 ASN.1 modules on-line,
but in the meantime I can wrap up my current set of XML Schemas and
send them to you if you are interested.

Bear in mind that this is still a work in progress. The translator
skimps on constraints, though it does handle occurrence constraints.

Regards,
Steven

>  
> Bob
> 
> ------------------------------------------------------------------------
> Do you Yahoo!?
> <http://us.rd.yahoo.com/my/navbar/sethp/*http://www.yahoo.com/r/hs>

---

From: Martin Clausen <[email-masked]>
Date: Wed, 20 Apr 2005 09:51:35 +0200

Take a look at the following project.

http://www.trl.ibm.com/projects/xml/xss4j/docs/axt-readme.html

Med venlig hilsen / Kind regards

Martin Clausen <[email-masked]>
IBM Research GmbH, Zurich Research Laboratory
Säumerstrasse 4 / Postfach, CH-8803 Rüschlikon
Phone: (+41) 1 724 8469 

[email-masked] wrote on 20-04-2005 06:26:58:

> Without starting a religious war, does anyone know of existing XML 
> XSD or DTD specifications for X.509 certificates. Ideally, I'm 
> looking for something that tracks closely to X.509 including the 
> standard extensions and their contents. I'd appreciate any 
> references or links to such specifications. I have seen some "toy" 
> descriptions that barely describe basic certificates without any 
> consideration of the standard extensions. Thanks.
> 
> Bob
> Do you Yahoo!?