Subject: RE: Re: key usage - key encipherment or data encipherment

From: "Simon McMahon" <[email-masked]>
Date: Fri, 20 May 2005 07:50:03 +1000

Sure, but the rewording mentions "RSA" for the public key and doesn't specify anything for the private.

Do asymmetric ciphers often get combined this way in practice? A device would need full implementations of both RSA and elliptic curve to support this.

The example should match typical usage and doesn't have to cover every possibility. The current wording implies RSA.

Simon.

Simon McMahon

Work: (07) 31311420
Mobile: (043) 2294180

>>> <[email-masked]> 05/18/05 12:15am >>>
But, if the asymmetric private key is based on elliptic curves?

Diego

----- Mensaje Original -----
Remitente: "Simon McMahon" [email-masked] 
Destinatario: [email-masked], [email-masked] 
Fecha: Martes, Mayo 17, 2005  1:03am
Asunto: Re: key usage - key encipherment or data encipherment

>
>The example for 'keyEncipherment' should not include an "RSA public 
>key encrypting an asymmetric private key", which, if it is also RSA 
>is too big to encrypt with the public key. Surely, an RFC shouldn't 
>list impossible cases as examples.
>
>Simon.
>

***********************************************************************************
This email, including any attachments sent with it, is confidential and for the sole use of the intended recipient(s).  This confidentiality is not waived or lost, if you receive it and you are not the intended recipient(s), or if it is transmitted/received in error.

Any unauthorised use, alteration, disclosure, distribution or review of this email is prohibited.  It may be subject to a statutory duty of confidentiality if it relates to health service matters.

If you are not the intended recipient(s), or if you have received this email in error, you are asked to immediately notify the sender by telephone or by return email.  You should also delete this email and destroy any hard copies produced.
***********************************************************************************

---

From: Sam Roberts <[email-masked]>
Date: Fri, 20 May 2005 10:19:51 -0400

Wrote Simon McMahon <[email-masked]>, on Fri, May 20, 2005 at 07:50:03AM +1000:
> The example should match typical usage and doesn't have to cover every
> possibility.

It probably isn't "typical", but the TCG uses RSA private keys encrypted
with RSA public keys of the same strength.

IIRC, instead of encrypting d,p-1,q-1,... (which would be too large),
they only encrypt p. The decryptor can recreate the rest of the private
key from the public key and knowledge of p.

Cheers,
Sam

-- 
http://www.certicom.com