Subject: RE: CMS Advanced Electronic Signatures (CAdES)

From: "Stefan Santesson" <[email-masked]>
Date: Mon, 18 Jul 2005 17:10:23 +0100

A question that is relevant to this is any information on to what extent
this standard is actually deployed.

Stefan Santesson
Program Manager, Standards Liaison
Windows Security

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Turner, Sean P.
> Sent: den 18 juli 2005 05:39
> To: 'S-MIME / IETF'
> Cc: 'pkix'
> Subject: RE: CMS Advanced Electronic Signatures (CAdES)
> 
> 
> The question at hand is someone in the working group willing to review
> this
> ID?
> 
> spt
> 
> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On
> Behalf Of Denis Pinkas
> Sent: Wednesday, July 13, 2005 9:20 AM
> To: S-MIME / IETF
> Cc: pkix
> Subject: CMS Advanced Electronic Signatures (CAdES)
> 
> 
> To the S-MIME list,
> 
> 
> Copy: the PKIX list.
> 
> RFC 3126 has been issued in September 2001 and its title is:
> 
> "Electronic Signature Format for long term electronic signatures"
> 
> The contents of this Informational RFC is technically equivalent to
ETSI
> TS
> 101 733 V.1.2.2.
> 
> In the mean time, ETSI TC ESI has revised this Technical Standard (TS)
and
> is going to publish a new version of it with a new title :
> 
> CMS Advanced Electronic Signatures (CAdES), in order to be the
"brother"
> of
> XML Advanced Electronic Signatures (XAdES), published as ETSI TS 101
903.
> 
> In order to make this document widely available, ETSI has produced an
> equivalent of the revised TS using the format of a RFC.
> 
> This document is temporarily available (by a kind hosting from Paul
> Offman)
> from:
> 
> <http://www.imc.org/ietf-smime/TEMP-draft-pinkas-smime-cades-00.txt>
> 
> until is is officially posted in the IETF repository.
> 
> The major changes are mentioned section  J :
> 
>    "The title of the document has changed to be aligned with the title
>    of XAdES, the vocabulary used within the present document has been
>    aligned with the vocabulary used in XAdES,
> 
>    In the previous version of TS 101 733 (i.e. version 1.5.1)
>    sigPolicyHash was mandatory.  Implementations requiring to be
>    backward compatible with version 1.5.1 and previous versions
>    of the current document MUST include SigPolicyHash.
> 
>    The OIDs from the ASN.1 modules have changed for the following
>    reasons:
> 
>     - the OIDs of the ASN.1 modules of RFC 2560 and RFC 3161 have been
>       included.
> 
>     - since RFC 2459 and RFC 3369 has been obsoleted by RFC 3280 and
>       RFC 3852 respectively, there was the need to refer to the OIDs
>       of the ASN.1 modules of RFC 3280 and RFC 3852, instead of the
>       OIDs of the ASN.1 modules of RFC 2459 and RFC 3369.
> 
>     - the other change is related to the field sigPolicyHash from
>       SignaturePolicyId (see clause 5.8.1). That field was mandatory
>       and is now optional."
> 
> It is proposed to progress this document within the S-MIME WG as an
> Informational Standard.
> 
> Denis
> 
> 
>

---

From: "Turner, Sean P." <[email-masked]>
Date: Mon, 18 Jul 2005 12:24:23 -0400

It's intended to be informational so I'm not sure how relevant how deployed
it is an issue.

spt

-----Original Message-----
From: Stefan Santesson [mailto:[email-masked]] 
Sent: Monday, July 18, 2005 12:10 PM
To: [email-masked]; S-MIME / IETF
Cc: pkix
Subject: RE: CMS Advanced Electronic Signatures (CAdES)

Stefan Santesson

> this ID?
ETSI
and
"brother"
903.