Subject: Re: I-D ACTION:draft-ietf-pkix-cert-utf8-01.txt

From: Russ Housley <[email-masked]>
Date: Mon, 03 Apr 2006 15:20:12 -0400

Stephen:

>Couple of comments.
>
>Typo: "PrintiableString" in a couple of places.

I found two places....

>In the case where a string can be representable as a PrintableString is
>an implementation free to use UTF8String if it so desires?

Yes, as long as it does so everywhere to avoid cross encoding 
comparison.  Is there some place that explanation is needed?

Russ

---

From: "Stefan Santesson" <[email-masked]>
Date: Wed, 5 Apr 2006 07:49:57 +0100

I don't feel strongly that a change is necessary but I would not oppose
recommending printable string when it is sufficient.
However I would not like to mandate printable string as it may break
conformant implementations.

Stefan Santesson
Program Manager, Standards Liaison
Windows Security

> -----Original Message-----
> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Russ Housley
> Sent: den 5 april 2006 01:20
> To: Santosh Chokhani; pkix
> Subject: RE: I-D ACTION:draft-ietf-pkix-cert-utf8-01.txt
> 
> 
> Given the strong push in RFC 3280 toward UTF8String, I think raising
> PrintableString to the same level is a significant change.  However,
> if the PKIX WG thinks that your recommendation is appropriate, I am
> not opposed to it.
> 
>  From a process perspective, PKIX WG Last Call is finished.  This
> document is now in IETF Last Call.  So if this is the consensus, the
> comment needs to be made on the IETF mail list.
> 
> Russ
> 
> 
> At 06:03 PM 4/3/2006, Santosh Chokhani wrote:
> 
> >Russ,
> >
> >Given the problems with UTF8 in terms of spoofing, should we not
require
> >or strongly urge the use of printable string when printable string
will
> >suffice?
> >
> >-----Original Message-----
> >From: [email-masked]
[mailto:[email-masked]]
> >On Behalf Of Russ Housley
> >Sent: Monday, April 03, 2006 3:20 PM
> >To: Stephen Henson; pkix
> >Subject: Re: I-D ACTION:draft-ietf-pkix-cert-utf8-01.txt
> >
> >
> >Stephen:
> >
> > >Couple of comments.
> > >