Subject: NIST announces Draft Requirements and Evaluation Criteria for New Hash Algorithms

From: Shu-jen Chang <[email-masked]>
Date: Tue, 23 Jan 2007 12:03:45 -0500

NIST Wants Comments on Proposed Hash Algorithm Requirements and Evaluation 
Criteria

The National Institute of Standards and Technology is planning a 
competition to develop one or more cryptographic hash algorithms to augment 
and revise the current Secure Hash Standard (Federal Information Processing 
Standard 180-2). As a first step in this process, NIST is publishing draft 
minimum acceptability requirements, submission requirements, and evaluation 
criteria for candidate algorithms ( See the Federal Register Announcement 
on http://www.nist.gov/hash-function ), and requests public comment by 
April 27, 2007.

---

From: Shu-jen Chang <[email-masked]>
Date: Tue, 23 Jan 2007 14:01:15 -0500

Thank you for pointing out the mistake. It was correct in the file that we 
sent out, but somehow got messed up in the final publication. Sorry about that.

Shu-jen

At 01:48 PM 1/23/2007, you wrote:
>Hi,
>
>There is an obvious typo:
>
>"A.3 The algorithm must support
>224, 256, 384, and 512-bit message
>digests, and must support a maximum
>message length of at least 264 bits."
>
>Probably it should be:
>
>"A.3 The algorithm must support
>224, 256, 384, and 512-bit message
>digests, and must support a maximum
>message length of at least 2^64 bits."
>
>(Usual copy paste error from Word ...)
>
>Regards,
>Danilo!