Subject: RE: asn.1 modules in 3280bis

From: Stefan Santesson <[email-masked]>
Date: Fri, 2 Feb 2007 11:18:43 +0000

I would like to have the other editors and WG opinion.
If it is positive, then I assume it's a fairly straightforward process if we get to it.

Lets finish this up so we can ship this document.

Stefan Santesson
Senior Program Manager
Windows Security, Standards

> -----Original Message-----
> From: [email-masked] [mailto:owner-ietf-
> [email-masked]] On Behalf Of Russ Housley
> Sent: den 29 januari 2007 18:02
> To: Peter Sylvester; pkix
> Subject: Re: asn.1 modules in 3280bis
>
>
> Peter:
>
> RFC 3280 includes two ASN.1 Modules:
>     PKIX1Explicit88, and
>     PKIX1Implicit88.
>
> I have no objection to using three ASN.1 Modules in 3280bis:
>     PKIX1Explicit88,
>     PKIX1Implicit88, and
>     PKIX1Extensions.
>
> I'm sure that you could help the authors figure out which type
> definitions to move to the third module.
>
> Russ
>
>
> At 09:43 AM 1/29/2007, Peter Sylvester wrote:
>
> >It may be a bit late but I would like to propose a small change RFC
> 3280 bis.
> >
> >The text defines (as well as 3280) two ASN.1 modules. The definitions
> contain
> >two types of information:
> >
> >- rewrites from X.509 etc
> >- new definitions like the id-pkix arc and extensions
> >
> >If one wants to use the new definitions in other specifications here
> is
> >the problem of ASN.1 compatibility when imported into other
> >modules/
> >I propose to add two modules:
> >
> >PKIXUsefulDefinitions which regroups definitions in such a way that
> >they can be imported elsewhere.
> >the syntax definitions for the private extensions. The actual
> >
> >PKIXExtensions in current syntax to use the
> >EXTENSION CLASS to bind the extensions the OIDs.
> >
> >If this cannot be included into the 3280bis I propose a small RFC
> >defining these modules.
> >
> >Peter

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 02 Feb 2007 12:00:36 +0000

I'd be marginally against this change, on the basis
that its so late, might be error prone and I'm not
sure that the claimed benefit is significant (don't
most people just comment out one of the colliding
definitions?).

Having said that, if David (who'd do the work) does
want this, I won't object,
Stephen.

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 2 Feb 2007 09:03:41 -0800

>most people just comment out one of the colliding

I agree with Stephen and Sharon. This could easily be an add-on RFC.

--Paul Hoffman, Director
--VPN Consortium