Subject: Re: Draft response to the liaison from ITU-T SG 17 to IETF on the resolution of DR320

From: "Denis Pinkas" <[email-masked]>
Date: Tue, 4 Dec 2007 13:36:51 +0100

Stefan,

>You are right that this ending was not based on the consensus of the room, but I still think it is reasonable to welcome proposals to be posted to the WG.
>I think that the consensus in the room was that the solution mentioned in the liaison request is totally unreasonable and that we can't see any other solution to the problem worth pursuing.
>
>I practically stole the ending from Sam's proposal on response to the other liaison request.
>It sort of takes the position that if they want something done, they have to propose a mechanism rather than asking us to find one.
>
>But I can remove it also.

There are two options:

a) keep the first two sentences

Yes, the statement is true. IETF does not provide any guidelines to ensure that CA names are unambiguous.
No, it is not possible for the PKIX work group to maintain a list of CA names or similar mechanism that 
would prevent conflict of CA names. 

b) add a third sentence based on your sentence hereabove:

Yes, the statement is true. IETF does not provide any guidelines to ensure that CA names are unambiguous.
No, it is not possible for the PKIX work group to maintain a list of CA names or similar mechanism that 
would prevent conflict of CA names. The solution mentioned in the liaison request is unreasonable and 
the IETF does see such a solution worth pursuing.

I prefer the latter proposal.

Denis

>Stefan Santesson
>Senior Program Manager
>Windows Security, Standards
>
>> -----Original Message-----
>> From: Stephen Farrell [mailto:[email-masked]]
>> Sent: den 3 december 2007 19:38
>> To: Stefan Santesson
>> Cc: [email-masked]
>> Subject: Re: Draft response to the liaison from ITU-T SG 17 to IETF on
>> the resolution of DR320
>>
>>
>>
>> Stefan Santesson wrote:
>> > The
>> > PKIX WG does however welcome and encourage those who would like to
>> > propose useful mechanisms to present them to the PKIX work group.
>>
>> I didn't get a sense in the room today that we would actually
>> welcome a proposal for how to maintain a list of CA names. In fact,
>> I got the opposite impression, i.e. that the people in the room
>> would find such a proposal unwelcome. (All modulo WG participants
>> who weren't in the room of course.)
>>
>> Other than that, I think your text is fine.
>>
>> S.

---

From: Stefan Santesson <[email-masked]>
Date: Tue, 4 Dec 2007 17:17:51 +0000

I'm fine with the latter proposal.

Stefan Santesson
Senior Program Manager

> From: [email-masked] [mailto:owner-ietf-
> [email-masked]] On Behalf Of Denis Pinkas
> Sent: den 4 december 2007 04:37
> To: [email-masked]
> >You are right that this ending was not based on the consensus of the
> room, but I still think it is reasonable to welcome proposals to be
> posted to the WG.
> >I think that the consensus in the room was that the solution mentioned
> in the liaison request is totally unreasonable and that we can't see
> any other solution to the problem worth pursuing.
> >
> >It sort of takes the position that if they want something done, they
> have to propose a mechanism rather than asking us to find one.
> >

---

From: "Sharon Boeyen" <[email-masked]>
Date: Tue, 4 Dec 2007 13:00:11 -0500

I guess this one is a harmless statement but just the first two
sentences is also a valid summary of the discussion I believe. What I
don't want to see is any encouragement for anyone to initiate activity
of that sort in PKIX - I do believe it is outside the scope. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Stefan Santesson
Sent: Tuesday, December 04, 2007 12:18 PM
To: Denis Pinkas; [email-masked]
Subject: RE: Draft response to the liaison from ITU-T SG 17 to IETF on
the resolution of DR320

Stefan Santesson
Senior Program Manager

> No, it is not possible for the PKIX work group to maintain a list of 
> CA names or similar mechanism that would prevent conflict of CA names.
>
> No, it is not possible for the PKIX work group to maintain a list of 
> CA names or similar mechanism that would prevent conflict of CA names.

> The solution mentioned in the liaison request is unreasonable and the 
> IETF does see such a solution worth pursuing.
>
> >> > PKIX WG does however welcome and encourage those who would like 
> >> > to propose useful mechanisms to present them to the PKIX work
group.

---

From: Stephen Kent <[email-masked]>
Date: Tue, 4 Dec 2007 12:59:31 -0500

Folks,

If no one objects, I will take responsibility for composing the 
response to the DR, based on the comments we have seen on the mailing 
list. I will then send it out for review and approval by the WG, then 
Stefan and I will forward this to Russ, for transmission to ITU-T.

Steve