Subject: [pkix] Is there a SW standard to validate private key protection?

From: Roberto Opazo <[email-masked]>
Date: Thu, 10 Mar 2011 16:52:22 -0300

Hello:

A have the hope this community will have an answer to this question:

Is there a SW standard to validate private key protection?

Something like FIPS-140-2 level 2, but just software. A check list like:

* Private key is generated in the software private key container.

* There are no API to export private key from the PKC. No backup or
other export functions, so the certificate subject can trust he is the
only one on possession of the private key.

* Private key container implements a cryptographic protection on
private key to avoid unauthorized access.

-- 
Best regards,

Roberto Opazo

---

From: Anders Rundgren <[email-masked]>
Date: Thu, 10 Mar 2011 21:21:45 +0100

Roberto,

I'm pretty sure that there is no standard for this because
SW key protection doesn't actually say anything.

If the key is owned by the user process it might be copied
and exposed to various attacks.

If the key is owned by a kernel process or similar the protection
is probably as strong as the protection of the kernel is.

If you have HW access you may run a CPU emulator like JTAG and
then you have no protection as at all.

So the only thing you could do is to list the vulnerabilities
which is quite difficult unless you are an expert on the actual
operating system.

Regards,
Anders Rundgren

---

From: "Miller, Timothy J." <[email-masked]>
Date: Thu, 10 Mar 2011 15:21:56 -0500

> Is there a SW standard to validate private key protection?

There's no *software-only* way to protect a private key on an *untrusted, untrustable, general purpose computer*.   Once the key's in memory it's fair game to anything with the access rights.

-- Tim