Subject: Re: [pkix] [Technical Errata Reported] RFC5914 (2667)

From: Sean Turner <[email-masked]>
Date: Wed, 09 Mar 2011 09:04:52 -0500

Any objection to accepting this one?

spt

On 12/9/10 7:14 PM, RFC Errata System wrote:
> The following errata report has been submitted for RFC5914,
> "Trust Anchor Format".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=5914&eid=2667
>
> --------------------------------------
> Type: Technical
> Reported by: Jim Schaad<[email-masked]>
>
> Section: A.1
>
> Original Text
> -------------
>     PKCS7-CONTENT-TYPE ::= TYPE-IDENTIFIER
>
>     trust-anchor-list PKCS7-CONTENT-TYPE ::=
>         { TrustAnchorList IDENTIFIED BY id-ct-trustAnchorList }
>
>
>
> Corrected Text
> --------------
> INSERT INTO IMPORTS SECTION before the final semi-colon
>
>     CONTENT-TYPE
>     FROM CryptographicMessageSyntax-2009 -- from [RFC5911]
>        { iso(1) member-body(2) us(840) rsadsi(113549)
>        pkcs(1) pkcs-9(9) smime(16) modules(0)
>        id-mod-cms-2004-02(41) }
>
>
>
>
> REPLACE ABOVE TEXT WITH
>
>     trust-anchor-list CONTENT-TYPE ::=
>         { TYPE TrustAnchorList IDENTIFIED BY id-ct-trustAnchorList }
>
>
>
> Notes
> -----
> The content type is designed to be placed into a CMS SignedData object.  Since the exact same class definition (not a syntaxically identicial one) needs to be used to get object sets to work correctly, the defintion of the content type must be updated to reference the identical one defined in the CMS module.
>
> A future version should additionally note that the content type is to be added to the ContentSet object set in the CMS module.
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC5914 (draft-ietf-pkix-ta-format-04)
> --------------------------------------
> Title               : Trust Anchor Format
> Publication Date    : June 2010
> Author(s)           : R. Housley, S. Ashmore, C. Wallace
> Category            : PROPOSED STANDARD
> Source              : Public-Key Infrastructure (X.509)
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Carl Wallace <[email-masked]>
Date: Wed, 09 Mar 2011 09:13:18 -0500

This one has the definition that is missing in the other one.  Paste
CONTENT-TYPE before the import in the other errata and both seem fine to
me (will test compile them sometime next week).

On 3/9/11 9:04 AM, "Sean Turner" <[email-masked]> wrote:

>> The content type is designed to be placed into a CMS SignedData object.
>> Since the exact same class definition (not a syntaxically identicial
>>one) needs to be used to get object sets to work correctly, the
>>defintion of the content type must be updated to reference the identical
>>one defined in the CMS module.
>>
>> A future version should additionally note that the content type is to
>>be added to the ContentSet object set in the CMS module.
>>
>> Instructions:
>> -------------