Subject: [pkix] Fwd: New Version Notification for draft-pritikin-est-02.txt

From: Max Pritikin <[email-masked]>
Date: Thu, 21 Jul 2011 16:03:34 -0600

Folks,

I very much appreciate the time and comments received from folks on this list concerning earlier versions. Although I'm sure all issues have not yet been addressed I think this version of the document is a step forward. I'll be in Quebec City for the first couple days and look forward to further feedback during the monday session.

This version is slightly restructured to make the concepts clearer and I recommend at least skimming the introduction and reading the table-of-contents. In particular Figure 1 should help orient new readers. 

draft-pritikin-est-02:
> Abstract
> 
>    This document specifies a protocol for certificate Enrollment over
>    Secure Transport (EST).  EST is a certificate enrollment protocol
>    that operates over HTTPS, and thus should be trivially accessible by
>    modern clients.  The Certificate Management over CMS (CMC) "Simple
>    PKI Request" and "Simple PKI Response" messages are leveraged.  EST
>    is designed to be easily implemented by clients and servers running
>    other common enrollment mechanisms such as Simple Certificate
>    Enrollment Protocol (SCEP).  Renewal and rekey mechanisms are
>    described consistent with Certificate Management Protocol (CMP).

Thanks,

- max

Begin forwarded message:

> From: [email-masked]
> Date: July 11, 2011 3:50:20 PM MDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for draft-pritikin-est-02.txt
> 
> A new version of I-D, draft-pritikin-est-02.txt has been successfully submitted by Max Pritikin and posted to the IETF repository.
> 
> Filename:	 draft-pritikin-est
> Revision:	 02
> Title:		 Enrollment over Secure Transport
> Creation date:	 2011-07-11
> WG ID:		 Individual Submission
> Number of pages: 25
> 
> Abstract:
>   This document specifies a protocol for certificate Enrollment over
>   Secure Transport (EST).  EST is a certificate enrollment protocol
>   that operates over HTTPS, and thus should be trivially accessible by
>   modern clients.  The Certificate Management over CMS (CMC) &quot;Simple
>   PKI Request&quot; and &quot;Simple PKI Response&quot; messages are leveraged.  EST
>   is designed to be easily implemented by clients and servers running
>   other common enrollment mechanisms such as Simple Certificate
>   Enrollment Protocol (SCEP).  Renewal and rekey mechanisms are
>   described consistent with Certificate Management Protocol (CMP).
> 
> 
> 
> 
> The IETF Secretariat

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 22 Jul 2011 00:57:46 +0200

Max, I won't bother you more.  I just wanted to say I'm unconvinced
that a new enrollment protocol that does not

- have browser bindings like Apple's iPhone SCEP
- support container-based sessions
- provide key attribute data like PINs

is what the market is waiting on.

I still wish you good luck!

Anders

On 2011-07-22 00:03, Max Pritikin wrote:
> _______________________________________________
> pkix mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pkix
>