Subject: [pkix] [Technical Errata Reported] RFC3739 (3108)

From: RFC Errata System <[email-masked]>
Date: Mon, 6 Feb 2012 05:50:22 -0800 (PST)

The following errata report has been submitted for RFC3739,
"Internet X.509 Public Key Infrastructure: Qualified Certificates Profile".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=3739&eid=3108

--------------------------------------
Type: Technical
Reported by: Loïc Etienne <[email-masked]>

Section: C.1.1.1.

Original Text
-------------
GeneralizedTime : "197110141200Z"

Corrected Text
--------------
GeneralizedTime : "19711014120000Z"

Notes
-----
X.690
11 Restrictions on BER employed by both CER and DER
11.7 GeneralizedTime
11.7.2 The seconds element shall always be present.

In rfc 3739, C.3 DER-encoding, the second-zeroes are present:
... ..313937 31313031 34313230 3030305A ...
They are just missing in the string representation above.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3739 (draft-ietf-pkix-sonof3039-06)
--------------------------------------
Title               : Internet X.509 Public Key Infrastructure: Qualified Certificates Profile
Publication Date    : March 2004
Author(s)           : S. Santesson, M. Nystrom, T. Polk
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Sean Turner <[email-masked]>
Date: Wed, 08 Feb 2012 10:44:51 -0800

On 2/8/12 10:19 AM, Stephen Kent wrote:
> At 5:50 AM -0800 2/6/12, RFC Errata System wrote:
>> Reported by: LoÔc Etienne <[email-masked]>
>>
>> Section: C.1.1.1.
>>
>> Original Text
>> -------------
> Seems like a valid catch of a typo to me.

I agree. If you look at 5280 it says the following about generalized time:

5280 req:       YYYYMMDDHHMMSSZ
original text:  197110141200Z
corrected text: 19711014120000Z

I'm going to go ahead and mark this one as verified.

spt

---

From: Stefan Santesson <[email-masked]>
Date: Wed, 08 Feb 2012 19:43:15 +0100

Agreed

/Stefan

On 12-02-08 7:19 PM, "Stephen Kent" <[email-masked]> wrote:

>Steve

---

From: Stephen Kent <[email-masked]>
Date: Wed, 8 Feb 2012 13:19:05 -0500

Steve