Subject: [pkix] [Technical Errata Reported] RFC5912 (3130)

From: RFC Errata System <[email-masked]>
Date: Sun, 19 Feb 2012 09:30:34 -0800 (PST)

The following errata report has been submitted for RFC5912,
"New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5912&eid=3130

--------------------------------------
Type: Technical
Reported by: Russ Housley <[email-masked]>

Section: GLOBAL

Original Text
-------------
  ct-foo CONTENT-TYPE ::=
      { FooType IDENTIFIED BY id-ct-foo }

Corrected Text
--------------
  ct-foo CONTENT-TYPE ::=
      { TYPE FooType IDENTIFIED BY id-ct-foo }

Notes
-----
Of course, 'ct-foo', 'FooType', and 'id-ct-foo' need to be replaced as appropriate for the use of CONTENT-TYPE in RFC 5912.  CONTENT-TYPE is imported from a module defined in RFC 5911, and errata 2612 makes a change to that definition.  Therefore, 'TYPE' needs to be added each time a content type is defined to align with errata 2612.

The definitions that need to be updated are:
   ct-encKeyWithID,
   ct-scvp-certValRequest,
   ct-scvp-certValResponse,
   ct-scvp-valPolRequest,
   ct-scvp-valPolResponse,
   ct-PKIData, and
   ct-PKIResponse.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5912 (draft-ietf-pkix-new-asn1-08)
--------------------------------------
Title               : New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)
Publication Date    : June 2010
Author(s)           : P. Hoffman, J. Schaad
Category            : INFORMATIONAL
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: "Jim Schaad" <[email-masked]>
Date: Sun, 19 Feb 2012 10:37:26 -0800

I agree that this is a correct Errata - we should have done it when errata
2612 was reported for RFC 5911 and we apparently missed it.

Jim

> -----Original Message-----
> From: RFC Errata System [mailto:[email-masked]]
> Sent: Sunday, February 19, 2012 9:31 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Technical Errata Reported] RFC5912 (3130)
> 
> 
> The following errata report has been submitted for RFC5912, "New ASN.1
> Modules for the Public Key Infrastructure Using X.509 (PKIX)".
> 
> Of course, 'ct-foo', 'FooType', and 'id-ct-foo' need to be replaced as
> appropriate for the use of CONTENT-TYPE in RFC 5912.  CONTENT-TYPE is
> imported from a module defined in RFC 5911, and errata 2612 makes a
> change to that definition.  Therefore, 'TYPE' needs to be added each time
a
> content type is defined to align with errata 2612.
> 
> This errata is currently posted as "Reported". If necessary, please use
"Reply
> All" to discuss whether it should be verified or rejected. When a decision
is
> reached, the verifying party (IESG) can log in to change the status and
edit
> the report, if necessary.
> 
> Title               : New ASN.1 Modules for the Public Key Infrastructure
Using
> X.509 (PKIX)